Previous 1 2 Next 24 Replies Latest reply: Mar 23, 2012 4:21 PM by mhie
wolfgang.werner Level 1 Level 1



I have installed Lion on my MBP. After the first reboot, a grey screen with login fields appears. Filling in my username and password - nothing happens...


The 'progress indicator' runs and runs and runs


I tried

- to boot up in verbose mode - no failure indicator

- to boot in single user mode, performing fsck - no error

- to login with apple remote desktop - no connect

- to login with ssh - deamon runs, but my login credentials are not accepted

- to login as normal user in single user mode - password not accepted


Help, please!


Thanks, W.

MacBook Pro, Mac OS X (10.7), Login Error after Install
  • reddog708 Level 1 Level 1

    I dont know if this will help you but i havent gotten any decent help and i have a similar problem, but this worked for me:


    I opened terminal from recovery mode (holding option on restart) and typed resetpassword. This allowed me to access root, which wasn't showing up during login. I reset the password and permissions options for root and restarted. Now there is a new icon for "other users" which allows me to enter root and log in. This gets me into the OS as root.

  • ecocode Level 1 Level 1



    I have exactly the same problem here on my mbp. Gona try the root login also..

  • R13ckJ Level 1 Level 1

    Having same problem. Spent an hour on phone to Apple yesterday and no one could help. Supposed to get call back from supervisor, nothing. Spent three hours restoring from Time Machine only to find entire Desktop folder missing. Contained hundreds of files, can't find them in any Time Machine backup. Called them again today, another hour wasted. Told me to phone back in two hours when it's quieter. Hours wasted, "backed up" files lost and one very very angry customer. Would love to know how Apple are going to compensate me for this... Lion only £20.99 but could end up costing you £1000s!

  • ecocode Level 1 Level 1

    Don't panic. Your files ain't gone.

    Click on the link on this page (at the top) under 'more like this' called 'can't login aft lion upgrade'.

    I did the root login and recreated my account. Everything is back now.




  • wwerner Level 1 Level 1

    Thanks for the hint with password recovery.


    After digging around for some time, I checked the console.log and found several error messages (mostly startup items / launchd. After removing those... still the same.


    I decided to give a fresh clean install to the machine and recovered my files from my time machine backup.


    Thanks to all.





  • R13ckJ Level 1 Level 1

    Thanks, that helps with Lion. I'm going to stick with 10.6 for now though - from all other problems I've been hearing about Lion doesn't sound production ready. The main problem now is after "restoring" my Desktop folder, that Time Machine was supposed to back up, is gone. Days of work and precious photographs lost :(

  • mehdimehdi Level 1 Level 1

    So I think I solve the exact same issue by doing the following:

    • restart in recovery mode (holding the option key while booting)
    • run resetpassword in the terminal for root
    • logging out, and logging back in as root
    • going to system preferences to create an account with the exact same username as what I had previously
    • then it asks you if you want to use the same user folder, say yes.
    • logout and log back in with the original username and your desktop should be back.

    That worked for me. I think I lost some of my Desktop's files but that was not too important for me...

  • Sam VanDerlip Level 1 Level 1

    I was having this problem too - tried booting into the recovery partition by holding down the option key at startup and resetting my password, setting the root password...but none of that worked.


    For me the only solution that eventually worked was to re-install Lion from the recovery partition - after I did that it acknowldeged my password change and I was able to log in using my own account....

  • Kris Lakshmanan Level 1 Level 1

    I had similar issue also, login keeps spinning after Lion install. Worked with Genius Bar folks (they had to get 2-3 Genius' involved) at the Apple Store.  They went thru single usermode startup, deleted the DB file from the /var/db/AppleSetupDone.db (?).  Went thru terminal program from Recovery Disk to create the original login user and map to the users/<originalname> file.   After that it came up okay.  The keychain file password seems to have gone in the process but other than that all is normal so far.

  • andrewfrombuxton Level 1 Level 1

    I have same issue, utter disaster as I can't login with any user and there's no recovery option either for some reason - so much for internet recovery. No single-user mode as I have an EFI password and I can't remove the EFI password until I get into the OS ! This is on a 2011 MBP so you'd expect it to be seamless.


    I discovered, if I boot with an Ubuntu 11.04 CD, I can mount the filesystem read-only and then copy off all of my user files to a USB drive so don't panic if you can't recover and you don't have backups.


    This is my first experience with Mac OS X upgrading and I'm not very impressed with the quality. I've done many Ubuntu over the air upgrades and never any issues as serious as this that would require a re-install.

  • léonie Level 10 Level 10
    Photos for Mac

    wolfgang.werner wrote:


    I tried

    - to boot up in verbose mode - no failure indicator

    - to boot in single user mode, performing fsck - no error

    - to login with apple remote desktop - no connect

    - to login with ssh - deamon runs, but my login credentials are not accepted

    - to login as normal user in single user mode - password not accepted


    Help, please!


    Thanks, W.

    It seems, the only thing you have not tried so far is booting in safe mode.

    That was the solution that worked for me in the same situation. In safe mode I could log in and disable all start up items and deinstall all my "haxies".  After that I could log in normally with out problems.

  • R13ckJ Level 1 Level 1

    I used a solution that I think's been mentioned before. From my unreliable memory...


    - Boot using Command + R

    - Launch Terminal

    - Type passwordreset and hit enter

    - Select drive that user account's on

    - Reset password for root if your account's not available

    - Reset ACL

    - Exit open apps and restart

    - Login as root

    - Go to System Prefences

    - Create new user account with same username as before

    - Should get message saying something like, "Folder already exists would you like to use it?"

    - Accept

    - Logout

    - Your old login should now work but with whatever password you used to recreate account


    Worked for me

  • macmicke Level 1 Level 1

    Just wanted to add my voice to the group.. I have the same problem... Allmost. The root solution doesnt work, safe boot doesnt work. I am now in the process of doing a second backup before attempting clean install and timemachine reinstall..

  • UKenGB Level 2 Level 2

    I am also having a login problem, but what is not clear from what has previously been said here is whether the original account is still there after the upgrade and it simply can't accept the password, or if it seems ot have 'lost' the account even though its home folder is still there.


    So, when you login as root and then use System Prefs to create a new account with the same name etc, is that original account actually visible in the list of accounts? IOW, is it just confused over the authentication or has it 'forgotten' the user account?

Previous 1 2 Next