Previous 1 2 3 Next 31 Replies Latest reply: Feb 10, 2012 5:17 AM by smiff
ichilton Level 1 (0 points)

Hi,

 

I've just installed the Lion release from the App Store on my 17" MacBook Pro (2010).

 

About 5 minutes after boot, the keyboard stops working.

 

It will respond to ctrl-num to switch spaces but will not respond to any normal keystrokes in any app or system dialog (including the login password entry).

 

Tried an external keyboard and that doesn't work either.

 

Only option is to turn off, turn back on and it will work for a few minutes before stopping again.

 

Any ideas?

 

Thanks,

 

Ian


MacBook Pro, Mac OS X (10.7)
  • skolchevski Level 1 (0 points)

    I have the same problem, but in my case the external bluetooth keyboard is working

  • danny54321 Level 1 (0 points)

    I have same problem with apple usb keyboard on lion, it stops working couple of times, just volume buttons is working.

    i did user log-out, and then it worked.

  • russlunn Level 1 (0 points)

    same here on a MBP 15" i5

     

    built in keyboard totally tonto. needs reboot to fix.

  • skolchevski Level 1 (0 points)

    ok resetting the PRAM fixed the issue for me

  • ichilton Level 1 (0 points)

    Hi,

     

    I tried resetting the PRAM but it didn't help.

     

    In the end, a clean install from DVD fixed pretty much all my issues!

     

    Ian

  • regnauld Level 1 (0 points)

    Just FYI, I think this is the same problem as: https://discussions.apple.com/thread/2161076?start=255&tstart=0 (SnowLeopard).

     

    Might want to check out http://reviews.cnet.com/8301-13727_7-10361439-263.html as well.

  • andreionut Level 1 (0 points)

    This is an issue with Spaces and it happens when you use the keyboard shourtcuts to switch spaces. I have the same problem on SL and Lion.

    It's not related to the time the Mac is on.

     

    Did anybody sent a bug report to Apple about this?

  • Jalien21 Level 1 (0 points)

    I have a similar problem. The keyboard stops working (except that I can still switch between my spaces/desktops with ctrl+arrow keys). I notice that it happens more frequently when I'm running VMware Fusion.

     

    I've got to say: I've noticed way, way more bugs and problems in Lion than any other Apple product that I've ever bought. I hope it's not indicitive of things to come. People pay a premium for Apple products because they 'just work.'

  • SebTT Level 1 (0 points)

    +1 on this issue. Same problem with my 2009 MBP and it's very annoying as I use my computer to work. I don't want to disable Mission Control as it's really useful to me. I hope this will be fixed soon.

  • SebTT Level 1 (0 points)

    For me it seems that it can be related to DisplayLink. Similar issues are reported on DisplayLink support forum http://displaylink.org/forum/showthread.php?t=935&page=6

     

    I'm using DisplayLink 1.7 beta 3, which is the latest release available compatible with Lion.

  • Gary O Level 1 (0 points)

    Having the same issue here on a new 11" macbook air with Lion installed. I don't use the number shortcuts for switching spaces, always use control and the arrow key. Hitting Shift+Control+Eject Key seems to reset the keyboard, but it will lock up again in a few minutes.

  • Syndicateofnoise Level 1 (0 points)

    This is definitely a Spaces/Mision Control-related issue - I disabled the keyboard shortcuts and the issue goes away. Of course this is not a solution as I need keyboard shortcuts to be productive.

     

    I think it has something to do with the control key being mapped to multiple functions. This issue cropped up for me only after upgrading to Lion. When I upgraded to Lion for some reason the left control key took on the same function as the "Application Windows" function in Mission Control (which is assigned by default to F10). I went into the Keyboard shortcuts settings and can't see where the left control key is being mapped so I can't remove it. I think for me this is the cause of the spaces keyboard shortcut issue - something in the system is grabbing onto the left control key function and fighting with Mission Control when I hit control-1 or control-left to switch desktops. When this happens the keyboard no longer responds to most keypresses and I have to kill the dock to restore functionality.

     

    If anyone else could confirm that their left control key is invoking the "Application Windows" function I think we can narrow down the issue and possible come up with a solution. Please report back and I'll do the same. Also, Apple, please take onus and address this issue as I believe it's not related to third-party software.

  • Syndicateofnoise Level 1 (0 points)

    Just a quick update - for me the issue appears as a result of the 1.7b3 DisplayLink driver as well. I uninstalled the driver and re-enabled the Mission Control keyboard shortcuts and everything appears to be working so far. I'll update this post if anything changes.

  • SebTT Level 1 (0 points)

    No issue in 10 days since I uninstalled Display Link software and I using my MBP almost 10 hours each days! Sounds like a solution!

Previous 1 2 3 Next