Previous 1 2 3 4 Next 48 Replies Latest reply: Feb 23, 2012 5:00 AM by pips7000 Go to original post
  • Tim Kilburn Level 1 Level 1 (20 points)

    The first time I unchecked the box in System Prefs, Safari did not change its behaviour.  I then changed the Recent Applications pop-up to None and then Safari worked as before.  I've since changed the Recent Apps back to 10 and Safari still acts as before and opens the Home page upon startup.  This whole "Opening the last windows" thing in Safari was causing me a huge problem last night as I had gone to a site that had redirected me to a spam sort of site that was hanging Safari.  I would Quit Safari but end up right back there when starting Safari.  It was like an infinite loop that I couldn't get easily out of.  I'm not particularly fond of this behaviour in safari or any other app for that matter.  The fixes mentioned in previous posts with some tweaking does appear to fix this though.  I would rather this be a manageable setting within Safari Prefs instead of being a global change in System Prefs.

  • jeffreyfrommanassas Level 1 Level 1 (10 points)

    This is a new "feature" in Lion. It is designed to prevent you from losing your work and to restore you to where you left off working. This feature is great for apps where you are creating some type of content. However, this "feature" is absolutely terrible in Safari. If a user manually Quits Safari he or she is showing obvious intent and Safari should not restore to its previous state. It is not a bug specifically but i do think it is an oversight in practical usage. I cannot think of one scenario where i would want to save my Safari tabs and windows yet Go through the process of manually QuitIng Safari. Pretty sure Apple will either change this feautre in Safari or give the user the ability to disable it within Safari.

  • LKBLKB Level 1 Level 1 (0 points)

    Where is the "Recent Apps" to set as you described. I am so frustrated with this new Safari behavior too! I want Safari to open always to my home page, as I have set it, and it keeps opening with all of my past tabs, even when I clear the cache and start over.

  • mystroh Level 1 Level 1 (0 points)

    I totally agree.

     

    I also found the following simple solution.  Maybe it will work for others.  Without changing any preferences anywhere , simply close Safari windows first (the red close window button) and then close Safari.  When reopening it then goes to homepage as expected.

  • LKBLKB Level 1 Level 1 (0 points)

    Pappasbike, I don't see the option in the Preferences/General pane to uncheck for Safari to open to last viewed pages. I have a Mac, obviously. Can you be more specific as to where I can find this?

  • Brother Geronimo Level 1 Level 1 (0 points)

    Is there any way to eliminate this problem while I'm running Snow Leopard?

  • Tim Kilburn Level 1 Level 1 (20 points)

    Both the Recent Applications pop-up and the Restore Windows options are in the General pane of System Prefs.  There are pop-ups for Recent Apps, recent Documents and Recent Servers.  All I needed to change was the Recent Apps to None.

  • LKBLKB Level 1 Level 1 (0 points)

    Neither of these items appears in the General page of my System Prefs, if you are talking about Safari Preferences. Here is a screen shot of my General Pane. What am I missing here?

     

     

     

     

    Screen shot 2011-07-25 at 12.30.43 PM.png

  • Tim Kilburn Level 1 Level 1 (20 points)

    It's not in Safari Preferences.  You need to go under the Apple to system Preferences and click on the General button.  As well, this is only relevant for Lion.

  • Pappasbike Level 3 Level 3 (560 points)

    LKBLKB wrote:

     

    Pappasbike, I don't see the option in the Preferences/General pane to uncheck for Safari to open to last viewed pages. I have a Mac, obviously. Can you be more specific as to where I can find this?

    Correct, it's not under Safari preferences. It's in System Preferences, that gear box looking thing, under General toward the bottome - Reopen Windows When Quitting, etc. Uncheck that. Again that option is probably only in Lion.

  • LKBLKB Level 1 Level 1 (0 points)

    I'm really sorry and I'm really frustrated. I still don't see what you are talking about. Here is a screen shot of the System Preferences on my Mac. I am a sophisticated user of the Mac and computers in general, so it's quite frustrating to have someone offer what is probably really useful information, yet I can't seem to see it! Where in System Preferences is this area you are talking about? Thanks!

     

    Screen shot 2011-07-25 at 2.18.12 PM.png

  • RandomPhil86 Level 1 Level 1 (0 points)

    I have found the option to turn the feature off, however this removes the feature from every application.

     

    I dont want to do that, I like the feature just not in Safari when I have intended to close Safari by completly closing down the program.

     

    Hopfully Apple update this feature slightly.

  • Pappasbike Level 3 Level 3 (560 points)

    You must not be using Lion. Where you're seeing Appearance on your system preferences, Lion now shows General with that option. I'm not aware of any way to deal with this without Lion. You may have to just wait until there is a general update to Safari. Other than going to Safari preferences and playing around with the settings there a little, there may be nothing else you can do but wait.

  • Coyas Level 1 Level 1 (0 points)

    Check what Mr. Peterfromkalmar said a few comments above... Problem solved!

  • Tim Kilburn Level 1 Level 1 (20 points)

    In Snow Leopard, use Safari Prefs and change the New Windows Open With pop-up to Homepage.  I've tested this on an SL machine and it works as it should.  for more info, you can look on the first page of responses in this thread.