Previous 1 2 3 4 Next 48 Replies Latest reply: Feb 23, 2012 5:00 AM by pips7000 Go to original post
  • rick28 Level 1 Level 1 (0 points)

    I agree with all I am running Lion and Sarfari 5.1 and I have done everything mentioned and everytime I open Sarfari it comes up with the last page I viewed.  I cannot get it to open to my homepage.....

  • Randalu Level 1 Level 1 (0 points)

    Thank you, this has been driving me crazy as well!

  • Doug Guillot Level 1 Level 1 (0 points)

    Have you tried ALT+CMD+Q instead of CMD+Q? Works everytime.

  • Doug Guillot Level 1 Level 1 (0 points)

    Try ALT+CMD+Q instead of CMD+Q. Works every time. On all apps displaying this behavior.

  • lepremier Level 1 Level 1 (0 points)

    Try this, I found it on another forum...


    open Safari to your homepage and quit it. then go to ~/Library/Saved Application State/ and lock and then Safari should always open to the state that you just locked


    note: to lock a file/folder right click it and choose Get Info (or select it & press command+I) and then click "Locked" in the info window.

  • Othon Leon Level 1 Level 1 (5 points)

    This is so frustrating. Why does Apple change things that worked perfectly well? Since I changed to Lion, when I open Safari, sometimes it opens in the last page I was in... some others (as it should) it opens to the Homepage I set.


    Question: Is there a way to make Safari open EVERY TIME, to the pre-established Homepage?

  • amyw716 Level 1 Level 1 (0 points)

    Othon -- I think you need to read this thread from the beginning.  The solutions were mentioned and DO work by going into System Preferences.  Worked for me in Lion.  Now opens every time to my home page.

  • amyw716 Level 1 Level 1 (0 points)

    Rick -- did you ever get it fixed?  We seem to be running the same systems.


    Click the System Preferences in your dock.

    Then click General

    Under "Number of Recent Items", UNcheck the box that says "Restore windows when quitting and re-opening apps".


    Now, every time I close Safari 5.1 by using the red "x", it opens to my set home page.  You have to have your home page set in Safari: Preferences: General: Home Page:  I'm sure you've done this, correct?


    I'm a brand-spankin' new Mac user....if *I* can do this -- anyone can!  Trust me!  LOL 



  • Othon Leon Level 1 Level 1 (5 points)

    Thanks Amyw716, I did it and it's working well now...

  • amyw716 Level 1 Level 1 (0 points)

    Awesome, Othon -- great news!  This "new Mac" experience is maddening for me.  Am sure I will grow to love it.  But in the meantime, glad to have a forum like this to read and learn from!  Have a nice weekend! 

  • RagingTempest Level 1 Level 1 (0 points)

    So far Alt+Command+Q is the only thing that works for me. I unchecked in general settings, and my safari settings. Any other ideas for persisting problems?

  • ROGERHUMPHRIES Level 1 Level 1 (0 points)

    I was experiencing the same problem and thought it was a Mac thing. Come to find out, somehow the permissions on my preference panes was not letting me save anything. I was having trouble saving anything on my Mac. So, you might try this, it finally solved all my problems. First, so that you know you are in the right Library. Go up to your Finder and click on preferences. Next, click on the "sidebar" and then scroll down the list and click on the "Hard Discs", your Machintosh HD will now be in your Finder Window List down under devices. Click on that and go to Library. Do not go to the Library in the System folder. Now highlight the Libraray folder, do not open it, and then go up to the Finder and go to File, scroll down to Get Info. Look at the bottom and see what permissions you have. If it says you only have read only permission, then you have to make some changes. First you have to unlock the window. Click on the lock, lower right and put in your computer password. That should open the lock.  Then click the + at the bottom and add Administrator to the list, unless Admin is already there. If it is, then highlight that and click on the gear to "Apply to enclosed items". I also did it for my Users folder under Machintosh HD window as well because some things got munged up in there as well. Lock the lock and go back to everything and make you changes and see if they don't stick now.

    Really hope this helps a lot of you.


  • check171 Level 1 Level 1 (0 points)

    In Safari Preferences, you must actually press enter for the desired home page - as long as it is still highlighted in blue (such as the screenshot someone posted), it hasn't actually been entered yet. Once the blue disappears and the desired url remains, all is well and the correct homepage opens correctly with every window, rather than the last url visited.

  • Buzzknit Level 1 Level 1 (0 points)

    It worked and thanks so much - good job!!!  Things are right with my mac now and the fix was so easy!

  • Alfonso Lebron-Berges Level 1 Level 1 (0 points)

    Using Lion.


    None of the advices worked.


    Thanks for your help. Problem SOLVED!!!


    I did switch to Firefox. Period!



    P.D. Lion is to Mac OS what Vista was for Windoze. Piece of crap!!!