Previous 1 2 3 4 Next 48 Replies Latest reply: Feb 23, 2012 5:00 AM by pips7000 Go to original post
  • ZX48 Level 1 Level 1 (0 points)

    Thanks Lepremier. I like to set Safari to launch with the homepage, but open new pages with the Same Page.

     

    One thing to note: your solution doesn't work if you have already unchecked the Restore windows option under General in System Preferences. Why not? Becasue when I quit Safari the savedState folder is deleted if this is unchecked.

     

    So: You must have the Restore Windows option checked in System Prefs. Navigate to Homepage in Safari. Quit Safari. Lock the com.apple.Safari.savedState folder. Then you are free to uncheck the "Restore windows" option under System Prefs>General.

     

    Solution!

     

    But should something so basic really be this hard??!?!?

     

    What happened to the Mac OS "just working" ???

  • ZX48 Level 1 Level 1 (0 points)

    In fact this still doesn't work if you happen to close all Safari windows but don't QUIT. WHen you next click Safari or press Command+N, a blank page opens.

     

    SOlution is to first quit and then relaunch.

     

    What a massive UI mess!

     

    I jsut fiddled with fullscreen view and this is even more terrible (for different reasons). New pages open in new full screens. And if you close one teh one you are in (command+W), you crash back into the main desktop (not the other Safari full screen window (but which is still open!).

     

    What odd UI decisions by the Lion "designers".

  • ruskin219 Level 1 Level 1 (0 points)

    I'm having the same problem.  My System Preferences page looks the same as LKBLKB's.  I just upgraded to Lion about 5-days ago.  Did not initially have this problem.  It just started this morning.

  • pips7000 Level 1 Level 1 (0 points)

    unchecking "Restore windows when quitting and re-opening apps" works for me  thanks guys.happy days

Previous 1 2 3 4 Next