Previous 1 2 Next 27 Replies Latest reply: Feb 19, 2013 8:05 PM by JellyBellyFred Branched to a new discussion.
Chief Tarun Level 1 Level 1 (10 points)

I've just upgraded from Snow Leopard to Lion and have also come to know that Xcode 4.1 is free for Lion users. I already have Xcode 3.x from my SL. I just upgraded to Lion. When I try downloading Xcode 4.1 from the MAS, it says downloading, and shows the status bar the same for several minutes, with no progress in download. Do I have to uninstall my older Xcode for Xcode 4.1 to download. Why is it staying in the download status forever? Thanks.

iMac 27" Core i5 Mid-2010 Model
  • Younsuk Lee Level 1 Level 1 (0 points)

    I have same problems with Xcode in Lion. I have used a paid verion of Xcode 4.0.1, which doesn't work in Lion. They say 'intall the Xcode tools version in Apple Store' but it can't be downloaded.


    Any solution?

  • ChiperSoft Level 1 Level 1 (0 points)

    Mine doesn't even say "Downloading", the icon is just sitting there in the Launchpad with the word "Waiting" under it.  I deleted the old 4.0.1 Install Xcode app, but it still doesn't work.

  • William Kerber2 Level 1 Level 1 (20 points)

    I am having the same issue as ChiperSoft.  It just says waiting.  Does nothing.



  • notlion Level 1 Level 1 (0 points)

    Same problem here. App is perpetually "Waiting...". Sometimes the app store gives the error "There was an error with the App Store (1)"

  • galgalatz Level 1 Level 1 (0 points)

    Same issue here.... Apple guys, any ideas what's going on?

    I have tried to remove the Xcode 4.0, restart, yet no resolution.

    no itunehelper in the house....


  • Thebestplacehere Level 3 Level 3 (705 points)

    I install Lion with the xcode that buy with snow leopard time ago so when open xcode it say that isn't compatible with Lion because is the snow leopard version.So i go app store and yea i see is free so i download it and true takes a bit but i wait and i install it,it say updating xcode and done.In launchpad are the two installers yes the one for snow leopard version and the one for lion but the applications xcode,instruments etc now are up to date so may good idea don't delete the applications because that way don't need install them again just update them.After that i delete the install xcode snow leopard version but may can be done before that so no problems for me.

  • notlion Level 1 Level 1 (0 points)

    Okay. I finally got this to work by uninstalling XCode 4.0.1, restarting, and just mashing "install" in the app store repeatedly until it changed to "installing"... I know that's not really a clear answer, but it worked for me. Also XCode crashed the first time I opened it. Yay!

  • Larry Daniele Level 1 Level 1 (0 points)

    I just bought a brand new MacBook Air with Lion preinstalled. Same problem installing Xcode 4.1. The icon just sits on "Waiting..." with no apparent progress. Since there is no tooltip giving you more information, I can only assume that it is stuck (as opposed to just very slow). Poor UI design if you allow large downloads. Any ideas would be appreciated.

  • William Kerber2 Level 1 Level 1 (20 points)

    For me going into the ~/Library and deleting the preference file for the appstore and then restarting worked.  In ion the user's library is hidden so you need this in the terminal:


    chflags nohidden ~/Library


    YMMV, but this worked for me.



  • coffear Level 1 Level 1 (0 points)

    I had it sitting at waiting for about 2 hours before the download actually started,


    The annoying thing is once I installed I still got the message stating that I could not use this version with Lion

  • Larry Daniele Level 1 Level 1 (0 points)

    I finally got Xcode 4.1 to install on Lion. My guess is that the download server was simply overloaded. But hours later the download resumed and the program installed fine. Just wish there were better feedback when this happens.

  • coffear Level 1 Level 1 (0 points)

    After posting my previous post I decided to remove my old Xcode from the max (moved to trash from the app folder). After doing this I used the same downloaded file as before. This new install never completed (very nearly did).


    Now xcode appears to be working fine. So it it is not the download that is faulty more the install procedure, there must be something the install is not updating.

  • sl33pwalker Level 1 Level 1 (0 points)

    I had a problem where I had XCode 4.2 beta installed on Snow Leopard, upgraded to Lion, downloaded the free version on the App Store, and kept getting this when I clicked either the already installed, or the Install

    Screen Shot 2011-07-25 at 11.03.02 AM.png

    This is a totally confusing alert by the way


    I used this to uninstall XCode and the dev tools:


    sudo /Developer/Library/uninstall-devtools --mode=all


    and yet the Mac App Store said I had XCode installed (though I had appeared to have successfully uninstalled 'XCode for Snow Leopard'). I couldn't figure it out, and couldn't re-download the Mac App Store version of XCode (4.1 for Lion).


    Finally, I searched for the term 'XCode' on my system, and saw the 'Install' in a folder named the same, also in my /Applications folder. I noticed that the one outside the folder had a much older date and the version number was 4.02. The one inside the folder (Macintosh HD/Applications/Install XCode/Install had the right version and right modified date. That was the right one.


    Hope this helps someone.

  • Mehran Zand Level 1 Level 1 (0 points)

    I have same problem for installing XCode 4.1 on lion, after selecting install XCode from AppStore, XCode appears in lunchpad and staying in waiting mode.



Previous 1 2 Next