Previous 1 2 3 4 Next 113 Replies Latest reply: Jan 24, 2014 7:00 AM by taramason Go to original post
  • KMSR09 Level 1 Level 1 (0 points)

    I have this exact problem.  I want to go back to the way things were and just leave the installer boot but it wont let me.  If I go to "Startup Disk" from the apple menu and choose "Macintosh HD" it will tell me it can't do it because:


    "Startup Disk could not gather enough information on selected disk"



    it cant and that it "could not gather enough information" .... At this point I'd rather just backpedal from this installer more than anything else.  I'll be able to repair the disk and worst case scenario at least just back up my files before i start again.  Any ideas?




    Some further info to put on the table - here's what I get after I run disk utility and this includes when the snow leopard disk is at hand:



    Verifying volume “Macintosh HD”
    Checking file systemPerforming live verification.
    Checking Journaled HFS Plus volume.
    Checking extents overflow file.
    Checking catalog file.
    Incorrect number of file hard links
    Bad hard link creation date
    (It should be 3325742596 instead of 3340504404)
    Hard link record has data extents (id = 2888169)
    Checking multi-linked files.
    The volume Macintosh HD could not be verified completely.
    Error: This disk needs to be repaired. Click Repair Disk.

    Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.



    How can I even back up my files when I can't even access them because of this installer boot mode!


    Someone help, please.  At least to just get me out of this installer boot mode.

  • Graham Perrin Level 2 Level 2 (255 points)

    KMSR09 wrote:

    …  Someone help, please.  At least to just get me out of this installer boot mode.


    Earlier in this topic, three steps. Try those.


    Aim to start from your Snow Leopard DVD and use its Disk Utility, first for a verification.

  • KMSR09 Level 1 Level 1 (0 points)

    I already did, it doesn't help.  As you can see from the log I posted the repair attempt came out futile


    Now I'm stuck in limbo....I can only use safari right now because its part of the installer utilities.

  • Graham Perrin Level 2 Level 2 (255 points)

    Wherever there is live verification it is properly impossible to repair that volume.


    Try the traditional c key to start from your Snow Leopard DVD then use its Disk Utility to verify the volume. Don't rush to repair, let's see whether what's reported is significantly different.

  • KMSR09 Level 1 Level 1 (0 points)

    Okay I just tried that and it wouldn't work.  At the grey apple screen it just gave me the spinning grey wheel/gear and stayed like that for several minutes until I eventually held the power key and started normally.


    I also tried holding down option and it brought me to the boot selection, but it only had one option - "OSX Installer"

  • Steve Martin2 Level 3 Level 3 (565 points)

    I have the EXACT same thing happen. I am now in limbo with no where to go. In my disc utility, repair disc is greayed out. Cannot exit the installer, and do not want to reinstall Snow Leopard, I do not want to wipe my HD clean. Someone needs to fix this. I've never had a problem like this, my computer is in limbo.

    Thanks, Steve M

  • chiruchi Level 1 Level 1 (0 points)

    Likewise same problem here.


    Tried also selecting the boot disk to the original, internal disk and it says it hasn't got enough information etc, same error.


    Tried the restore from TimeMachine option as well, but with no luck since it does not show the internal disk as an option to restore the data?


    Did I understand correct that the next steps would be:


    1) Try to boot from SL installation disk and repair the disk from there

    2) If that fails, erase the current partition and restore from TM, assuming it will now show the volume as an option?



  • bldg13 Level 1 Level 1 (0 points)

    Hey I just spent half the day trying to install Lion—never ending loop of rebooting, disk is damaged, etc. I tried taking out 3rd party ram. I tried a differnt drive—thinking it was my 3rd party SSD.


    I zapped the p-ram as mentioned by Graham Perrin and we're finally installing.

  • chiruchi Level 1 Level 1 (0 points)

    Good to know, must try that next.

  • jklangbehn Level 1 Level 1 (10 points)

    Well in tried the pram and command r. Put in my snow leopard disk and all it does is spinning stop and go blank. Guess I'll be calling tel support. This is on my 2010 mbp. My 2011 iMac no problem on the install. If anyone comes up with something new to try before tech support opens plaz post

  • wnd Level 1 Level 1 (0 points)

    These disk repair errors are so usual to me over the years even before Lion. I assume you are stuck having files on internal hard drive, no way to copy them as the only way to get operating system working again would be reformatting the internal drive first. There are 2 things you could do to copy the files out of the broken partition:

    - use unix console commands in Terminal that you can run from OS X install dvd, to copy files to some external memory (too difficult for some users)

    - use OS X install DVD to make a temporary install to some external memory like a large USB disk or a unused USB hard disk. Then you can boot it off that and use Finder to normally copy files from the broken partition to somewhere safe.

  • Graham Perrin Level 2 Level 2 (255 points)

    KMSR09 wrote:

    … only had one option - "OSX Installer"


    To escape from that limitation, try another reset of PRAM and NVRAM.

  • VicMacAnt Level 1 Level 1 (0 points)

    I had the same problem in the Lion install. I was able to reboot from the SL DVD (holding c during boot) and it was able to repair the hard disk (which Lion could not). I was then able to re-boot from the SL hard disk, and am now frantically backing up (which I of course should have done prior to the Lion download). I think I'll stick to SL for a while...

  • bfmcmillen Level 1 Level 1 (10 points)

    About 3 this morning I managed to reformat my hard drive using my snow leopard disk. Right now I am copy files from the time machine. Should take another 2 hours, I think. Can't wait to see what registration info or photographs I've lost.  Can't imagine why the damaged drive info happened but shame on Apple for not giving us a way to get back to our previous condition so early in the install. Especially since this is a download and any flick of the Internet could change the installing files.


    Anyway, hoping to have things clean with capability of actual upgrade to Lion.

  • Noddy1960 Level 1 Level 1 (0 points)



    Tried the suggestions regarding reset ram etc to no avail. Have now started with original disc, disc utility said disc cannot be repaired. Formatted disk and am now restoring from TM - 2 hours 11 mins left to go - lets see what happens then...........


    Thanks for all the advice so far Gents.




Previous 1 2 3 4 Next