1 21 22 23 24 25 Previous Next 488 Replies Latest reply: Mar 14, 2014 2:11 PM by ishadoe Go to original post
  • 330. Re: Time Machine backup very slow in Lion
    tomfromloveland Level 1 Level 1 (0 points)

    I have no idea why, but my TM seems to be running well now.  I am backing up 1.6 TB of data on my iMac internal 2TB drive.

     

    I had my iMac going to a firewire 3TB external drive and it took 2 weeks with multiple retires to get it to even do one backup.  Then it took many, many hours to do each backup.  Never got more than 2 backups done.  I finally downloaded chronosync and gave up on TM.  Chronosync works great.

     

    Then I got a 3TB Time Capsule from work to use for my macbook air.  Figured I'd give it a try at backing up my iMac as well.  First backup worked (took 23 hours to do).  And since then, each TM backup is complete in minutes.  I have the Time Capsule hooked to the iMac via ethernet cable not over WiFi. 


    As an interesting note, my MBA backs up very quickly to the Time Capsule via WiFi as well.

     

    I know this post doesn't provide any useful data, but thought I would share.


    Tom

  • 331. Re: Time Machine backup very slow in Lion
    arctophile Level 1 Level 1 (15 points)

    Did today's update fix the problem? I, too, am getting the slow incremental Tima Machine backups even though I have tried every suggestion in this thread. TM incremental backups used to be fast for me in Snow Leopard.

  • 332. Re: Time Machine backup very slow in Lion
    Jonathan Payne1 Level 1 Level 1 (40 points)

    It's hard to say but I think not. A simple 11.1Mb backup is taking 17 minutes so far which is outrageous. It finished backing up after about 15 minutes but now is deleting old backups, 3 so far. So on and on it goes, slow as anything, and pretty much useless. I left the thing running all night to complete its indexing, and it did finish it. Then I ran a backup this morning which kept indexing for a couple of hours. And now I have this small little backup and on and on it goes.

     

    Finished 22 minutes later, deleted 4 expired backups. Argh.

     

    Well the 10.7.2 release was so feature packaged I guess I am not surprised they didn't fix time machine. However, I think they made a poor choice.

     

    But then again the poorest choice of all was by me, upgrading to Lion the day it came out.

     

    Good luck!

  • 333. Re: Time Machine backup very slow in Lion
    DeimosL Level 1 Level 1 (0 points)

    Jonathan Payne1 wrote:

     

    ...

    Well the 10.7.2 release was so feature packaged I guess I am not surprised they didn't fix time machine. However, I think they made a poor choice.

     

    But then again the poorest choice of all was by me, upgrading to Lion the day it came out.

     

    Good luck!

    I waited before upgrading (until some time after 10.7.1 - so there was plenty of time to fix really important things like backups!!) - so being fast upgrading is not the problem.

     

    I just wish there was some way to get back to Snow Leopard but to restore backup would revert and lose so much work now it would be a disaster for me.  But then if I have any "disk problems" it would also be a disaster as I have not managed a Time Machine Backup for ages now (its just sitting there disabled as I use my Mac for other stuff occasionally).

     

    Ian

  • 334. Re: Time Machine backup very slow in Lion
    Espen Vestre Level 1 Level 1 (140 points)

    As mentioned several times in the thread, I fixed time machine accidently through a power outage, because that forced full regeneration of the .fseventsd. Since the slow backup was evident from the beginning, it might have been introduced by the Lion installer. If it's a pure installer bug, there's nothing to fix in Time Machine itself (but in the installer, and who knows, maybe it has been fixed?), but of course it would have been great if there was a safe and easy way to ask OS X to reset the .fseventd's.

     

    I don't know what happens if you try to delete .fseventd manually from the command line, so I don't want to encourage anyone to try that, but I think you may have luck and force a regeneration if you run a disk check/repair from Disk Utility through Lion Recovery, you may want to try that: http://www.apple.com/macosx/recovery/ In fact, everyone here should try that, because the first thing to check if your backup is slow is whether any of your disks need repair.

     

    Ah, and yes, backup still works fine after upgrade to 10.7.2. The first backup after the upgrade was big and took 20 minutes, but the next took only 56 seconds (22 seconds for the two internal disks, 34 seconds for thinning including one delete).

  • 335. Re: Time Machine backup very slow in Lion
    allan187 Level 1 Level 1 (5 points)

    10.7.2 seems to have fixed the issue for me. I was seeing every backup take about 40 minutes for around 250,000 files (always pretty much the same number of files). Now I'm down to about 10 seconds before thinning, and the number of files bears some resemblance to what has probably changed. Total time including thinning for last backup was about 5min 30seconds.

     

    The first time backup ran after the upgrade I noticed that it was waiting for the backup index to be rebuilt. I hadn't seen that before so maybe it was the index that was corrupted after all. In any case, the 10.7.2 upgrade caused that to be rebuilt at least.

  • 336. Re: Time Machine backup very slow in Lion
    Jonathan Payne1 Level 1 Level 1 (40 points)

    Actually, my experience is matching yours. My backups have gotten successively quicker since the first, second and even third backup after I updated. And just now I did a 1G backup as a ton of files changed. In fact, the backup started while I was in the process of changing huge numbers of files, and it didn't seem to cause much of an issue. And most importantly, the drive was ejected at the end and closed down and my computer isn't indexing the backup.

     

    So - there is hope. But we need to keep an eye on things. If I can manage to go about a week or two without any issues I will finally upgrade the rest of my family to Lion and start having fun with iCloud or at least portions of it.

     

    Good luck.

  • 337. Re: Time Machine backup very slow in Lion
    DeimosL Level 1 Level 1 (0 points)

    Upgraded to 10.7.2 and did a backup.  It finished after about 4 hours (most of which was indexing - but straight after an upgrade I accept quite a lot of new/changed files).  So after a complete clean backup and thus virtually nothing changed/to write I start a new TM backup.  It immediately starts "Waiting for Index to be ready" and keeps it for over 50 mins (and network coverage is nigh on perfect for both laptop and Time Capsule); wrote files for <2 mins; post backup thinning for 5 mins; then indexed for >1hr (before I killed it in disgust).  But on the positive, the fan only kept me warm during the post file writing stage!

     

    This is a complete load of @£$#.  I need backups (daft not to), I can't downgrade to Snow Leopard (too much work since).  Sorry but windows was never ever this bad (and they have had some pretty iffy released.  What in gawds name are Apple playing at letting something like this escape ?

     

    Already done the Disk Utility stuff, the mdutil resets, everything and none of it made any difference (except take loads of my time - time I will never ever get back - thank you Apple).

     

    So I purchased a new Time Capsule to see if an empty drive is faster (I still need backups).  So, after the initial backup (bound to be a biggy) I'll post info about how long it all takes.

     

    Next laptop has got to be Windows 'cos this is driving me insane.  Always used to be OS X was solid but this ... but I need backups because stuff does break/get nicked/whatever.

     

    (and I've still got a lot of steam left to "let-off").

  • 338. Re: Time Machine backup very slow in Lion
    Espen Vestre Level 1 Level 1 (140 points)

    FWIW I've now also upgraded my MacBook Pro i7 15" (2010 model) to Lion, and after a long (of course) first backup, backups take from 14 seconds to 1 minute.

  • 339. Re: Time Machine backup very slow in Lion
    Jonathan Payne1 Level 1 Level 1 (40 points)

    Don't give up dude. It's working quite well for me for the second day now. There is hope ... maybe.

     

    The initial backup was long and slow and I had a boatload of waiting for index to complete. And I have a network monitor so I could see it reading and writing many Megabytes/second to the remote file server over my sometimes slow wireless network.

     

    I am not sure what backup scenario you are using. It's not a local hard drive right? It's a network one on some other computer or on a Time Capsule? Wireless networks can be crap slow and unless you're wired you'll never really know until you actually get a monitor or open Activity Monitor (I just realized).

     

    I personally would stay away from Time Capsule. I don't trust it and I especially don't want to deal with the first time my Time Capsule hard drive fails. I prefer the "plug a hard drive into some already existing Mac.

     

    So - take a deep breath, let the backup run, keep your computer awake and the other side of the equation awake, and wait for the indexing to stop. If you are doing it over a wireless network, wait until the network activity stops. Every now and then you get a slow backup because there's a ton of data OR it has to expire a number of previous backups. Deleting a boatload of files over the network can be very slow as well. It's just the nature of networks.

     

    Send back a note with your details of your backup set up.

  • 340. Re: Time Machine backup very slow in Lion
    clanger9 Level 1 Level 1 (15 points)

    Seems good here on 10.7.2: 1.7GB backup over wireless in just under 7 minutes and no crazy indexing.

     

    14/10/2011 18:07:22.358 com.apple.backupd: 2.94 GB required (including padding), 468.64 GB available

    14/10/2011 18:13:47.741 com.apple.backupd: Copied 3264 files (1.7 GB) from volume Macintosh HD.

    14/10/2011 18:14:13.454 com.apple.backupd: Starting post-backup thinning

    14/10/2011 18:14:13.454 com.apple.backupd: No post-back up thinning needed: no expired backups exist

    14/10/2011 18:14:14.278 com.apple.backupd: Backup completed successfully.

  • 341. Re: Time Machine backup very slow in Lion
    allan187 Level 1 Level 1 (5 points)

    This is now typical for me:

     

    14/10/2011 17:50:43.086 com.apple.backupd: Starting standard backup

    14/10/2011 17:50:43.109 com.apple.backupd: Backing up to: /Volumes/Backup/Backups.backupdb

    14/10/2011 17:50:44.520 com.apple.backupd: 617.2 MB required (including padding), 124.22 GB available

    14/10/2011 17:50:47.845 com.apple.backupd: Copied 1524 files (19.9 MB) from volume Macintosh HD.

    14/10/2011 17:50:47.906 com.apple.backupd: 592.5 MB required (including padding), 124.20 GB available

    14/10/2011 17:50:48.676 com.apple.backupd: Copied 96 files (93 bytes) from volume Macintosh HD.

    14/10/2011 17:50:49.256 com.apple.backupd: Starting post-backup thinning

    14/10/2011 17:50:49.256 com.apple.backupd: No post-back up thinning needed: no expired backups exist

    14/10/2011 17:50:49.276 com.apple.backupd: Backup completed successfully.

     

    So I have no complaints with a 6 second backup, but does anyone know why the file copy stage happens twice? And those 96 files must be pretty tiny, unless they are just 0 byte lock files or something.

  • 342. Re: Time Machine backup very slow in Lion
    DeimosL Level 1 Level 1 (0 points)

    What is ahppening with this thread now.  I got a load of e-mail notificastion about answers people have posted and can't see any of them on this thread.  I can't seem to get beyond page 23.  No subsequent pages listed.

     

    Has my Lion just given out (unlikely as its a web page) or what ?

     

    Ideas welcome 'cos I really need to sort this problem out.

     

    Update:  Sorry.  Posted this message and suddenly all the other messages appeared.  Something well weird as I had already done  Safari Empty Cache and restarted Safari.  And now I can't see any way to delete this post - so sorry everybody.

     

    Backup is to Time Capsule over network (but excellent coverage, rate @270 and Time Capsule probably even better).  Same system as under Snow Leopard.  I'm now into a long long backup (initial backup to a new Time Capsule!!) - still 20hrs left to go at current estimates.  But it is an initial backup to a new disk to it is bound to be a long one.

  • 343. Re: Time Machine backup very slow in Lion
    DeimosL Level 1 Level 1 (0 points)

    What I'm finding is that once I get the "Backup Completed" the menu bar icon goes "idle" but the logs show a backupd "waiting for spotlight ..." message every 10 mins.  I've now found out thet when a new backup starts it switches to a "waiting for index ..." every minute whilst spotlight continues its previous indexing.  So manually eject the backup disk after the "backup completed" log entry and you then get a failed log entry from mds.  This seems why some have reported that the disk is not being ejected - it is waiting for a very very long spotlight index operation to complete.

  • 344. Re: Time Machine backup very slow in Lion
    Michael Newbery Level 4 Level 4 (2,360 points)

    I upgraded to 10.7.2 and turned TM back on.

     

    14 hours later it's still "Preparing Backup" with the system

     

    com.apple.backupd: Waiting for index to be ready (100)

     

    In other words, no immediate fix. If and when it completes its first backup, I'll see if the problem has really gone away with subsequent backups.

1 21 22 23 24 25 Previous Next