Previous 1 27 28 29 30 31 Next 488 Replies Latest reply: Mar 14, 2014 2:11 PM by ishadoe Go to original post
  • MrLingan Level 1 Level 1 (0 points)


    I have done that!

    And than, give it all to Media!

  • lauhub Level 1 Level 1 (0 points)



    I think I found the workaround for this (my TimeMachine backup has just ended after only 2 hours). I had to do several operation using the terminal and I finally have my TimeMachine working.


    Actually, the problem is between TimeMachine and Spotlight. Indexing blocks the backups... I read a lot, tested several things.


    Putting in all together, here is what I did


    Using Terminal:

    1. I disabled Spotlight indexing:

    sudo launchctl unload -w /System/Library/LaunchDaemons/


    2. I deleted Spotlight index in all my drives (including the backup drives):

    sudo rm -rf /.Spotlight-V100/Store-V1 /.Spotlight-V100/Store-V2  /.Spotlight-V100/VolumeConfiguration.plist


    (rm -rf /.Spotlight-V100/* did not work for me)


    3. I deleted /var/folders content (see this topic to know why):

    sudo rm -rf /var/folders/*


    4. I deleted the .inProgress files from my Backups.backupdb subfolders (put to trash then empty the trash is the only way to do this).

    It may be necessary to reformat your backup drive instead of only deleting .inProgress files.


    5. I restarted Spotlight:

    sudo launchctl load -w /System/Library/LaunchDaemons/

    sudo mdutil -i on -E /


    6. I waited until Spotlight finished indexing process

    7. I launched a new backup using TimeMachine


    8. I opened a bugreport to Apple with the title: "TimeMachine hangs when Spotlight is in use under Mac OS X 10.7".

  • peter_watt Level 3 Level 3 (905 points)

    D. Rackerby wrote:


    Dimaxum: That procedure can be accomplished via GUI as described here:


    Big problem with the gui approach

    1. Cannot put TM volume into privacy as it uses spotlight.

    2. When main HD is taken out of privacy it starts a new index. In my case estimated at three weeks.


    My solution was restore 10.7.4 using TM (Command R while booting etc etc) til they get 10.7.6 out. I can't buy mountain lion as it would take most of my broadband allowance. No longer happy with Apple at all.

  • lauhub Level 1 Level 1 (0 points)

    The Terminal approach is the only one that worked for me (except for some Spotlight exclusions I did using the GUI).


    You can follow this article that shows how to manage spotlight exclusions using the terminal.


    Is there a way to get back to 10.7.4 if I do not have the TM backup for this ?

  • Pondini Level 8 Level 8 (38,715 points)

    lauhub wrote:

    . . .

    2. I deleted Spotlight index in all my drives (including the backup drives):

    sudo rm -rf /.Spotlight-V100/Store-V1 /.Spotlight-V100/Store-V2  /.Spotlight-V100/VolumeConfiguration.plist

    Usually, that's all you need to do.  And it's a bit easier to just delete the whole /.Spotlight-V100 folder.  OSX will re-create the folder and contents.


    4. I deleted the .inProgress files from my Backups.backupdb subfolders (put to trash then empty the trash is the only way to do this).

    That shouldn't be necessary if the problem is with the Spotlight index.   The only time it's needed or helpful is if the .inProgress package is so large it causes Time Machine to delete old backups.  Otherwise, Time Machine will clean it up when the next backup completes.

  • lauhub Level 1 Level 1 (0 points)

    I agree that some things I did may not be necessary. But as this bug is quite tricky, I took all the chances for me to make it work, since people still had problem by doing things partially

  • Varkias42 Level 1 Level 1 (10 points)

    @lauhub did the above list of actions permanatlly fix the issue for you? I disabled spotlight and was able to complete a a new full TB backup (390GB) at a normal pace (about six hours, while I slept last night) but after I turned spotlight back on (I use it regularly) It's now taking a massive amount of time to do anything, and is mostly just failing.


    I'm assuming that since I just disabled spotlight (and didn't clean it up) that I just hid my issue during my backup.


    Just wondering if I should expect things to return to normal if I follow the above list of actions.  Also, did you perform any reboots during any of that?


    Thanks for helping to fix this issue!

  • lauhub Level 1 Level 1 (0 points)


    No, it is not a permanent fix. Currently, I have to disable spotlight using the "launchctl unload..." command before running a TM backup. Then I re-enable Spotlight using the load command.


    The other steps are only to re-build Spotlight index if it is corrupted. It allowed me to make a TM backup without disabling Spotlight yesterday, but a few hours later, a new TM backup was also blocked. So now I disable SL, run TM backup, then enable SL.


    So definitely, no, it is not a fix, only a workaround for people who experience issues with both TM and Spotlight (which are linked together).

  • Pondini Level 8 Level 8 (38,715 points)

    Start by just deleting the index.  That fixes it permanently for many (perhaps most?) folks.


    Turn Time Machine off and if a backup is already running, cancel it.   Then delete the index on your internal HD (and any other volumes being backed-up).  Wait for re-indexing to complete before turning TM back on.


    If that doesn't do it, delete the index for your backups.  Note that if your backups are on a network, the index you want is the one inside the sparse bundle, not at the top level of the drive (although it won't hurt to delete both).  See the pink box in #D2 of Time Machine - Troubleshooting for details.



    If you still have trouble, try lauhub's whole list.

  • Varkias42 Level 1 Level 1 (10 points)

    @lauhub, thanks for the clarification on that one! So is the issue that Spolight keeps corrupting? I hope there is a more permanat fix for this soon.


    @pondini I'll look that over!

  • PhotoShoot Level 1 Level 1 (5 points)

    Time Machine uses Spotlight, so re-enabling Spotlight after the backup is complete may or may not work. Indexing just my 500 GB SSD was projected to take at least 3 days.  Since I index all of my internal drives (6.5 TB of data total) using Spotlight is not an option for me.  On the advice of the development Apple Support eschued asking me to delete the V100 file, telling me to keep Spotlight off and wait for the fix.

  • Varkias42 Level 1 Level 1 (10 points)



    So Apple told you there was a fix coming?


    I only have about 360GB of data on this iMac, so for now turning off spotlight, running a backup, and then turning it back on isn't a bad option. Since I don't do much on this computer other then email and entertainment, manully doing this once a week or so is more then adequate for the time being. I just hope there is a fix soon, because this is a PIA.

  • WunWingLoh Level 1 Level 1 (10 points)

    So I've suffered the same as everyone else but unfortunately didn't read all the multitude of threads in the correct order so basically lost my original TM backup, then my Spotlight db in a failed effort to fix it.


    A thread somewhere which I can't find again (I think it was more about slow Spotlight index) had a post from a guy who simply reinstalled 10.7.5 and everything was back to normal. So I did that, and it worked.


    After completion of the reinstall I left TM off and allowed Spotlight to index. I went out for a ride and when I came back it was done - 149GB in something less than 90 min. And it works, I've searched for stuff on my HD.


    I then turned TM on and it took 2hrs 9min to complete.


    So if you are considering spending the time and bandwidth downgrading to 10.7.4 you may wish to consider a reinstall of 10.7.5.

  • lauhub Level 1 Level 1 (0 points)


    Can you tell us if this definitively fix the problem ? Because the first times I used TM (I am under Lion since the beginning), everything worked nice.


    The problem appeared for me one week ago, so I am not sure a complete re-install is the solution.

  • WunWingLoh Level 1 Level 1 (10 points)



    I can not guarantee that it will fix it in your instance, clearly this is a very obscure bug.


    The MacMini I have Lion on came with Lion installed. I've had TM running on it since the begining and it has worked fine. The TM slowdown I noticed on 2Oct, when it actually started playing up I don't know - it's my wife's computer, we'd just come back from holidays and she'd downloaded hundreds of photos and then noted TM said it was going to take 93 days to complete it's back up! So I spent an entire day trying to fix it.*


    There are a large number of threads out there on this subject, and the related slow Spotlight indexing. I saw a couple that indicated they just rolled back to 10.7.4 and that fixed it. So I downloaded the 10.7.4 combo update, but whilst that was happening I read another post that said they just did a 10.7.5 reinstall and that fixed it.


    So my plan was to try a 10.7.5 reinstall, and if that didn't work, roll back to 10.7.4. Thankfully 10.7.5 worked for me. Your milage may vary.


    Good luck.


    * My efforts to fix it included wiping a years worth of TM backups and starting again, and wiping my Spotlight Indexs, all to no avail. As far as I'm aware the guy that simply did the 10.7.5 reinstall didn't trash anything so I wish I'd tried that option first.

Previous 1 27 28 29 30 31 Next