Skip navigation

Apple TV not working Flashing White LED

939 Views 3 Replies Latest reply: Jul 20, 2011 7:21 PM by mreze725 RSS
MCOJFKflyguy Calculating status...
Currently Being Moderated
Jul 20, 2011 12:34 PM

My second generation Apple TV has a white flashing LED light, and I am getting no picture or sound.  It's hooked up to the TV via the HDMI port, and is plugged in.

  • Winston Churchill Level 10 Level 10 (81,650 points)
    Currently Being Moderated
    Jul 20, 2011 1:10 PM (in response to MCOJFKflyguy)

    Try pulling ALL the cables and trying again in a few moments. If that doesn't help you can restore it using a micro USB cable and connecting it to iTunes on your mac/PC (disconnect power when doing this)

  • jkent27 Calculating status...
    Currently Being Moderated
    Jul 20, 2011 4:20 PM (in response to MCOJFKflyguy)

    I have this same problem.  I have reset the apple tv to it's original settings (a couple times), and it just won't show anything on my tv screen.  It only says "no signal".  I tried it on another tv and get the same issue.  This same apple tv worked fine on a friend's tv, just not mine. 

     

    Any ideas?

  • mreze725 Calculating status...
    Currently Being Moderated
    Jul 20, 2011 7:21 PM (in response to MCOJFKflyguy)

    I am having the same problem.  It was working just fine the other day.  I tried plugging a DVD with an HDMI cable into another HDMI port, and now, neither work.  At first I thought it was the HDMI cables (bought them cheap on ebay), but I just bought another one from the store, and still, nothing.  It would freeze up occassionally on me in the past, but a hard reset (unplugging the power in the back) usually worked (even if it was annoying).  However, this time it's not even recognizing a signal, so I can't go into Apple TV to reset that way.  I've tried the power reset, and the light flashes many times (I counted 18 times once ... then it stopped, then flashed another 5 times).  But still, no power.  Some posts say I I need to plug it into my computer with a micro HD cable.  If this is a potential need (now and again), it should have been provided by Apple.  Thanks, Apple, for being cheap yet again, and trying to bleed me at every possible angle. 

     

    My guess is to plug it into iTunes for a firmware update?  I thought I'd done that within the last month wirelessly (though could be wrong).  I don't know why, but I don't think this is the issue.  Any other suggestions?  With only a 90 day warranty (it was a Christmas gift and not even used until a month ago), this product reeks of "unfixable problems" without significant (and unworthwhile) cost.

     

    If anyone can help me fix this without having to pay yet even more money, I'd GREATLY appreciate it.  This is starting to get quite frustrating.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.