Previous 1 2 Next 27 Replies Latest reply: Aug 22, 2011 7:12 AM by hannes du plessis Go to original post
  • Mediconcept Level 1 Level 1 (0 points)

    I reported this to Apple and now they are running my MobileMe-account on a test-machine to figure out what is wrong. The 'senior-support-team' is working on this for the last 4 days ... I hope they come up with a good solution!

  • Fritsander Level 1 Level 1 (0 points)

    Hi All,

     

    I have the same issue when adding an appointment to my wife's shared calendar in MobileMe. Using my iPhone 4 it still works so it must be Lion that I upgraded to last week.

     

    Please Apple fix this issue, it is most annoying.

     

    Thanks,

     

    Fritsander

  • Mike Feeley Level 1 Level 1 (0 points)

    We see the same problem too. 

     

    Deleting the account and adding it back as a MobileMe account did NOT work for us.  Error persists.

     

    Setting the shared calendar as the default calendar does work for us, as for others here (i.e., adding events to a shared calender works, and only works, if its the default calendar).  Thanks for the tip noisypenguin.

  • ARSECPH Level 1 Level 1 (15 points)

    Seems like that Apple has solved the issue

  • Dave Simanoff Level 1 Level 1 (15 points)

    Have tried it all, and still can't get anything to work. I'm waiting on a fix too.

  • tgarcez Level 1 Level 1 (0 points)

    Add me to the growing list - trying the default workaround for now.

  • LPG2006 Level 1 Level 1 (0 points)

    Interesting.  I was having the same problem (adding events to my corporate calendar as CalDAV - this worked fne pre-Lion), but I was able to add a new calendar to the server from iCal, and then add events to that.  At work it shows up fine on the calender server as well. But for some reason permissions or some hidden setting on older calenders that worked pre-Lion now don't work. 

  • ARSECPH Level 1 Level 1 (15 points)

    After several chats with Apple - following works for me.

     

    1. Close iCal.
    2. Select MobileMe in your System Preferences.
    3. Sign out on the accounts tab. Sign back in using the word 'test' as the username and the password. You should receive a validation error. Once you get the error, sign back in using your own data.
    4. Make sure on the sync tab there, that the option to sync with MobileMe is on automatic. Make sure calendars are checked.

     

    • If the calendar option is not listed there go out of MobileMe system preferences and then go to your mail, contacts, calendar preferences.

     

    • Remove the account from there and add it back again.

     

        5. Open iCal.

     

     

    Make sure that your shared or local calendar, where you would like to add or adjust an entry, is selected by the new calendar button at the top left corner - the calendar must be selected before you make any change to this calendar.

  • noisypenguin Level 1 Level 1 (0 points)

    What you describe is simply selecting the calendar to make changes to. If we just had one calendar then this would be no issue. Where there are multiple calendars you can make adjustments / entries into the selected calendar, but if you want to change an event from one calendar to another it does not work as you can only be logged into one calendar at a time. The only way to do this is to delete an event from one calendar, change the default calendar at the top of the page and then add a new entry in that calendar.

     

    Whilst this works it is a messy workaround.

     

    Come on apple!

  • michael.sherman Level 1 Level 1 (0 points)

    I just want to add that changing the default calendar to the shared calendar (originally created under my account, but being accessed with my wife's account), she can now add events to ALL shared calendars. And you can change the default calendar back to what it was before once you try adding a new event. Actually, I don't know if the act of simply changing the calendar to default to the shared one alone will work, or if you have to add an event, but this workaround does seem to fix the issue.

     

    FWIW, I've seen worse workarounds.

  • Niclet Level 1 Level 1 (5 points)

    Count me in. This is very annoying for our buisness since we share a lot of calandars, so the "Default Calandar" workaround is useless. I tried to remove and replace MobileMe accounts from all Mac here (if you try this, don't forget to backup your data) but it just didn't work.

     

    Please Apple Fix this ASAP !!!

  • Mike Feeley Level 1 Level 1 (0 points)

    Here's some progress.

     

    The problem appears to be that you can not move an event to a shared calendar (i.e., change its calendar). Creating an event in a shared calendar works fine; that's why changing the default calendar works.

     

    What you can do (just realized) is set the default calendar to "last calendar selected" (bottom of the default calendar drop-box on the "General" Preferences pane).  And now, to add an event to any calendar, first select that calendar in the calendar list (from the "Calendars" button) and then double click to add the event to that calendar. You still can't move the event to another calendar (if its shared), but at least you can add events without having to change the default calendar each time (and you can use the web version to edit events, if necessary).

  • hannes du plessis Level 1 Level 1 (115 points)

    What you're describing is exactly my problem. My wife and I share a calendar for all future events, and as soon as an event becomes chargeable I used to be able to simply move it into a client's calendar and it will automatically be charged for. Now I have had to resort to cutting and pasting between calendars, a much less elegant solution.

Previous 1 2 Next