Skip navigation

Multiple websites

20419 Views 66 Replies Latest reply: Nov 15, 2011 12:54 PM by hphoeksma RSS
  • iHatePC Level 2 Level 2 (155 points)
    Currently Being Moderated
    Aug 2, 2011 3:03 PM (in response to SGlazier)

    So what's the deal, are we all doing something wrong that is preventing multiple sites from working or is this a bug? If it's a bug, what the heck is going on at Apple, why wouldn't they have fixed this by now with an update?

  • voigtstr Calculating status...
    Currently Being Moderated
    Aug 20, 2011 2:27 AM (in response to CaLiFoRNiAWEBER)

    Make sure you are adding it to the top very top --->

     

    Should look like this...

     

    NameVirtualHost *:80

    #

    # Mac OS ... .......

     

    Turn off web. (wait until it completes).. turn on web..  - should work and should be able to add additonal sites

    any idea why that works, when the virtual hosts section of httpd.conf doesnt work?  So I now have wikis working again on my main domain (eg the www.mydomain.com) and a sub domain now points to the correct folder on the server to pick up content (eg william.mydomain.com)  BUT its not resolving the text as html its actually echoing the content of the .html page to the screen.

     

    <html>

    <body>

    This is a test.

    </body>

    </html>

    in the body of the html file is displaying as above in the browser

  • voigtstr Level 1 Level 1 (25 points)
    Currently Being Moderated
    Aug 20, 2011 2:32 AM (in response to voigtstr)

    Ok the html rendering as plain text?

    Because I was using a cocoa writer instead of pico, and the cocoa writer was wrapping all my text with markup.

    I've re-edited the page in pico and its working as intended!

  • dpasarchi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 26, 2011 1:54 PM (in response to SGlazier)

    Has anyone resolved this issue of the services not working?

     

    I've reinstalled Lion Server twice and every time I get the response that iCal is not turned on.

     

    Frankly if this is what an easy server is to Apple then they can tell that to those of us who find that it's broken out of the box.

     

    I guess you get what you pay for and since the cost isn't expensive, it's to be expected but that it still isn't working over 2 months after release is absolutely unacceptable.

  • Michael C M Level 2 Level 2 (205 points)
    Currently Being Moderated
    Sep 26, 2011 10:10 PM (in response to dpasarchi)

    I have had success recovering services a few times. I don't know exactly what the one item that works each time, but here is my typical recovery steps:

     

    1. Set all certificates to None using Server.app (wait till it completes).

    2. Repair disk permissions.

    3. Restore /var/pgsql from the last known working instance.

    4. Restart 2-5 times, by this time pgsql should be starting on its own again, and your services should have recovered themselves.

    5. Make sure DNS service is running with Server Admin.app, seems to be required for mail and wiki to startup.

    6. Choose the correct certificates for each service again.

    7. Reduce mail security required for incoming SMTP connections to allow incoming mail with Server Admin.app.

     

    My issues are all typically spawned from pgsql not booting, or rather claiming to get a shutdown request immediately after starting up. Once I have it running it stays running until I reboot or install updates again. Its been up for over 20 days now.

     

    Good luck! I really hope that Apple fixes all these issues in the next update... it would be nice to be able to reboot it whenever and have reliable services. I still have yet to get the profile manager and podcast manager running. They seem to be the cause of some failures when I first tried them out.

  • Brett Higginbotham Calculating status...
    Currently Being Moderated
    Nov 9, 2011 8:29 AM (in response to Brian S. Campbell)

    Help!

     

    What is the best way to setup the server. Host name for Internet or Host name for local Network.

    I just want to host mail a web site and podcasts.

     

    I have registered example.com  and want that to point to my mac mini server via port forwarding and NAT.

    Thanks anyone.

  • hphoeksma Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2011 12:54 PM (in response to SGlazier)

    Okay, this is how I got it working:

     

    Add the 0000_MoreTesting.conf as said earlier (with one line NameVirtualHost *:80)

    If you restart (apachectl restart or graceful won't do it, you need to do it in the server app!) you will get a forbidden message.

    To prevent that, change Override None to Override All in the respective conf file (not sure if the default virtual .conf file will do or is overwritten by the app).

     

    Restart the webserver using the server app. All good!

     

    For me DNS resolving didn't seem to work, so I added it to my hosts file on my MBP. (My server is running on a MacMini in the same network).

     

    I did all this in 10.7.2.

1 2 3 4 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (16)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.