Previous 1 11 12 13 14 15 Next 383 Replies Latest reply: Dec 20, 2013 6:34 PM by louisinhongkong Go to original post Branched to a new discussion.
  • c2oxide Level 1 (0 points)

    @enigma2k

     

    "Okay so if I want to have the laptops display off after wakeup I always have to close the lid to send it to sleep, then wake him up and only then I can open the lid, so it stays off.

     

    A bit complicated imo if I am using it on an external monitor."

     

    No, you do not need to wake it up just to sleep it again.  When the lid is closed, and external screen plugged in, wake it up with your external mouse / keyboard.  When you see it come up on the external screen, open the lid and the laptop display will stay off (assuming you ran the Terminal command above that we're all cheering about)... this is how they behaved with Snow Leopard...

  • enigma2k Level 1 (0 points)

    @croxide

     

    Okay and if I send it to sleep again and wake it up, will the laptop display stay off or do I have to make the same procedure again for the internal display to stay off?

  • c2oxide Level 1 (0 points)

    You can even reboot the computer and not have to re-enter the Terminal command.  The only way to undo it is either by entering the "reverse" Terminal command, or resetting your PRAM.

  • chenga.8 Level 1 (15 points)

    Scarlac, I posted the command to make it behave like it did before Lion (on page 12).

     

    Enigma, as long as the lid is closed when you wake the laptop, you're good. You only have to type the command once, and then reboot. Yes, it's a bit complicated, which is probably why Apple changed it. But it works well, and if you know the system it's better than using a magnet to keep the display off.

     

    You can always do a "detect displays" to achieve the new automatic result of opening the lid in Lion.

  • hamer313 Level 1 (10 points)

    You are a Genius!

    Thank you so much for this fix. You cannot imagine how much I appreciate this!!!!

    Keep up the great work!

  • johndontaylor Level 1 (0 points)

    Need to give kudos to chenga as well, thanks so much for sharing that command with us.  Us simpletons aren't aware of the ability to alter OSX through Terminal.  Let's hope Apple never locks down OSX like iOS!

  • MacTheFox Level 1 (10 points)

    Great post! Thanks a lot!

    Only a question of understanding. How can I set the behavior back to the standard lion behavior?

    To set SnowLeopard modus: sudo nvram boot-args="iog=0x0"

    To set Lion modus: sudo nvram -d boot-args (is a reset of NVRAM)

     

    But what kind of "boot-args" is the setting of Lion?

    Thanks again

  • chenga.8 Level 1 (15 points)

    You understand correctly, MacTheFox. Those are the commands to set SnowLeopard and Lion modi. But, 'sudo nvram -d boot-args' doesn't reset NVRAM; it just deletes 'boot-args.' The other NVRAM items are untouched.

     

    The default for Lion is that there is NO 'boot-args.' (At least for my computer)

  • MacTheFox Level 1 (10 points)

    Thanks! Great info chenga.8

    By the way: it worked great on my MacBook Pro 17".

  • yujiLY Level 1 (0 points)

    I have a related question: in Snow Leopard on my MBP, what I always did was to wake up the computer by plugging in a USB device (usually the USB cable from the Cinema Display), then open the lid so I could use the keyboard and trackpad.

     

    Now, using Lion on my MBA, this isn't working for me: plugging in a USB device doesn't even wake up the MBA. And I've run the nvram command that chenga.8 posted.

     

    Is there something else that I need to be doing?

     

    Thanks so much!

  • chenga.8 Level 1 (15 points)

    yujiLY,

     

    There's probably a similar command line you can put in to make the laptop revert to that behavior. I don't know what it is though.

     

    I'm guessing that you use the laptop's keyboard, but an external monitor. If you have an external USB keyboard, or a bluetooth keyboard, you can use that to wake up your computer though.

  • minzmogul Level 1 (0 points)

    Hm, can`t get it to work on my Macbook Pro 13". Neither on 10.7 nor 10.7.1. The Macbook is connected with a Mini Display Port to HDMI Cable (no adapter) to an AOC 24" LCD. Tried several times. When the lid is opened the internal display comes up. Don`t want to use a magnet, so still waiting  and hoping for a solution...

  • Obasan Level 1 (50 points)

    Thanks for the effort chenga.8. Unfortunately, this didn't work for me. :-(. I can't understand why apple would disable this functionality. Not only is it useful for cooling the laptop, it also enables the isight.

  • chlab Level 1 (0 points)

    chenga.8,

    Thanks mate, that seems to do the trick!

     

    For those having trouble: I had to reboot for it work.

  • Namarillo Level 1 (0 points)

    @chenga Thanks for the trick, it works perfectly on my MacBook White Late 2008 running OS X 10.7.1

     

    This is the behavior I want, just like Snow Leopard.

Previous 1 11 12 13 14 15 Next