Previous 1 13 14 15 16 17 Next 383 Replies Latest reply: Dec 20, 2013 6:34 PM by louisinhongkong Go to original post Branched to a new discussion.
  • moptopcanada Level 1 (0 points)

    Thanks to everybody who worked on this solution, it's great to have a community to come to for answers. I have however come across an interesting scenario with my workflow and using the Terminal fix. I would be interest to see if other users can replicate this as well.


    After applying the Terminal command, and restarting the open clamshell works as described. But I have found that because Mac OSX "thinks" the lid is closed it shuts off my microphone and will not allow me to audio chat, even with the lid open and the screen off. This creates a secondary effect that I cannot initiate a single screen screenshare because iChat says the audio is not available.


    If I put the MBP to sleep and wake up with both monitors turned on, the audio and screenshare work perfectly. Of course, anyone that has tried to screenshare with dual monitors knows it is impossible to see as you get two small screens on one monitor on the other end of the chat. It's also useless to initiate an audio chat with the clamshell closed because the reverberation off the screen causes feedback into mic.


    The only workaround I have been able to achieve is to set Lion back to it's original state, open the clamshell with both monitors turned on, initiate an audio chat, then use the magnet trick to shut off the internal screen, and then initiate a screenshare after that. Phew!


    So if Apple doesn't think there is an issue with the default Lion settings with external screens, they should, as they have rendered one of their own applications useless under normal circumstances.


    I would like to see if other users on this forum can replicate the same scenario.



  • NervousTitan Level 1 (0 points)

    chenga.8's Terminal command did not do the trick for me. I'm running OSX 10.7.2 on an Early 2008 15-inch MacBook Pro.


    After entering the command (+ password) into the Terminal window and doing a restart, the MBP's display keeps turning itself on after opening the lid. So I use the external screen alone with the MBP's lid closed > want to use the trackpad so I open the lid, and the MBP's screen gets added. Maybe the Terminal's command has been made redundant in 10.7.2 ?


    Also, why does Apple not simply provide a 'switch monitor # off' in the Display's Preferences?


    Seems like I am the only one that does not get it to work? Am I missing something?

  • Eldon Henley Level 1 (0 points)

    I am irked by this "update" as well. 


    Apple: Please address this issue with a software update, as it is a major inconvenience as well as a huge detriment to my MBP's battery life (from overheating) and Wifi reception.


    Thank you.

  • eww Level 9 (52,975 points)

    These are user-to-user forums, Eldon. Apple is not here.

  • Jonathan UK Level 5 (6,480 points)

    As I have pointed out to eww before (in connection with another reply of the same nature), his reply is inaccurate. Apple has advised that this board is "heavily monitored". Furthermore, users have been asked to provide feedback regarding this issue in the forum. Apple doesn't reply in the forums, but they are most certainly here.


    harmonica01 quoted Apple support as saying:


    If you and others do believe this is in error, I strongly advise you all to create a thread with screenshots of temperatures and other evidence as you feel necessary.The apple discussion board is heavily monitored by our tech and other departments so a chance for future software updates that would accommodate what you feel is a missing feature in the new operating system may become possible."




    The feedback form is a further important way to advise Apple of our concerns and should ideally be completed in addition:


  • razvy Level 1 (0 points)

    the trick works for me too. thanks. really appreciate

    (mbp13" 2011, lion)

  • markatos Level 1 (10 points)

    Add me to the list of people who want to use their MBP in clamshell mode and still have wifi.  This is annoying as I don't need two monitors and spent $1000 on this cinema display so i can do what I used to do in snow leopard.

  • dsogari Level 1 (0 points)

    Not to mention that if one chooses to run extended mode, there is the inconvenience – in addition to the graphics card memory overhead – of the mouse cursor quitting the main screen whenever it is near the separating edge.

  • R6H8 Level 1 (0 points)

    Logging my requirement that Lion should be updated to include the excellent feature from the previous version of OSX allowing the user to use the cinema screen with the laptop case open. It worked before - why did they take it away?

  • simmer9191 Level 1 (0 points)

    I'm using 10.7.2 on mb late2009.  This trick works for me.

  • vaclavXXX Level 1 (0 points)

    *** with you Apple???

    (i didn't receive answers for my requests from


    We all want switch off open the lid. Because ... overheateting, multi-touch, save energy etc.


    What is the real problem, to do it?

    (for example, in display preferences: Display - OFF, External display - ON)

  • thesebastian Level 1 (0 points)

    Or a hotkey like in Windows 7:


    <Command Key + P> = Switch between 4 options ( Main Monitor -  Duplicate - Extend - Projector Only )


    Main Monitor = Only show Desktop at the main monitor.

    Duplicate = Show the same content in all the monitors.

    Extend = Show Desktop in primary monitor (You can define it) and alternative desktop in secondary monitor

    Projector Only = Disable the main monitor and use only the external monitor. (This is what you are already asking for...)


    And what about an option to don't f%&ing SLEEP the LION when you close the LID, to only move..maybe from your bedroom to your kitchen with the lid closed (minimizing risk when walking, energy to turn on/off your Laptop for just a 20 seconds walk, human energy to type again your password, etc).

    I woluld cry for an option like this in MAC.....

  • eww Level 9 (52,975 points)

    vaclavXXX: Apple doesn't answer Feedback, and tells you so right on the Feedback page.


    If you want to send Apple feedback about the MacBook Pro in particular, do it in the right place:


  • Luke20333 Level 1 (5 points)

    Hello all!


    Lion has changed to default behavior of the internal screen from the old functionality in Snow Leopard. Previously, in SL (Snow Leopard), a Mac with an internal screen could be connected to external mouse, display, and keyboard and be ran with the external as the primary monitor WITH the laptop screen open. It is important to keep the screen open on laptops to release heat. Here are the steps to restore this functionality in Lion:


    I have found that this command in Terminal restores Snow Leopard functionality in Lion to closed-lid/clamshell mode.


    1. Open up Terminal in /Applications/Utilities

    2. Type the following command:     sudo nvram boot-args="iog0x0"

    3. Press return

    4. You will see a warning about using the sudo command. PLEASE make sure you typed the command into Terminal correctly. Mispelling sudo commands can     be... dangerous.

    5. Type in your password to confirm and press return.

    6. You should see Terminal move to a new line.

    7. Restart your Mac and the Snow Leopard functionality should be restored!


    Note: Resetting the PRAM will erase this modification. If you are ever told by Apple to reset the PRAM or need to do so for another reason, you will have to repeat these steps again. The mod holds as long as the PRAM is kept intact!

    If the command did not work after restarting, reset your PRAM by holding Command, Option, P, and R after turning your computer on. You can release the buttons when you see the screen light up.

  • RobertCailliau Level 1 (0 points)

    Great solution!

    I am still struggling with migration to Lion (I will not elaborate here why), and I noticed this behaviour after opening the lid.

    I normally work at my desk, with the laptop on a shelf behind my 2560x1600 screen + keyboard + mouse.

    Occasionally the fans come on, and I then open the lid to let it cool better.

    If the screen then comes on, as it does by default in Lion, the machine then works even harder!

    But in addition, my mouse can then get "lost" on the laptop's screen, which I can't see.


    At least Lion leaves the menu bar on the external screen...


    Beware: "before we reach the mountain of artificial intelligence, we have to cross the wilderness of the half-witted machines"





Previous 1 13 14 15 16 17 Next