Previous 1 18 19 20 21 22 Next 383 Replies Latest reply: Dec 20, 2013 6:34 PM by louisinhongkong Go to original post Branched to a new discussion.
  • Laurent-C Level 1 (0 points)

    The trick I posted (ctrl-shift-eject + close and reopen), does not work anymore on OSX Lion last update (10.7.5)



  • Felix Lieb Level 1 (0 points)

    Confirming boot-args solution not working anymore in 10.8.2. MBP (6,2) goes to sleep all the time.


    I won't express my anger, as so many people did it before me.


    I hope to find a solution, soon.


    This is not "keep it simple", this is PATHETIC! RIDICULOUS! Ups. Now I expressed a tiny bit of my anger anyways 8o)

  • Leeroy21 Level 1 (0 points)

    Hey guys,

    not sure if you all have already worked this out but there is a genuine fix for this and it is alot simpler than you may think. This is my first post here so im not sure if i will be breaking any rules but i have a link to a site where they explain this extremely simple work around.

    Can you let me know first if i will be breaking any forum rules by posting an external link in here...





  • flnm Level 1 (0 points)

    Well, you don't have to post a link here. You could describe a search-term for searching a popular search engine. For example: search for "please fix the iphone", first hit. ;o)

  • Leeroy21 Level 1 (0 points)

    well i found a way to do this when i used put on my searching glasses and oogled over my screen using the search term;




    i found the first link extremely helpful

  • Felix Lieb Level 1 (0 points)

    None of those work on 10.8.2


    The only way it currently works for me is to reboot with the boot-arg.


    When waking the MBP up from standby with the lid closed, it will go back to standby immediately. When I open the lid after waking up from standby, the internal screen is switched on. So it's only possible by rebooting with the lid closed. After booting it can be opened and won't be turned on.

  • Fix The Bugs Please Level 1 (0 points)

    Agree, this is total rubbish. I am definitely taking back the MBPr I just bought over this stupid bug that NOTHING can fix. There is no hack, I tried everything from boot-arg to SwitchResX display controller.


    It is impossible to play any games, the frame rate just gets cut in half from the internal display being on. Dimming it does not help except if you are watching a movie and the frame rate doesn't matter.


    Total joke. Enjoy losing £2000 apple.

  • Fix The Bugs Please Level 1 (0 points)

    I forgot the real dealbraker though, there is no way to set a normal mouse acceleration curve. The mouse in Mountain Lion is absurdly laggy and uncontrollable. The trackpad works beatifully, but use the magicmouse and you will instantly feel the pain of rsi. You can install tools to make it better, but it is imperfect. Considering they want to convert windows users so much, a simple "make mouse accelleration like windows" would make sense.


    You could control external monitors in windows 3.1, why is such rage allowed to occur for me in 2012?

  • flnm Level 1 (0 points)

    Well... your response is obscure.


    If you buy a Mac for playing games, maybe that is the first error. Games for Mac are very often poorly ported versions of the Windows-Game. That's the game-developer's fault. If you want to play games with good performance on a Mac, there's no way but using Bootcamp. Within Windows you then have no problem with external monitors and mouse acceleration. Mac's Mouse-acceleration indeed is no good for gaming. But if your focus is  gaming at all, you could buy a **** of a gaming-machine for that money, even mobile.


    The boot-args thing works well, when rebooting everytime you want to use only the external screen. Shutdown, restart, close the lid when the reset actually takes place and wait until your logged in. After that you can reopen the lid.


    I don't know which mouse-behaviour you are describing. General mouse behaviour in the system is as normal as it has been in the past. If you describe the mouse-behaviour in games, well, again, it's the developer's fault of poorly porting their games. Trine & Trine 2 is a good example. I had a laggy, sluggish, unusable mouse. Counterstrike worked well, but the Mac's mouse acceleration disturbs a lot in games, that rely on mouse-precision and training so much. Other games, like EVE, WoW or GW work well as related to the mouse, but poor as related to the performance in comparison to the Windows-Clients.


    I don't really know, why I am typing all that ****. People writing that irrational either don't want to know how things work or they are viral marketing-agents trying to discredit the competitor.


    I'm no Mac-evangelist, but as a developer I am a power-user and I've been using all three big systems. The Mac is THE FORCE regarding work, while Windows is THE FORCE regarding gaming and Linux is THE FORCE regarding servers. So the conclusion of this digression is: Diversity is the key 8o)


    Back to the problem: We can't use external screens with the lid of our MBs open under 10.8.2. If any one knows a solution, please post it here. And Apple: SHAME ON YOU.

  • Fix The Bugs Please Level 1 (0 points)

    By games I mean online poker with a hud overlay, and 8 bit emulations. The video card is fine for one display, not two in this situation. Windows XP is a little bit faster in bootcamp for these things, but it still has the same problems. The good news is in XP you can shutoff one monitor. The bad news is that everything else is terrible on windows.


    I am working on 10.8.2, there is no solution. The boot-arg command does not work. Even if it did, that wouldn't be acceptable because I would have to use another command to undo it every time I disconnected the laptop form the monitor. I wish I could install snow leopard on this MBPr, at least I know that I could operate in clamshell mode (which was still less than ideal).


    When you are multitasking, running two monitors adds a bunch of extra heat. Things are much snappier when the laptop is cool. I have ice packs I switchout from underneath the laptop to improve performance. I think I wouldn't need to do this if there were the ability to shut off the internal display.


    I didn't buy this machine to multi-monitor, I knew that would be a stretch. I used to have a 4 monitor setup, but that strained my neck and made me tire faster. I found by improving my use of the desktop this was alleviated. I am much happier with one display, and OSX gives you spaces and hot corners to make life easy.


    re: mouse issues, The devloper of the mouse problems is Apple. It is really annoying just browsing, you always miss things because of the illogical slowspeed behaviour. If you used a mac for WoW you must have a high tolerance for pain, I couldn't imagine it. I know that most ports make open gl look incapable, but it is just ****** afterthought development.


    The mouse issue is just so stupid when they made the best trackpad ever. I use a mac to not only play poker, but multi-task my daily workflow. There is no doubt OSX is superior for workflow, but a basic input is crippled from laziness in part of Apple. This has been an issue since 2007.

  • flnm Level 1 (0 points)

    Now that sounds better 8o)


    Well, I wouldn't write, that Bootcamp-Windows performs better with games, if I didn't try the Mac-Versions/Clients/Ports. I always try them, to find out, if there's finally  a good one.


    I don't have the problems with mouses, they work well for me. I liked the Magic Mouse at my office-iMac so much, I bought one for my MBP at home - when using external screen. I think it depends on individual preference.


    In fact, I only have this silly problem with external screen+open lid.


    To bring readers back on topic: There has been a workaround for that by setting a boot-argument, as discussed here, that stopped working since 10.8.2. Further more it's pathetic, that there's no simple control, that the user doesn't have the choice, ever since. Solutions? Anyone?

  • J. A. Thomas Level 1 (0 points)

    Ok guys!


    Lets keep this simple,


    This solution has always worked for me:


    1) Close the MacBook lid (just use the auxiliary monitor)


    2) Run a Game with a different screen resolution setting ( e.g,: I use Steam's Back to the Future)


    3) Once you're in the game and notice the change of size in the image, open the lid (it'll remain dissabled!!)


    4) Exit the Game.



  • Gontzal Level 1 (0 points)

    This worked for me:


    Start up the MBA with the external monitor pluged in and close the lid before the grey screen appears.

    Let the computer run and open the lid

    It works until the MBA enters sleep mode.

    If you awake the MBA it will recognize both mointors, but if not, it will work only with the external monitor.


    Good luck!



  • Godoy12 Level 1 (0 points)

    Gontzal and J.A. Thomas, it doesn't work for me in 10.8.2


    This is the last Mac computer I buy until they fix this... maybe I'll go back to Linux altogether.

  • scarlac Level 1 (15 points)

    I tested this with Diablo 3. Closed lid, started Diablo, opened lid, closed Diablo. Screen kept off.

    Another benefit is that the trackpad and keyboard on the laptop still works with this workaround.


    The fullscreen-workaround is in contrast to the current workaround I was employing: a simple magnet. The magnet trick also works just fine for most people and is quite harmless. The screen has magnets built in, which is how the laptop senses you have closed it, and which is why that workaround also works. Magnet trick is simpler to use, but some people are naturally afraid of putting a magnet on their machine even though there are already plenty in the screen.



Previous 1 18 19 20 21 22 Next