Previous 1 21 22 23 24 25 26 Next 383 Replies Latest reply: Dec 20, 2013 6:34 PM by louisinhongkong Go to original post Branched to a new discussion.
  • code.samurai Level 1 (0 points)

    I recently accidentally discovered a way to turn off the primary display on my MBP late 2011.  Confirmed that this trick works on OSX Mountain Lion 10.8.2.  Note: If you ran the NVRAM command line hack before this then you would need to disable it.  See the solution posted by chenga.8 in: https://discussions.apple.com/thread/3190417

     

    This method has been posted somewhere in this thread earlier, but wasn't able to do it earlier.  First thing that you need is a game app that has a full screen mode (Note: not windowed full screen but actual full screen).  Games I've used for this tricks are Warcraft 3, Zen Bound 2 and possibly Civilization 4 (not quite sure about the last one).  Any game could work as long as it blackens the primary LCD when the game goes full screen.  Here are the steps:

    1. Close the lid on the MBP, this will put it in clamshell mode.

    2. Run the game in Full screen mode.

    3. While the game is running, open the lid of the MBP.  You will notice that the primary screen is still turned off.

    4. Quit the game.

     

    You'll notice after the 4th step that the primary display of MBP is still turned off after you quit the game.  When you need to restore the primary display, just close the lid and open it again when no fullscreen game is running.  Enjoy.

  • TRON Level 1 (20 points)

    I haven't been able to test this, but I used Apple's sample code for a full-screen app to make a dummy app that launches in full screen.  If anybody would like to try it, it should be available for download here:

     

    https://www.box.com/s/wy1v7j2hpxvrps3z44de

     

    The app will just launch a graphic of a spinning globe in full-screen, so you can try the steps from code.samurai, et al., [above], without having to run a game.  Good luck!

  • TRON Level 1 (20 points)

    Okay, my first try at that full-screen app didn't work, so I've uploaded a new version that should work (fingers crossed!); it's at the same link [above].

  • nickfin Level 1 (0 points)

    So a solution - but it costs

    SwitchResX   http://www.madrau.com/indexSRX4.html  does the trick

    Nick

  • scarlac Level 1 (15 points)

    I'm currently working on a small program that does nothing but display a blank screen and instructions on what to do. The whole process takes less than 10 seconds (launch+open lid+press escape), and then you're good to go.

     

    I will post a link when it's done.

  • scarlac Level 1 (15 points)

    Hello everyone

     

    I have created a small program to fix the issue per sesssion:

    http://www.seph.dk/blog/uncategorized/clamshell-mode-with-open-lid-in-mountain-l ion/

     

    Once downloaded: Close the lid. Launch the program. Open the lid. Press escape.

     

    The method is the same as the one code.samurai mentioned. This is a replacement for launching an entire game.

     

    Regards

    Seph

  • guguii Level 1 (5 points)

    thanx so much!

    I  like the icon

  • Laurent-C Level 1 (0 points)

    Hi, Seph,

     

    I just tried your little app, but it seems to be for Mountin Lion only.

    Is it possible to make it compatible with both Lion and Mountain Lion ?

     

    Laurent

  • alsax Level 1 (0 points)

    IT WORKS. GENIUS

  • scarlac Level 1 (15 points)

    Laurent, do you get an error when launching? I am very new to Mac development, and I tried to create a version that worked for both Lion and Mountain Lion but was unsuccesful. I don't have a Lion installation at hand. Write to me, then I'll work on a version that works for you as well.

  • Laurent-C Level 1 (0 points)

    Seph, it simply refuses to launch with a popup saying "You have OSX 1.7.5. This application requires OSX 10.8+"

    I never built an OSX app before, but I'm a developper so this shouldn't be that complicated. If you're ok to share your source, and maybe some guidelines to build it, I can give it a try.

    my email laurent.chaply at gmail.com

     

    Laurent

  • alsax Level 1 (0 points)

    you need to change the deployment target from "Current Mac OS" to 10.7. If you don't use functions of the 10.8 SDK you are safe leaving the Base SDK as it is.

  • scarlac Level 1 (15 points)

    I re-uploaded a version with 10.7 as minimum version. Clear your cache and re-download to try again.

  • scarlac Level 1 (15 points)

    Ok. Done. I just had some issues trying to run the app myself. Kept getting a version error if I changed stuff to 10.7. I guess I changed too much . It should work for Lion users now.

  • Laurent-C Level 1 (0 points)

    No luck here.

     

    I cleared my cache to be sure to re-download the latest version, but still the same error.

    MD5 (ClamshellOpen.app.zip) = 6b1ac279c4112d16a2baa0de59491f42

    is this the correct version ?

     

    Laurent