Previous 1 22 23 24 25 26 Next 383 Replies Latest reply: Dec 20, 2013 6:34 PM by louisinhongkong Go to original post Branched to a new discussion.
  • macison Level 1 (0 points)

    Yes, I just reconfirmed. I'm running 10.8.3 on a MacBook Pro, and when I shut the lid, the monitor turns off, and the computer goes to sleep (as I would suspect most people would want; I wish Apple would expose more switches in their Energy Saver system prefs in the first place).


    Anyway, it works for me.


    Greg Dixon

  • code.samurai Level 1 (0 points)

    lol, I think there is some confusion here with macison's post.  What he's saying is he wanted his MBP to go to sleep even when an external monitor is connected by just closing the lid on his MBP.  And that chenga.8's solution worked for what he wanted.


    The problem is that in this thread we don't want our MBP to go to sleep, what we want is to turn off the built-in display of our MBP while the lid is open.


    Anyway as an update to this thread, I'm still running 10.8.3, I wish I can regress back to 10.8.2 where I can do the fullscreen app trick.  Sometimes when I wake my MBP from sleep the built-in display is turned off and it's not available from the Display Preferences, when I close the lid and open it again the built-in display is still turned off.  It's like I still have my ear-pod connected to my MBP's lid sensor, if you know what I mean.   Although I still can't tell exactly what I'm doing that's somehow "turning off" the built-in display, however when I put it to sleep again and wake it up the built-in display becomes available again.


    Maybe some of you can do further experiments with this and find out exactly how to turn-off the built in display while the lid is open?  This would really be useful.

  • thekitch Level 1 (0 points)

    The nvram trick seems to have worked perfectly for me on my mid-2009 MBP 13 running 10.8.5. Thank goodness! I need all the extra performance and cooling I can get when driving a 27" external display.

  • StevePlease Level 1 (0 points)

    Also works on my 13 inch, mid 2012 running 10.8.5 with the nvram trick. Thanks everybody!

  • Man Bui Level 1 (0 points)

    Thanks, PDzero, for the tip. Works great with my 2012 MacBook Air (SSD drive and Mountain Lion).


    The reason I want to turn off the LCD while still having the lid open is it gets much better wifi reception (primary motivation) and the machine runs much cooler and quieter due to less fan action (secondary motivation). I use my MBAir in home office mode where there's always an large external display attached.  I wanted the external display to be the only active display so it gets the fullest resolution from the MBAir graphics subsystem.


    So, per PDzero's tip, I'd boot up or wake the Air to a login screen while the lid is down. (If powering on, you'd have to open the lid, press the power button, then close the lid back down.) So now I'm on my external display and keyboard/mouse while at the login screen, and the lid is down. At this point, the Air sees that only the external display is the active one, as you would expect. Then I'd select my user account, enter my password, and the moment right after I hit the Enter key on my password, I flip the lid open ... quickly. 


    Apparently, if you flip open the lid within this little window of time, the machine does not detect that the lid has been opened and therefore does not activate the LCD screen. It remains dark, the way we want it.

  • Namarillo Level 1 (0 points)

    Hi, I just tried the NVRAM trick on Mavericks but it doesn't work (in Lion and Mountain Lion it works fine for me). Anyone have an idea?

  • dg4prez Level 1 (0 points)

    I just use a small magnet, like a fridge magnet or something similar.  Put it on the edge of the keyboard tray near the SD card slot and it'll think the screen is closed and turn it off.

  • Namarillo Level 1 (0 points)



    Sorry, I just did a typo error in the Terminal the first time.... Just fix it and now I can confirm that the NVRAM trick also works on Maverics.

  • louisinhongkong Level 1 (0 points)

    Upgrading to OSX Mavericks solved this problem for me too. And it was free.

Previous 1 22 23 24 25 26 Next