Previous 1 2 Next 29 Replies Latest reply: Jul 8, 2013 5:37 AM by AGREM Go to original post
  • AGREM Level 1 Level 1 (0 points)

    On our end, it was recommended to start Safari in 32-bit mode, and that seems to work reliably MOST of the time.  On occasion, I get the Java loader running, but netconnect simply doesn't get launched.  If I close Safari and re-open it and start again, it works fine.

     

    Also, not sure if others have this ability, I saved the Juniper Netconnect to my dock, and I have launched

    it directly and that seems to work reasonably well too -- it skip[s starting the browser and having it try and launch the client.

     

    Environment:  Lion w/7.1 upgdate, Safari 5.1 (7534.48.3), Network Connect 7.0.0 (17289)

  • bedelman Level 1 Level 1 (10 points)

    Interestingly, after well over a week of this not working for me, I switched Safari over to opening in 32-bit mode and I could get a VPN connection working. BUT only if I went through the browser -- and I can live with that for now. Thanks!

     

    If I try to go directly by launching the dock icon I also created for Network Connect (which is what I had been doing for years), it does not work. Instead I get a message from Network Connect that states...

     

    ---------------------

    Setup Control

     

    You are not allowed to launch software downloaded from the following server. Contact your system administrator for assistance.

    ---------------------

     

    - Bob

  • mccu7pj2 Level 1 Level 1 (15 points)

    On a new machine (Lion, no Java) I needed to:

     

    1) Install Java

    2) Check "Enable applet plug-in and Web Start applications" in /Applications/Utilities/Java Preferences

    3) Check that "Enable Java" was checked in Safari's preferences

     

    Then:

     

    4) Browse to the VPN page (e.g. vpn.yourdomain.com/connect)

     

    First time around, I hadn't enabled Java, so I had to click past the "Host Checker". At this point I could see the greyed out embedded applet in the page. I could click on there, be prompted to switch on support for Java applets in Safari, and then it worked immediately (downloaded Network Connect and logged me in - I'd already entered my credentials in step (4)).

  • Samuel Chambers Level 1 Level 1 (40 points)

    Just to say that mehaase's recommendation worked perfectly for me.

     

    I'm running 10.7.1 and Firefox 7.0.1. Didn't mess with any other preferences, just trashed network connect, ran terminal commands, and then let it reinstall. Network Connect 7.0.

  • yupster13 Level 1 Level 1 (0 points)

    Many thanks to joebella and mehasse. Turning on the Develop menu in Safari and selecting the user agen 5.0.6 and removing and reinstalling NC as mehasse explains makes my iMac very happy, and me too.

     

    mehaase

     

    I was having a similar problem with NC after upgrading to Lion. Here's how I fixed it:

     

    1. Drag "Network Connect.app" to Trash.

     

    2. In terminal, run these two commands:

     

    sudo sh /usr/local/juniper/nc/install/uninstall_nc.sh

    sudo rm -fr /usr/local/juniper

     

    3. Reinstall Network Connect. (The easiest way to do this is to go your VPN web site and login. On my site after I log in, it automatically reinstalls Network Connect.)

  • blueowl14 Level 1 Level 1 (0 points)

    Hi, I'm having the same issues.  Only when I enter the user name / pw info it's telling me invalid user name or pw.

    I'm working in Lion with the latest updates. Java latest updates and Juniper 7.6.

     

    I've tried enabling the java "enable applet plug-in and web sstart applications".  No dice.

     

    Thanx Much

  • etresoft Level 7 Level 7 (27,125 points)

    No. You are having a completely different issue. You will need to remove that latest Java update and install the previous one. See this thread: https://discussions.apple.com/message/16695172#16695172

  • robfromfalls church Level 1 Level 1 (0 points)

    The problem:

     

    On Lion with Juniper Secure Application Manager and I get this nasty error when I try to Start JSAM:

        This browser does not use the Cocoa Java Plug-In.

        1) Make sure that the JVM 1.4.1 or later is installed

        2) Check that this browser supports Java for Cocoa (such as Safari)

    The fix:

     

    After trying many solutions including straight Safari 5.0.5, Java6+Java7+Safari 5.0.5, chrome, firefox, old webkit builds from the correct 5.0.5 era, I decided to read the source.

     

    Turns out this is a trivial problem. The developer of the browser detection logic decided to check for the literal existence of a plugin file called "JavaPluginCocoa.bundle" which was important for java functionaly back in the day. However, that bundle is no longer needed to run java in osx browsers apparently. So, if we put a fake file in it's place, the detection logic doesn't get angry and all is well.

     

    The steps

     

    1. Change to the plugin directory in the finder: "/Library/Internet Plug-ins"

     

    2. Duplicate the file "JavaAppletPlugin.plugin" (CMD-C then CMD-V, or Right click copy, right click paste, ...)

     

    3. Rename the new copy to "JavaPluginCocoa.bundle" (no quotes)

     

    4. Restart your browser

     

    Profit!

  • rivimont Level 1 Level 1 (0 points)

    Hi,

    I've read through this entire thread.

     

    I am at a point where:

    - I can launch NetworkConnect fine if done through a browser as the admin user or as my local account (which is an admin).  This involves me logging into my company's web site and clicking a button which looks to load an applet which then calls NetworkConnect.  No problems here.

    - I can launch the NetworkConnect app directly through spotlight with no problems as the administrator user.

    - If I try to launch the NetworkConnect app through spotlight from my local account (which is an admin), than I get the following error message:

     

    Setup Control

    You are not allowed to launch software downloaded from the following server. Contact your sytem administrator for assistance.

    Server Name: http://vip.mycompany.com/

     

    Maybe, I am just being too picky but I would prefer to launch NetworkConnect directly from spotlight instead of logging into my company's site and launching it. 

     

    I have tried yupster13's suggestion, but this only works for me once.  If I try to run the app again, I get the sae error message unless I repeat those steps as root.  I have also tried modifying access to the app to give everyone Read+Write permissions but this didn't help.  Anyone have any more suggestions?  Thanks.

  • Kongair Level 1 Level 1 (0 points)

    Hi!

    I had the same problem on my mbp 15 w/retina with Lion 10.7.4, Safari v6.0, and juniper NC v7.0.

    Thanks to Mehaase and others, I got it to work now.

    I got stuck on the Loading Component page after I entered my credential to my company VPN.

    I went ahead and downloaded Network Connect to my Mac thinking that would help but it did not work as expected.

    These were steps I took to resolved my problem:

    First, I checked the "Enable applet plug-in and Web Start applications" in Java Preferences (under Utilities).

    Note that I have both 64 & 32 bit Java 1.6.0_33-b03-424 selected and the preferred orders is 64-bit first.

    Second, I uninstalled the Network Connect program. I could not find the ".app" program but I ran the two sudo commands to uninstall the program, See Mehaase note.

    Third, I reset Safari and started over again from my company VPN login screen.

    I was prompted to allow the applet to access my computer, I entered yes.

    Next, it installed Host Checker.

    Then it asked me to allow the download, install, and run the Network Connect app as the final step.

    It works great now, thanks to everyone who shares the ideals and workarounds.

    I hope this continue to work with the next upgrade to  Mountain Lion.

  • AaronB816 Level 1 Level 1 (0 points)

    mehaase wrote:

     

    I was having a similar problem with NC after upgrading to Lion. Here's how I fixed it:

     

    1. Drag "Network Connect.app" to Trash.

     

    2. In terminal, run these two commands:

     

    sudo sh /usr/local/juniper/nc/install/uninstall_nc.sh

    sudo rm -fr /usr/local/juniper

     

    3. Reinstall Network Connect. (The easiest way to do this is to go your VPN web site and login. On my site after I log in, it automatically reinstalls Network Connect.)

     

    This worked perfectly for me too.  Thanks!

  • LizzieHarry Level 1 Level 1 (0 points)

    Thank you Thank you.  This worked! 

  • kamd123 Level 1 Level 1 (0 points)

    Please provide any ideas you have re: Network Connect and Snow Leopard OS 10.6.8.

    No longer able to connect after updating to OS 10.6.8, even after IT help, which included updating JAVA software and changing its settings.  Problems started a few weeks after the update (another mystery). Using Sarfari Browser ver 5.1.9. Also tried with Firefox, and same problem (error message: failed to load).

    Any ideas you have much appreciated.

  • Hozay Level 1 Level 1 (10 points)

    I'm running OSX 10.8.4 and Safari 6.0.5, so I'm not sure whether my experience and yours will be the same.

     

    A few weeks ago, I installed an Apple Java update.  I believe it was version 2013-003.  After that, Netowrk Connect would no longer connect to my company's VPN.

     

    After a bunch of searching for answers, I found this: http://support.apple.com/kb/HT5559?viewlocale=en_US.  I did as instructed and Network Connect worked again.

     

    When Apple Java 2013-004 was released, I disabled the Java SE 6 web start, installed the latest Apple Java release, and everything still worked with Network Connect.

     

    Good luck!

     

    Hozay

  • AGREM Level 1 Level 1 (0 points)

    The article mentioned does the trick -- it seems Juniper has not yet seen fit to update their host-checker to support newer versions of Java.  So if your company has a requirement to execute the host-checker before finalizing a VPN connection, you're stuck with working around things.

     

    Here's a script I use that is based on the kb article -- I keep this one under my home account for work, and execute whenever a new update comes out from Apple that breaks things again.  At some point, we expect to get the newer Juniper software, but until then, this is what we've been doing.

     

    #

    #  script to manipulate Safari/Java settings so Corporate Juniper

    #  client will work.  These instructions came from the Apple Support

    #  site, and can be found at http://support.apple.com/kb/HT5559

    #

    #  Note:  rm -r command was added beccause once this process has

    #         executed, the disabled directory is not empty, and things

    #         don't work properly unless it is

    #

    sudo rm -r /Library/Internet\ Plug-Ins/disabled

    #

    sudo mkdir -p /Library/Internet\ Plug-Ins/disabled

    #

    sudo mv /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin /Library/Internet\ Plug-Ins/disabled

    #

    sudo ln -sf /System/Library/Java/Support/Deploy.bundle/Contents/Resources/JavaPlugin2_NPAPI .plugin /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin

    #

    sudo ln -sf /System/Library/Frameworks/JavaVM.framework/Commands/javaws /usr/bin/javaws

    #

Previous 1 2 Next