5 Replies Latest reply: Jul 22, 2011 2:08 AM by Soaper
thumper_net Level 1 Level 1 (10 points)

Having searched through google for hours without any answers i will try here.

before i upgraded to osx lion today i had a perfectly working system , where i could choose mac or windows through the alt button on start up.

after upgrading to lion the options i have are mac or recovery hd , windows has gone from the choice , i do not want to re install windows by formatting my

hard disk as i have photos and important files on my windows side of my macbook pro.

i can see in the disk utility the windows partition but this cannot be mounted ( if i could then i could copy the files over and start again.

my question is does anyone know how to get the option back to boot into windows ?

if it is not possable is there a way to return my mac to snow leapard where everything worked ?

this problem has happened on 4 macbooks , 2 macbook pro's and 2 white macbooks all have windows 7 on the second partition ,

The other macbooks are from friends who upgraded to lion when it appeared on the mac appstore , the one thing in common is all the macbooks

had the bootcamp to boot into osx .

This seems to be a huge bug in lion as i have in the past upgraded my old macbook from leopard to snow leopard without loosing windows ,

any ideas anyone on how to get my windows back ? or atleast to be able to save my photos.

being in holland we have no real apple stores so i cannot go to an apple store for help .

thanks for any ideas or solutions


MacBook Pro, Mac OS X (10.7)
  • benjaminfrombunschoten Level 1 Level 1 (0 points)

    I have the exact same problem as you have. I already posted this on another forum but since this is the official Apple support forum I'll post the details again:

     

    I installed windows 7 under Snow leopard but despite me using bootcamp, I reformatted the partitions during setup since bootcamp made 2 other useless partitions that cost me a lot of storage space for no apparent reason plus the one it made for me was not formatted correctly according to the Windows setup. I erased all three and made a new formatted one.

     

    Windows 7 installed just fine but if I wanted to boot up I had to hold the option (alt) key at boot-up to see both my Mac and Windows 7 partition. Everything worked just fine and bootcamp under windows 7 worked just fine as well.

     

    Now that I installed Mac osx Lion I no longer see my Windows 7 partition. Disk Utility shows the partition as Disk0s4 and when verifying the disk it says it needs repairing.

     

    Anything that was important for my studies I have on Dropbox so if all fails I can just reinstall and lose no data. However I am hoping that this is not necessary. I'm not a big fan of having to reinstall my software all the time.

     

    If anyone has a solution for my problem I would be glad to hear it. But, most likely I will have reinstalled before that since that would solve it right away for me. It's just going to be a hassle again.

     

    P.S. I can relate to your problem thumper_net, having photos and other personal stuff makes it really hard to just reformat and lose everything. I had to do that once and that's when I bought a Time Capsule, also, all the personal photo's and stuff on my mac are stored in iPhoto since it's the main operating system.

     

    If Apple or anyone else can't find a solution then you can try a company that specialises in retrieving data from damaged HDD. But that's expensive. Hope Apple comes through on this one and you get your photos back.

  • benjaminfrombunschoten Level 1 Level 1 (0 points)

    Hi thumper_net,

     

    I just ran across this thread: https://discussions.apple.com/message/4490343#4490343.

     

    Basically, If you let Windows format the partition (lik I did) You're in a really bad position and reinstall seems the only answer to this situation. From what I read I think it has something to do with Lion installing a recovery HD of 600 mb. It messes with the partitions.

     

    To finish of I would like to quote Brian Reading: "It looks like the moral of the story here is: "Don't let Windows format your partition!". Apparently, it doesn't know how to work with the GPT/MBR hybrid (or at least not all the time)."

     

    Sorry to be the bringer of bad news. Of course, if you used bootcamp in setting up your Windows partition. Something else might be wrong.

  • Bryan Crow Level 1 Level 1 (0 points)

    I have the same problem. This is ********. I've been ******* around with TestDisk for hours trying to recover, but it seems the recovery partition was placed squarely in the middle of the NTFS partition. What a piece of **** thing to do! Has anyone figured out how to recover any of the files from the now unmountable windows partition?

  • thumper_net Level 1 Level 1 (10 points)

    Apple show no interest in this problem , as its windows based , the only option is to reformat the windows partition and reinstall again , so any data , photos ect are lost forever , i did comment on the mac appstore about the problem but my complaint was removed , seems apple dont want anyone to know of the problem , something they should warn users of , the os itself i have found also to be very buggy , and the ios look it has is also not very good as the photo or background you have is bluured and not sharp as it is on the normal mode , overall i regret updating as the os does not live upto the hype it gets and with the loss of windows it makes this a joke and an expensive $30 , with all the lost data and for some photos that cannot be saved , apple should advice people to first back up thier windows side incase this happens to them , or remove the os until the bug has been fixed

  • Soaper Level 1 Level 1 (0 points)

    Ta for the info. This happened to me when I installed Snow Leopard, I lost the partition and all my files in my Windows 'side'. Then it wasn't compatible with XP. I finally bought Windows 7 this week and repartitioned my HD and installed using bootcamp, all so I could do my tax, and I really don't want to go through it all again!!!