Skip navigation

Wifi Constantly Dropping in Lion

522509 Views 2,266 Replies Latest reply: Mar 28, 2014 2:35 AM by WSR RSS Branched to a new discussion.
  • benjikan Calculating status...
    Currently Being Moderated
    Dec 26, 2011 2:30 AM (in response to Jean-Yves Vienne France)

    Thanks to Rys Sommerfeldt.  But it does not work on my Mid 2011 iMac.  In fact it made matters worse.  I had to manually connect to Wi-Fi.  I re-installed Lion.  Wher is the fix Mac?

  • flynod Calculating status...
    Currently Being Moderated
    Dec 26, 2011 3:13 AM (in response to lhale)

    Thanks Rys Sommerfeldt your fix seems to have worked for me.my only reservation now is when the update does eventually come out will the "downgrade" to the snow leopard driver have any implications on the Lion 10.7.3 upgrade that I assume will include the lion wi fi issues we have experienced?

  • Froggy Grodkin Calculating status...
    Currently Being Moderated
    Dec 26, 2011 7:46 AM (in response to ferkijel)

    Hi ferkijel

     

    You are absolutely correct I do not know if the OP has read all the information. I was taking issue with the fact that all reported successes were being discounted without any explanation of how the findings were arrived at. Comments of that type show that nil intelligent use has been made of what has been garnered from the research.

     

    I think we may have different understanding about the issue of Wi If dropping?

    I am not an expert, previously being merely a sufferer like hundreds of others here and having climbed out of the ‘pit’ just wish to see others doing something similar.

     

    With reference to your points:

    ferkijel wrote:

    ..............

    Now, the reason for my reply: your workaround (the magic DNS thing) points out that either:

    1) Your problem was between your router and your ISP, not between you and your router, as seems to be the case for 99.9% of the people complaining about this issue

    2) Your problem was solved because of another "fixes" you tried.

    ..............

    Firstly is seems that you are not accepting that there are many successes, I would agree that there are not enough recorded and that is why I made comments about those who have previously posted here so that we can get a better understanding of what is happening.

     

    I can absolutely confirm that my Wi Fi disconnected on a very frequent basis.

    To qualify this the Menu Bar Icon, as most already know, shows varying numbers of Black Bands when operational and all Gray Bands when it is not functioning.

    Less often, in my case, when not functioning this Icon showed all Gray with the addition of a Gray Exclamation Mark.

     

    The act of Switching Off and then Switching On the Wi Fi within System Preferences > Network, restored the Wi If connection to my Router Modem and web pages would be available for me to access again for varying periods before the occurrence of the next drop out.

     

    Are you really saying that I did not have a Wi Fi dropping problem?

    I admit it was a little like a nightmare, and most of us would like to wake up and find it was not reality, but the issue was always there next time I started the Mac.

     

    Not that I feel the need to further qualify what I was experiencing however allow me to relate a short story on the subject:

    At present I am undertaking a project which causes disconnection from the Internet for infrequent very brief, e.g, 7 seconds to 15 seconds, but these breaks are sufficient for my ISP to take action and reduce my connection Speed drastically.

    During the period of my Wi Fi issues there was no such intervention by my ISP and I can assure you that when the Wi Fi dropped it often took considerably longer for it to be reset. The Router Modem to Internet connection remained unbroken and this appears to be confirmed also by my Sam Knows Reports that utilise data from a Modem monitoring my Internet connection information 24/7.

     

    Like you I deployed alternative solutions and for a period my Internet connection was via Ethernet Adaptors over the Power Supply in my house.

    Every time I tried to use Wi Fi to connect the dreaded dropping was there waiting for me.

    When I had the time to research the subject again I found directions to utilising two instances of Terminal to Ping simultaneously a known good source and the Router in use. I wish I could locate the article again to place a link for it and give credit to the originator.

    The response times could be seen on a very regular basis to be rapidly increasing every ## seconds from e.g, the normal low values up to 200+ms, with both Terminal screens displaying similar results in unison. This slowdown in Ping rate then returned to normal and so the cycle continued.

    On many occasions there was an actual disconnection at the peak of the slow response times recorded.

    One of the notes in the article said that anyone using this method should keep in mind the requirement not to Ping the external source continuously.

    The actions I have described above ceased the Wi Fi dropping issues, it has remained so for the period stated.

    However I am aware that no condition is permanent and the issue could resurface, hopefully by that time [if it ever arrives] my Computer Room refurbishment will be complete and I will be connected by cable once again.

    Perhaps several members have reported success with DNS alterations because they actually did see that their Wi Fi was no longer dropping?

     

    I consider that not having any lasting success with the earlier solutions and then having a longish break because of other commitments rules out the possibility of what  you are implying by:

     

    2) Your problem was solved because of another "fixes" you tried.

     

    I am sorry you consider that I am cluttering up the list with a non proven solution, it was the first and only attempt after taking up the quest again. There is absolutely nil possibility that any other intended ‘solution’ played any part in the outcome.

    If you want to explain why it is such a waste of time and effort then please do so, many of us here are eager to learn something new.

    In the meanwhile I would suggest that given the time needed to enter a couple of DNS Addresses with the possibility of it lasting a good while, like it has for me, seems like a pretty good return on the investment?

    If it does not work it is easy to return to the original settings at a total expense of a few minutes key pressing, with no cash exchanging hands.

  • ferkijel Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 26, 2011 10:15 AM (in response to Froggy Grodkin)

    No, Froggy, I'm not implying or trying to discredit ANYTHING you said, in any way.  Please be aware the a forum post doesn't show body language, and please believe me when I say I relate to just about everything you described. I had the same exact issues, and I'm sure we both felt the same way until we managed to work around the issue.  We even wired the Mac at one point in time ! 

     

    My only point is that the DNS (which stands for Domain name system) is just like a white-pages of websites.  Basically it's a server (or groups of servers) that keep a big table in which they "translate" URLs (www.something-something-something.com, or whatever domain it is, be it .org, .edu, .co.uk, etc) to an IP address. That is all they do (actually there is a bit more of info other than the IP, but it's pointless to discuss in this thread).  These servers reside at your ISP and beyond. 

     

    What this means is that whatever DNS you told your Mac to go to, it needs to be actively connected to the internet to be able to reach it, whether it's your ISP's, Google's (such as 8.8.8.8 and 8.8.4.4), or anyone else's.  What I meant specifically by Your problem was solved because of another "fixes" you tried is simply that: that changing the DNS couldn't possibly help you keep your WiFi alive.  I truly and honestly don't believe changing DNS helps in any way, and thus think we should spare people the needless effort. I agree with you, it IS just a few minutes pressing, with no cash exchanging hands.  But I don't think it helps in any way.

  • Peter Saukov Calculating status...
    Currently Being Moderated
    Dec 26, 2011 8:09 PM (in response to lhale)

    Had the same problem for several weeks. Than I set up "channel width" on my router to 20 MHz as it recommended here: http://support.apple.com/kb/HT4199

    and now everything is fine.

     

    Set to20 MHz
    DescriptionChannel width controls how large a "pipe" is available to transfer data. However, larger channels are more subject to interference and more prone to interfere with other devices. A 40 MHz channel is sometimes referred to as a wide channel, with 20 MHz channels referred to as narrow channels.
  • klampert Calculating status...
    Currently Being Moderated
    Dec 28, 2011 12:42 PM (in response to klampert)

    I've updated the one click workaround I posted on October 30th to an automatic workaround.  After a few days of testing it appears to be working well.  My network connection used to always drop after my iMac had fallen asleep.  Since implementing this workaround I haven't had any issues.

     

    Here are steps to implement an automatic workaround in case it's helpful to anyone here:

     

    1. Run a text editor (like Text Edit or Text Wrangler) and copy/paste the following Bash shell script into it:

     

    #!/bin/bash

    #

    # This bash script checks to see if the Wifi connection is present.  If it's not then

    # it turns off interface "en1", then turns it back on, effectively restarting the

    # WiFi connection just as if you clicked on your WiFi icon and selected "Turn

    # WiFi Off" then "Turn WiFi On".  Your WiFi interface may be different than "en1"

    # so you might need to change that part of the script.  To see what it might be,

    # open a terminal window and type ifconfig.  This will show you a list of your

    # network interfaces.  While on WiFi, find the one whose status is active and has

    # an inet address similar to "192.168.1.101" or perhaps "192.168.0.101".

    #

    IFS=$'\n'  # Tell bash to ignore spaces and tabs; use new lines as a field separator instead

    RESULT=($(ifconfig en1 | awk '/inet/ {print $2}'))

    if [ "$RESULT" = "" ]; then

        echo "No Network.  Restarting..."

        networksetup -setairportpower en1 off; networksetup -setairportpower en1 on

    else

        echo "Network OK"

    fi

     

    2. Please read the comments in the script and, if necessary, change your interface from en1 to the correct one. Save the script (e.g. CheckWifi.sh) to a folder where you can find it later (e.g. /Users/klampert/Scripts)

     

    3. Schedule the script to run periodically.  I've set mine to run once every minute using the older free version (v2.1) of Lingon.  Note: you can now purchase v2.2 ($5) or v3 ($3) of Lingon in the App Store.  Reviewers have noted v3 doesn't have as many features so I'm sticking with v2.1 for now.  Alternatively you could schedule the script to run using OS X's built-in Cron scheduler.  Here's how to set it up in Lingon:

     

     

    WiFi.png

     

    4. After setting up the schedule you may need to logout and login again or reboot before it starts working.  I hope this helps.

  • sblahauvietz Calculating status...
    Currently Being Moderated
    Jan 2, 2012 7:26 AM (in response to klampert)

    I had the same issue, replaced a 20" imac running lion with a 27" imac with lion and on the 27' imac the wifi connection would drop constantly.  After being tired of turning off wifi and turning it on to get the network back, I started doing research.  I found this post and a lot of threads talking about using the Atheros firmware from leopard, etc but that seemed like and extreme step since the only thing that changed was the imac.  The old imac had lion and worked just fine.  Before going to the old driver I would recommend one or both of the fixes below.  They have cleared up my issue.

     

    I am connected to an Airport Extreme 2nd Gen wireless router.

     

    Solution 1 - remove all of your existing wireless settings

    1. Close all windows and applications
    2. go to: System Preferences/Network
    3. Click on "Wifi" then "Advanced"
    4. Delete all wifi networks, apply changes and close out
    5. Click on magnifying glass type in "keychain access"
    6. on left click on "login" and "all items"
    7. Remove any files that relate to your network and router
    8. Click on "system" and remove all files related to your network and router
    9. Close Keychain Access
    10. From Finder menu, Click "Go" then "Computer" then "Macintosh HD" then "Library" then "Preferences" then "System Configuration"
    11. Drag all of the files and folders in this location to your desktop
    12. Restart your mac
    13. Join your network
    14. Validate you are online
    15. put your mac to sleep
    16. Wake it up
    17. validate that the wifi connects and you are online
    18. Move the old system config files to the trash

     

    Solution 2 - Enable Interference robustness.  If like me you are using the 2.4GHz b/g/n channel because the 2nd gen router doesn't have dual bands

      1. open airport utility, go to "wireless mode"
      2. Open "Wireless Network Options"
      3. click on "Use Interference Robustness"
      4. Click "Done" and then "Apply"

     

    This may shorten the distance of your signal slightly so if distastance is important to you this may not be ideal.

     

    These changes have cleared up my issue, I hope this helps

  • PharaohNuff Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2012 12:27 PM (in response to sblahauvietz)

    Had written my reply and it seems its the same as sblahavietz!!

     

    This solution (number 1) worked for me too (I cribbed from a few different posts, but sblahavietz has summarised nicely).

     

    Only one additional point - make sure you delete anything got to do with your wi-fi from the Keychain - there may be one or two that are named something slightly different - particularly if you have tried numerous options (like me!).

     

    Hope this helps.

  • bigdawdog Calculating status...
    Currently Being Moderated
    Jan 4, 2012 11:21 AM (in response to lhale)

    This worked for myself and a friend, both running the latest verision of Lion.  Many of the BT Openzones and free wifi zones were using the same channel my router was also set to.  I suspected the power from the Openzones was swamping my iMac and thus, my iMac was constantly 'hunting' for the stronger openzone signal. 

     

    Deleted network settings and then changed my channel within router configurations; this was done before Xmas and I have not lost an internet connection to date!  Suggest that people having problems with internet dropping out, check whether there are other networks in your local area transmitting on the same channel as your router (many apps allow you to check this on your phone).  If you note that there are Openzones sharing the same channel as your router, then I suggest that you enter your router configuration menu and change the channel which your iMac connects to.  Hope this is of some help and apologies if this has already been covered.

  • the_mbwd Calculating status...
    Currently Being Moderated
    Jan 4, 2012 8:54 PM (in response to benjikan)

    Me too.  Anyome else use Rys' "fix" and then have Lion not automatically connect to WiFi on wake from sleep? 

     

    That is now my problem:  Rys seems to have fixed the intermittent dropping WiFi problem by downgrading the driver to Snow Leopard, but now WiFi does not connect on wake from sleep.

     

    Anyone have a solution to this new problem???

    benjikan wrote:

     

    Thanks to Rys Sommerfeldt.  But it does not work on my Mid 2011 iMac.  In fact it made matters worse.  I had to manually connect to Wi-Fi.  I re-installed Lion.  Wher is the fix Mac?

  • the_mbwd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 4, 2012 8:57 PM (in response to klampert)

    klampert:  is there a way to write that code so that it not only restarts WiFi -- but also rejoins your primary network?   Thanks.

    klampert wrote:

     

    I haven't found a solution to this issue that works for me yet, so until it's fixed I've created a simple workaround that allows me to restart my WiFi connection with one click from the dock.  In case it might help someone else, here's how to do it:

     

    1. Start Automator (found in your Applications folder)

     

    2. It will ask you to "Choose a type for your document"; select "Application".

     

    RestartWiFi 1.png

     

    3. In the Actions list (the second column) scroll down until you find "Run Shell Script".  You can also type "Run Shell" in the search box above the second column to quickly find it.

     

    4. Drag the "Run Shell Script" action to the right-hand spot that says "Drag actions or files here to build your workflow."

    RestartWiFi 2.png

     

    5. Replace the text that says "cat" with this line:

     

    networksetup -setairportpower en1 off; networksetup -setairportpower en1 on

     

    * Note: this is a bash script that turns off interface "en1", then turns it back on, effectively restarting the WiFi connection just as if you clicked on your WiFi icon and selected "Turn WiFi Off" then "Turn WiFi On".  Your WiFi interface may be different than "en1" so you might need to change this part of the script.  To see what it might be, open a terminal window and type ifconfig.  This will show you a list of your network interfaces.  While on WiFi, find the one whose status is active and has an inet address similar to "192.168.1.101" or perhaps "192.168.0.101".

     

    6. In the Automator application, select File > Save from the menu and give your application a name (e.g. "Restart WiFi"), a folder to save it in (e.g. "Scripts"), and use the file format "Application".

     

    7. Now navigate to the folder you saved the application to and double-click it.  You won't see any windows open but you should see your WiFi connection disable then re-enable itself:

     

    RestartWiFi 4.pngRestartWiFi 5.png

     

    8. By default your application will have an Automator icon.  To make it a little more recognizable you can change it to a WiFi icon (I found a nice one at iconfinder.com).

     

    9. To run the application from your dock with a single click you simply need to drag it there.  Now when you find your WiFi connection has dropped, just click on it and your connection will reset in a few seconds:

    RestartWiFi 6.png

    I hope this helps.

  • Rico1111 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2012 3:57 PM (in response to sblahauvietz)

    Mr. Sblahauvietz,   Thank You, Thank You, Thank You! Your 1st Solution has worked for me and I no longer am having any dropped connections nor do I have to shut down nor do I have to go to network panel to get assisted to join ............all of these things and more have been my daily ritual since installing Lion!!!! I have posted your solutions in another forum also about wifi connections in Lion ..it is also here on the Apple community boards ...so many people are having issues since lion and I for one am relieved that this is a fix...I am keeping my fingers crossed so I don't jinx myself. I followed everything the way u outlined but have to add if anyone else does this...When I got to step 11 and dragged my folders and files to the desktop, The same set of folders and files were only copied to desktop ..but not removed!  I then went ahead and restarted and went through the rest of the steps and had a brilliant connection...was just wondering though if they were supposed to be completely deleted from the System configuration folder? because as I said it looked like they were still in there.....and yes they were also on my desktop from me dragging them there. and then deleted after I had tried the wake experiment. All I know is it did work!!!

    Thank U again!

  • Rico1111 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 7, 2012 9:53 PM (in response to Rico1111)

    Wanted to update.......My connection is still GREAT!!!! I am in lion and Mr,Sblahauvietz u r a genious! Thank you again. I hope u don't mind ..I have been posting your post on other lion wifi problem threads.

  • albertocampo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2012 11:08 AM (in response to Rico1111)

    Hi everyone!!!!!!!!!!!!!!!! I have just tried the solution proposed by Sblahauvietz and everything seems going well (by now). I hope it keeps on working.

     

    +100 points to Sblahauvietz for his contribution. A pleasure to have somebody's help, even though it fails.

    -100 points to Apple. A complete disaster. A 1500€ computer can't have this kind of problems. It's unacceptable.

     

    Kind regards.

  • delventhalz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2012 11:26 AM (in response to sblahauvietz)

    I have been plagued by this issue for months (in my case the iMac consistently forgot my wireless network at log-in and on waking from sleep). What finally fixed it for me? Switching my wireless security on the base station from WEP to WPA2.

     

    Since so many people have had trouble, I'll go ahead and post links to all the various fixes I tried before I fixed it with the security switch. Maybe one of them will help you too.

     

    Some links:

    A collection of a variety of possible fixes big and small:

    http://osxdaily.com/2011/07/22/wifi-dropping-in-os-x-lion-fixes/

     

    Reparing permissions in Recovery Mode:

    http://blog.chron.com/techblog/2011/09/want-to-really-repair-permissions-on-your -mac-try-this/

     

    Renewing DHCP lease:

    http://osxdaily.com/2011/11/06/lion-wi-fi-problems-solution-mac/

     

     

    And you might try any of the following (most have instructions in the links above):

    - Repair disk permissions (both with Disk Utility and in Recovery Mode)

    - reset Airport Express to factory settings

    - delete all Network system preferences (locations, preferred networks, etc) and recreate them

    - delete com.apple.aif.plist

    - set a manual IP address with DHCP

    - moved Wi-Fi to the top of the service order list

    - added 8.8.8.8 as an additional DNS entry

    - Renewed DHCP Lease

    - set Configure IPv6 to "Link-local only" (under System Preferences > Network > WiFi > Advanced > TCP/IP)

    - deleting Captive Network Assistant (located in System/Library/Core Services)

    - and of course, switching my wireless security from WEP to WPA2 (which is finally what worked for me)

     

     

    Also, I didn't personally try this solution, but sblahauvietz posted this one on this very forum topic, and it seems to have helped out quite a few people:

    sblahauvietz wrote:

     

    I had the same issue, replaced a 20" imac running lion with a 27" imac with lion and on the 27' imac the wifi connection would drop constantly.  After being tired of turning off wifi and turning it on to get the network back, I started doing research.  I found this post and a lot of threads talking about using the Atheros firmware from leopard, etc but that seemed like and extreme step since the only thing that changed was the imac.  The old imac had lion and worked just fine.  Before going to the old driver I would recommend one or both of the fixes below.  They have cleared up my issue.

     

    I am connected to an Airport Extreme 2nd Gen wireless router.

     

    Solution 1 - remove all of your existing wireless settings

    1. Close all windows and applications
    2. go to: System Preferences/Network
    3. Click on "Wifi" then "Advanced"
    4. Delete all wifi networks, apply changes and close out
    5. Click on magnifying glass type in "keychain access"
    6. on left click on "login" and "all items"
    7. Remove any files that relate to your network and router
    8. Click on "system" and remove all files related to your network and router
    9. Close Keychain Access
    10. From Finder menu, Click "Go" then "Computer" then "Macintosh HD" then "Library" then "Preferences" then "System Configuration"
    11. Drag all of the files and folders in this location to your desktop
    12. Restart your mac
    13. Join your network
    14. Validate you are online
    15. put your mac to sleep
    16. Wake it up
    17. validate that the wifi connects and you are online
    18. Move the old system config files to the trash

     

    Solution 2 - Enable Interference robustness.  If like me you are using the 2.4GHz b/g/n channel because the 2nd gen router doesn't have dual bands

      1. open airport utility, go to "wireless mode"
      2. Open "Wireless Network Options"
      3. click on "Use Interference Robustness"
      4. Click "Done" and then "Apply"

     

    This may shorten the distance of your signal slightly so if distastance is important to you this may not be ideal.

     

    These changes have cleared up my issue, I hope this helps

     

     

    Good Luck! Lion is a huge turd we're all stuck with now!

1 ... 68 69 70 71 72 ... 152 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (82)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.