Previous 1 119 120 121 122 123 Next 2,266 Replies Latest reply: Mar 28, 2014 2:35 AM by WSR Go to original post Branched to a new discussion.
  • jhendrich Level 1 (0 points)

    FYI> With my IMac running Lion (10.7.4), the only thing that allows me to keep connected wirelessly is to have ping running in the background in a terminal window, pinging the router IP address.  Otherwise, it constantly loses the connection to my Linksys WRT110, running firmware version 1.0.07 (the latest as of a month ago).  I'm on channel 7 at 20MHz.  Like so many others, my other apple devices (macbook pro running snow leopard, IPad2, IPhone, and Apple TV) all are stable in their wireless connection.  Just the IMac running Lion has th e problem.

  • Big Red Dog Level 1 (0 points)

    I like that idea of a continuous ping. I've tried everything else on the MacBook and MacPro and nothing works. Did you write a script for the Terminal or are you using an App that you found?

  • McPeluz Level 1 (0 points)

    Screen Shot 2012-05-20 at 00.15.57.png
    Here the screenshot of automatic location item deleted.
    Finally I've decided to downgrade io80211 kext to snow leopard version 10.6.4 as suggested by others before in this thread (I followed instructions from this article: l).
    By now, it's about 2 hours that I'm using heavily wireless connection making a full time machine backup to nas without droppings!
    I'll let you know if this is just a rare case or if wi-fi has become really stable...
    I hope this can help even others.
    Thank you all

  • jhendrich Level 1 (0 points)

    @Big Red Dog


    I just open a terminal window, type in ping and away she goes.  ping doesn't stop on macs unless you terminate it with Ctrl-C.  I just remember to do it manually every time I reboot, but after that it's just in the background; it picks back up after sleep.


    It's a hack of a solution, but I'm too lazy to hassle with gathering data and more phone calls with tech support.

  • McPeluz Level 1 (0 points)

    Well, finally wifi connection drops less often than before but it is still an issue for me even after driver downgrade . Rarely it is possible to switch back connection on without rebooting lion, but unfortunately downgrading to snow leopard driver version did not represent a final solution.

  • osoriojr Level 1 (0 points)

    Hi All,


    If you updated from 10.7.3 to 10.7.4 and then got wifi dropping problem, look the posts at this thread

  • Billjacobson Level 1 (0 points)

    I hope that this is still working for you?   I can't get a connection to update...  €{%|>£#]{* hard to believe that this problem continues

  • wifiguru Level 2 (240 points)

    Have you checked if there is a firmware upgrade for your Linksys AP ?

  • luiz.kato Level 1 (0 points)

    Hello! I set my wifi router to only works with the G network mode, not N, and the drops are gone. It's not the best solution, but at least my Imac isn't dropping all the time. It's a linksys router.



  • Dirk Junghans Level 1 (5 points)

    Really annoying,

    new MBP (2 weeks old) running Lion 10.7.4 and I have to face constant dropping WIFI connections :-(  Same network with a second MBP running Snow Leopard without any Wifi issues! I changed the router channels and installed a new “location” without any improvement.

    Well done Apple :-)

  • MikeN1805 Level 1 (0 points)

    Yes - it is annoying. Wondering when this issue is going away....


    I was running 10.7.3 earlier and updated to 10.7.4 end of last week. Since then my WiFi connection dropped constantly ... again... as I had the same issue with 10.7.1 and 10.7.2 earlier. To solve it, I changed the router configuration (AVM Fritz 7270) to stop using "optimized 300 mbit/s channels". This solved the problem.


    As I switched the router software end of last week too (same time as switching to 10.7.4), "usage of 300mbit/s channels" was ticked again. Once I switched it off again (this morning), WiFi seems to work again... (at least so far for a few hours without interruption).


    As you seem to be based in Europe, you may try to avoid usage of channels 12 and 13 for WiFi...


    Hope this helps to sort your issue.

  • Big Red Dog Level 1 (0 points)

    I'm willing to try the same thing. I have a Linksys E3000 (802.11  a, b, g, n compatible. Where within the router's admin pages do I turn off "n"., leaving the other standards unaffected?  thx

  • Billjacobson Level 1 (0 points)

    Latest iMac WIFI to Verizon MIFI disconnecting issue and solution :


    After two days of no disconnects, I think I've found a solution!  (knock on wood)  A level 1 tech at Verizon suggested trying a Wireless USB adapter with Mac OS drivers.


    I purchased a Wireless N USB adapter (Airlink 101) for $13 at Amazon which included Mac OS drivers on a CD and the connection is working fine.


    With gratitute for Verizon having tech folk to at minimum, "LISTEN" TO THE ISSUE,  I can put this time consuming wifi problem behind.  Apple may want to take note ... if anyone is listening ????

  • handi Level 1 (0 points)

    maybe its not imac/Lion issue. i got wifi drops on ipad, iphone or imac. the common is the Time capsule gen4 with Firmware 7.6/7.6.1.


    after crashed Time Capsule Gen1 (works fin over 3 Years) i get a new TC gen4. now i have Wifi drops during time periods other peoples are coming home (evening) or weekends.


    same place, same neighbors but other Time Capsule. Apple support could not help, tried all forum posted ideas, changed to all channels ... nothing is helping. changed the TC same issue.



    the old TC gen1 hat a wifinoise iinterferenc button under 7.5.1 Firmware, the new TC gen4 does this Version no mor support, with 7.6 and above is this noise-buttom no more available.


    i think its not imac/lion issue, id could work, but nothing is shure. changing neighbors and tomorrow you have wifi drops. i'm locking furture with apple support, but this guys in front does not understand the issue ... box back to sender .. this does apple not interest.


    why apple is changeing running modes - not allways new is better

  • MichelA Level 1 (25 points)

    Some people have changed the MTU setting in

       System Preferences -> Network-> Airport 

    down from 1500 to (customized) 1280 and saw

    their wireless issues solved. I'm one of them.