Skip navigation

Wifi Constantly Dropping in Lion

524454 Views 2,266 Replies Latest reply: Mar 28, 2014 2:35 AM by WSR RSS Branched to a new discussion.
  • djiti Calculating status...
    Currently Being Moderated
    Jul 21, 2011 12:51 PM (in response to wifiguru)

    My router is a Cisco/Linksys WRT160Nv2 running v2.0.02. My Lion is migrated from SL.

    The problem happens both in (WRT160Nv2 side) mixed mode and b only.

    I tried the "last resort" of removing the plist files, it did not help.

    I am running WPA2-personnal that usually works fine.

    This is not a DNS problem, as pinging my default gateway by IP address breaks.

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Jul 21, 2011 2:15 PM (in response to djiti)

    djiti, whats your Transmit Rate at ? Clicking on the WiFI Menu Extra when connected will give you the RSSI,Transmit rate and MCS info.

  • scottshaun Calculating status...
    Currently Being Moderated
    Jul 21, 2011 2:22 PM (in response to lhale)

    My 2010 MBP was doing the same thing, but once I reset my router to it's factory settings everything seemed alright. May want to give it a try.

  • Sheila2 Calculating status...
    Currently Being Moderated
    Jul 21, 2011 8:50 PM (in response to lhale)

    adding my "me too"; I don't have the technical expertise to try most of the fixes here. Installed Lion last night; ended up with 3 drops today. The drop seems to occur for no particular reason and uneven intervals. The only way I can re-connect to the internet is by rebooting both the router (from Verizon FIOS) and the computer. Somewhat annoying. I'm hoping for an upgrade to fix this VERY soon!

  • Darryl Mylrea Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jul 21, 2011 8:58 PM (in response to Sheila2)

    Despite what others say here about adding a "me too", I believe it it quite helpful to post your "me too" message.

    The more that post they have the problem, the more weight is put on the conclusion that it's really a Lion issue and gives a better idea as to the amount of people having the problem.

     

    Workarounds?  Not interested.  Given the sheer number of people posting this error, multiply by magnitudes the actual number of people having the problem and not reporting it, and we're looking at a 10.7.1 fix is required. 

     

    It not any particular Mac model, or any particular wifi router model, or anything specific.  Everyone reports perfect wifi with SL but Lion is wifi unstable.

     

    Apple needs to fix this and now.  Really makes one wonder what kind of QA testing they do.  This should have been caught. 

  • TheAmdMAN Calculating status...
    Currently Being Moderated
    Jul 21, 2011 9:03 PM (in response to Darryl Mylrea)

    Me three... Tried the all of the hold key resets, deleting plists, removing systemconfiguration folder and nothing has worked.  Mine is 802.11n - 5ghz wireless SSID which drops every minute or 2.  Haven't gotten more than 3 minutes out of it.

     

    Console logs say:

     

    7/22/11 12:01:00.000 AM kernel: wl0: Beacon Loss Event

     

    then this:

     

    7/22/11 12:01:00.000 AM kernel: AirPort: Link Down on en1. Reason 4 (Disassociated due to inactivity).

     

    Can we get a break down of how many people with this issue installed from scratch?  Curious if it's just an upgrade issue...  I was an upgrade from SL 10.6.8.  Absolutely no issues on SL.  Also have 3 Macs in the house, after the upgrade all three exhibit the EXACT same issue.

  • dsun84 Calculating status...
    Currently Being Moderated
    Jul 21, 2011 9:19 PM (in response to TheAmdMAN)

    Hey,

     

    I'm sorry that I opend another threat yesterday. I haven't seen this one here. Here is my wifi.log:

     

    Thu Jul 21 13:13:23.685 <configd[15]> _bsd_80211_event_callback: LINK_QUALITY (en1)

    Thu Jul 21 13:13:28.685 <configd[15]> _bsd_80211_event_callback: LINK_QUALITY (en1)

    Thu Jul 21 13:13:38.435 <configd[15]> _bsd_80211_event_callback: BSSID_CHANGED (en1)

    Thu Jul 21 13:13:38.435 <airportd[484]> _handleNewMessage: received XPC event for pid 15, <dictionary: 0x7f9e1a100560> { count = 3, contents =

    Thu Jul 21 13:13:38.435           "_eventType" => <int64: 0x7f9e1a100380>: 3

    Thu Jul 21 13:13:38.435           "_interfaceName" => <string: 0x7f9e1a100400> { length = 3, contents = "en1" }

    Thu Jul 21 13:13:38.435           "_command" => <string: 0x7f9e1a1004a0> { length = 12, contents = "DRIVER_EVENT" }

    Thu Jul 21 13:13:38.435 }

    Thu Jul 21 13:13:38.435 <airportd[484]> _processDriverEvent: BSSID changed

    Thu Jul 21 13:13:38.435 <configd[15]> _bsd_80211_event_callback: Frequency Band updated <1>

    Thu Jul 21 13:13:38.435 <configd[15]> BluetoothCoexHandleUpdateForNode: <en1> Handle Bluetooth Coex: FrequencyBand <1>, Bluetooth Isolation Mode <4>, Clamshell Mode <0>

    Thu Jul 21 13:13:38.435 <configd[15]> isBoardIDEqualTo: <Mac-F42C8CC8> found a match? <0>!

    Thu Jul 21 13:13:38.435 <configd[15]> isBoardIDEqualTo: <Mac-F42D88C8> found a match? <0>!

    Thu Jul 21 13:13:38.435 <configd[15]> isBoardIDEqualTo: <Mac-F42D88A9> found a match? <0>!

    Thu Jul 21 13:13:38.435 <configd[15]> isBoardIDEqualTo: <Mac-F22C86C8> found a match? <0>!

    Thu Jul 21 13:13:38.435 <configd[15]> isBoardIDEqualTo: <Mac-F22C86A9> found a match? <0>!

    Thu Jul 21 13:13:38.435 <configd[15]> isBoardIDEqualTo: <Mac-F22C8AC8> found a match? <0>!

    Thu Jul 21 13:13:38.435 <configd[15]> isBoardIDEqualTo: <Mac-F22C89C8> found a match? <0>!

    Thu Jul 21 13:13:38.435 <configd[15]> isBoardIDEqualTo: <Mac-F22589C8> found a match? <0>!

    Thu Jul 21 13:13:38.435 <configd[15]> isBoardIDEqualTo: <Mac-F22586C8> found a match? <0>!

    Thu Jul 21 13:13:38.435 <configd[15]> BluetoothCoexModeSet: <en1> does not have BT Coex, do not perform APPLE80211_IOC_BTCOEX_MODE

    Thu Jul 21 13:13:53.403 <configd[15]> _bsd_80211_event_callback: LINK_QUALITY (en1)

    Thu Jul 21 13:13:58.403 <configd[15]> _bsd_80211_event_callback: LINK_QUALITY (en1)

    Thu Jul 21 13:14:08.410 <airportd[484]> ___createTerminateTimer_block_invoke_1: ...exiting

     

    The facts: iMac 2010 27", Router Speedport 920V, everthing else works fine! I loose my connection around all 5 - 10 minutes. But the connection icon still showes that there is a connection. Something crazy, since around 20 minutes I ping a website a DON'T loose the connection.

  • TheAmdMAN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 21, 2011 9:21 PM (in response to TheAmdMAN)

    This issue must be deep...  Booted into Lion Recovery and had the same Wifi dropping issue...

  • archesdevil Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 21, 2011 9:22 PM (in response to lhale)

    Add another, mine has been dropping all day. Running lion on a first gen unibody MBP (core 2 duo), APE with latest update... No issues with SL.

  • Kajuma Calculating status...
    Currently Being Moderated
    Jul 21, 2011 9:40 PM (in response to archesdevil)

    I am also having the same problem with my early 2011 MBP. I had no problem with SL for the past 5 months or so.

  • jasmelthomas Calculating status...
    Currently Being Moderated
    Jul 21, 2011 10:08 PM (in response to lhale)

    This seems to be working for me:

     

    Open System Preferences -> Network

    Click the little gear drop down and choose Set Service Order

    Make Wi-Fi be the top

    Click Bluetooth PAN and then choose Make Service Inactive in the gear drop down button

     

    Of course if you need to use Bluetooth you can try leaving that on. Maybe it's just having Wi-Fi be the top of the service order.

  • djiti Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 21, 2011 10:24 PM (in response to wifiguru)

    wifiguru, here we go:

    WiFi.png

  • Johnny R. Calculating status...
    Currently Being Moderated
    Jul 21, 2011 11:12 PM (in response to lhale)

    I'm having the same problem after the upgrade from Snow Leopard to Lion. I'm on a Macbook Pro 2.66GHz Intel Core i7 with 8GB RAM and a Apple Airport Extreme (4th Gen). This was never a problem before the upgrade so it must be Lion that is causing this annoying thing. My solution is to turn Wi-Fi off and on again - but Apple needs to adress this ASAP!

  • Link48010 Calculating status...
    Currently Being Moderated
    Jul 22, 2011 1:48 AM (in response to lhale)

    I am having this issue as well on one of my Mac's.

     

    I have an iMac, 27 inch Core i3 (no thunderbolt) that was upgraded from snow leopard which does not have the wifi issue. In fact, I use this computer to host several services including web sharing for a personal website for sharing media to my iphone while I am away.

     

    The second machine is a late 2008 Aluminum Unibody Macbook with the 2.0 ghz Core 2 Duo processor. It was a fresh installation of Lion. It has only dropped twice and seems to stay connected most of the time (at least an hour or so between drops).

     

    I may have fixed this by going into Network in System Preferences, under Wi-Fi, click Advanced, and remove all prefered networks and then reconnect to your desired Wi-Fi. I have not had it drop yet, I will keep you posted.

     

    For those interested, I have a D-Link DIR601 supplied by my ISP with custom settings for a DSL over Fiber Optics connection. Encryption is WPA2 Personal, and the router is in the same room as my computers (which rules out interferance.)

  • Link48010 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 1:53 AM (in response to lhale)

    I seem to have discovered another issue I feel is something related. When my Macbook comesout of sleep, it looses Wi-Fi. After trying to reconnect for several seconds, it fails. If I click on the AirPort icon in the Menubar, it looks for networks and only then finds my Wi-Fi and reconnects.

     

    This leads me to believe it is some power saving feature that pauses Wi-Fi when it's not in use, and for some reason it isn't reconnecting properly.

1 2 3 4 5 6 ... 152 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (82)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.