Previous 1 57 58 59 60 61 Next 2,266 Replies Latest reply: Mar 28, 2014 2:35 AM by WSR Go to original post Branched to a new discussion.
  • klampert Level 1 Level 1 (0 points)

    I haven't found a solution to this issue that works for me yet, so until it's fixed I've created a simple workaround that allows me to restart my WiFi connection with one click from the dock.  In case it might help someone else, here's how to do it:


    1. Start Automator (found in your Applications folder)


    2. It will ask you to "Choose a type for your document"; select "Application".


    RestartWiFi 1.png


    3. In the Actions list (the second column) scroll down until you find "Run Shell Script".  You can also type "Run Shell" in the search box above the second column to quickly find it.


    4. Drag the "Run Shell Script" action to the right-hand spot that says "Drag actions or files here to build your workflow."

    RestartWiFi 2.png


    5. Replace the text that says "cat" with this line:


    networksetup -setairportpower en1 off; networksetup -setairportpower en1 on


    * Note: this is a bash script that turns off interface "en1", then turns it back on, effectively restarting the WiFi connection just as if you clicked on your WiFi icon and selected "Turn WiFi Off" then "Turn WiFi On".  Your WiFi interface may be different than "en1" so you might need to change this part of the script.  To see what it might be, open a terminal window and type ifconfig.  This will show you a list of your network interfaces.  While on WiFi, find the one whose status is active and has an inet address similar to "" or perhaps "".


    6. In the Automator application, select File > Save from the menu and give your application a name (e.g. "Restart WiFi"), a folder to save it in (e.g. "Scripts"), and use the file format "Application".


    7. Now navigate to the folder you saved the application to and double-click it.  You won't see any windows open but you should see your WiFi connection disable then re-enable itself:


    RestartWiFi 4.pngRestartWiFi 5.png


    8. By default your application will have an Automator icon.  To make it a little more recognizable you can change it to a WiFi icon (I found a nice one at


    9. To run the application from your dock with a single click you simply need to drag it there.  Now when you find your WiFi connection has dropped, just click on it and your connection will reset in a few seconds:

    RestartWiFi 6.png

    I hope this helps.

  • robtbrodie Level 1 Level 1 (0 points)

    very useful workaround thanks

  • mbeckman Level 1 Level 1 (0 points)

    OS X Lion + U-Verse WiFi router. Wifi intermittently dropped every 20 minutes (on the dot) after resuming from sleep (overnight and/or after lunch). Rebooting U-Verse router would usually fix it, but that was a lousy "solution".


    Things I tried first: Static IP, disabled IPv6, purging firewall plist, and letting U-Verse automatically pick it's channel. I usually tried one change at a time, then see if I had the problem the next day after a nights sleep.


    Yesterday, I decided to stop broadcasting the SSID for my WiFi network, and today I have not had any of the symptoms I had been experiencing. I will report back if the issues return, but so far I have had two long Skype conversations, and I haven't been dropped from either.


    Of course, it could be a combination of the above factors, but if you're still having issues, I would suggest disabling the SSID broadcast.

  • laechleviel Level 1 Level 1 (0 points)

    I did so some days ago (iMac Mid 2010 Core i3 3,2 Ghz; Router: FritzBox 7270 v3). The wifi-connection has become more stable but the problem still appears frome time to time (2 or 3 times within some hours - and when the problem appears the kernel-log still says "en1: The BSSID changed to XXX").

  • Zolwixon Level 1 Level 1 (0 points)

    I have the same problem, wi-fi loses connection about every hour or hour and a half. Apple should check this problem as soon as possible, it's really annoying. If I see that I lost connection to the dropbox, I have to turn on and turn off Wi-Fi to connect again. I have a iMac 27 "Mid 2010 Core i7 - Mac OS X 10.7.2 Lion

  • fudgebrown Level 3 Level 3 (535 points)

    My new remedy: Got a new Dlink router (returned my Trendnet router). The Dlink supports 5ghz ... so far no problems ...

  • ksegers Level 1 Level 1 (0 points)

    WiFi was fine until 10.7.2, after which all h3ll broke loose.


    After 2 hours of testing with Apple Support on the phone, I found the following:


    - moving the MacBook to a spot closer to the router would pick up the network again.

    - plugging in a Seagate GoFlex Firewire 800 drive makes the connection drop IMMEDIATELY and there's no way of reconnecting until it's out. (a different Firewire 800 drive works fine)


    Go figure...

  • Snoop Dogg Level 4 Level 4 (1,265 points)

    lupunus, I don't understand what you're talking about regarding "local" and "home" and BT-Box.  You're mixing up NetBIOS and Bonjour.  Just because the BT-Box uses "home" for its home network doesn't mean that Multicast DNS won't work.  It's also not true that AirDrop requires machines to be in "local" which I assume you mean setting "local" in the WINS section of Network preferences.  The settings in the WINS section have absolutely nothing to do with Bonjour or AirDrop.

  • eviakhan Level 1 Level 1 (0 points)

    I have same problem.  Since upgrading to Lion, my wifi connection drops about every 30 minutes to an hour or so and will not try to reconnect on its own.  I have a lot of hate because of this but my current workaround solution is to open the terminal window and just keep it open with ping  My wifi has not dropped once with this workaround.  If I stop the terminal window, wifi drops again after about 30 minutes to an hour.

  • Pascal Dufour NL Level 1 Level 1 (0 points)

    same issue overhere. Getting realy frustrated. use about 4 difference networks daily .


    MBP I7 2.2 (03-2011)

  • wifiguru Level 2 Level 2 (235 points)


    sounds like some kind of interference from the firewire drive.

  • DrVenture Level 2 Level 2 (180 points)

    Pascal and eviakhan,


    Can you connect to the network that is giving you issues, then open a terminal and issue the following commands:


    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -I

    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -s


    Please copy and paste the above lines into your terminal (one at a time) and hit enter. Then paste the output of the two commands above to this thread.


    Also, when you loose connectivity, is your WiFi icon going grey or have an exclamation point?

  • eviakhan Level 1 Level 1 (0 points)

    @DrVenture - Thanks for trying, here are the results:


    I connect to two wifi networks (work & home) that have the same results of dropping connection.  Each drop produces no error, just loss of connectivity until I reconnect.  The wireless icon just becomes greyed out, no exclamation point.


    this test is from my home wifi network


    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -I


         agrCtlRSSI: -45

         agrExtRSSI: 0

        agrCtlNoise: -89

        agrExtNoise: 0

              state: running

            op mode: station

         lastTxRate: 130

            maxRate: 144

    lastAssocStatus: 0

        802.11 auth: open

          link auth: wpa2-psk

              BSSID: 5c:d9:98:60:b5:92

               SSID: RRFREE

                MCS: 15

            channel: 1


    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -s

                                SSID BSSID             RSSI CHANNEL HT CC SECURITY (auth/unicast/group)

                             WIN_870 34:ef:44:96:2e:41 -87  4       N  US WEP

                          belkin.318 08:86:3b:0d:e3:18 -89  1       Y  -- WPA(PSK/AES/AES) WPA2(PSK/AES/AES)

                             NETGEAR 00:24:b2:50:ca:92 -85  2       Y  -- WPA2(PSK/AES/AES)

                                 TMJ 58:6d:8f:2b:44:a6 -88  11      Y  -- WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP)

                         Belkin.5968 94:44:52:76:a9:68 -89  1       Y  -- WPA(PSK/AES/AES) WPA2(PSK/AES/AES)

                             kobziak 00:1e:2a:5f:57:08 -86  9       N  -- WEP

                          giammarino 00:1e:2a:78:cc:c0 -91  6       N  US WEP

                     Providence Pool 00:18:f8:be:ea:16 -89  6       N  -- WEP

                                ae51 00:23:4d:8b:a5:56 -60  7       N  -- WEP

                              RRFREE 5c:d9:98:60:b5:92 -48  1,+1    Y  -- WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP)


    1 IBSS network found:

                                SSID BSSID             RSSI CHANNEL HT CC SECURITY (auth/unicast/group)

                             hpsetup 2e:24:81:dd:e4:2c -89  6       N  -- NONE

  • Noble Seven Level 4 Level 4 (2,730 points)

    Lion currently lacks support for 802.1X. That is why some of you may be experiencing the constant loss of Wi-Fi, and I am in the same boat as you. Hopefully Apple will address this in the next Lion update.

  • DrVenture Level 2 Level 2 (180 points)

    Wow, you have a busy environment there. Couple of toughts...


    1. Set your router to just do WPA2 Personal (turn off WPA). No need for WPA unless you have a client that can only do WPA TKIP.


    2. Please turn off HT 40 (wide channels) for your 2.4 GHz router. Your Mac will not do HT 40 in 2.4, so it provides no benefit (unless you have a client that does support this). You are also hosing up your neighbor on channel 7 (since his devices will not be expecting your AP to suck up ch 6 (due to HT 40). If you want to use HT 40, I highly suggest you get a 5GHz 802.11N (or dual band) wireless router.


    3. Let's turn up airport logging and see what is going on. Open a terminal and do:


    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport debug +alluserland +alldriver +allvendor +LogFile


    sudo killall configd (please note this will restart your networking stack)


    Once you get connected back to your wireless network, continue on with you Internet activities. When you get a drop, note the time and then copy and paste 3 minutes worth of messages before and after the time your noted from the kernel.log and wifi.log. You can find these logs in your console app (in ultitles). Look for /var/log in the left hand pane of the console log.


    4. What is the make - model and firmware version of your wireless router?

Previous 1 57 58 59 60 61 Next