1 2 Previous Next 26 Replies Latest reply: Jun 12, 2014 10:44 PM by MollyPolly380
reddog708 Level 1 Level 1 (0 points)

I downloaded and installed Lion on my late 2008 mbp with the latest updated snow leopard and after the install, I'm stuck on a screen with icons of my users. If I click nothing happens. I tried repairing disk permissions as well as re-installing Lion but nothing has helped. Any ideas?


MacBook Pro, Mac OS X (10.6.8), late 2008 unibody
  • 1. Re: stuck at login screen after Lion install
    Kappy Level 10 Level 10 (226,765 points)

    You might see if this works:

     

    Clearing Caches to Fix Login Problem

     

    You will need to type some Unix commands. If you are not comfortable with this, I don't know of anything other than a re-install. But if you are careful, you should be OK. I recommend you print this out in a largish mono-spaced font so you don't miss any spaces (or add extra ones). Note that case is important.

     

    Be careful. Some of these commands are dangerous, since you are going to be root.

     

    Start up in Single-user Mode. When this has finished you will see a prompt ending in '#', although there may be other messages. Enter the following commands after the prompt:

     

    /sbin/fsck -fy

     

    Press RETURN. Wait a few seconds for 8-10 lines of output. If the last line says repairs were carried out, repeat this command until you get a message 'The volume <yourdiskname> appears to be OK'. Then continue with:

     

    /sbin/mount -uw /

    cd /Library/Preferences

    rm com.apple.loginwindow.plist

    rm com.apple.windowserver.plist

    cd /Library/Caches

    rm -r *

    cd /System/Library

    cd /System/Library/Caches

    rm -r *

    reboot

     

    Press RETURN after each command.

     

    This should now take you to a proper login screen after the normal boot sequence. You should then Repair Permissions by using Disk Utility (in your /Applications/Utilities folder).

  • 2. Re: stuck at login screen after Lion install
    reddog708 Level 1 Level 1 (0 points)

    This seems pretty dangerous and I don't want to do this unless someone can confirm this is the problem. Any other ideas?

     

    I've read that a lot of people are getting to a login screen where they can enter a username and password, but for me, I only see a screen asking me to chose which login, but aside from the icon for login being selected, nothing happens past that.

  • 3. Re: stuck at login screen after Lion install
    Kappy Level 10 Level 10 (226,765 points)

    Then I suggest you try reinstalling. Restart the computer and after the chime hold down the OPTION key until the boot manager screen appears. Select the Recovery HD icon then click on the downward pointing arrow button. When the menu appears select Disk Utility. Do this:

     

    Repair the Hard Drive and Permissions

     

    After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list.  In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive.  If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the menu.

     

    If DU reports errors it cannot fix, then you will need Disk Warrior and/or Tech Tool Pro to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X.


    Select the Reinstall Lion option and reinstall Lion.

     

    If this does not fix the problem for you, then I recommend you erase the drive and make a fresh installation of Lion. Restore your data from your backups.

  • 4. Re: stuck at login screen after Lion install
    Simon Bedford Level 1 Level 1 (25 points)

    Are you using a bluetooth keyboard or mouse? Coz Lion stops them working so yo can't get by the startup page. I connected a wired keyboard and mouse and all was well,

     

    SBB

  • 5. Re: stuck at login screen after Lion install
    Ian Parkinson Level 6 Level 6 (10,400 points)

    Have you really clicked or do you use soft click (in effect a touch)?

    Under Lion you have to do a real trackpad click on the icon to select it.

  • 6. Re: stuck at login screen after Lion install
    Kappy Level 10 Level 10 (226,765 points)

    My iMac has a BT keyboard and I did not experience any problem. Now there may be problems with third-party BT keyboards, but not with the one that came with my iMac.

  • 7. Re: stuck at login screen after Lion install
    reddog708 Level 1 Level 1 (0 points)

    I've tried everything you guys have said already, except the cache clearing but none of that worked. Here's what did work so far:

     

    I opened terminal from recovery mode and typed resetpassword. This allowed me to access root, which wasn't showing up during login. I reset the password and permissions options and restarted. Now there is a new icon for "other users" which allows me to enter root and log in. This gets me into the OS as root. I can then switch users to my original user, HOWEVER, upon restart, my old users still do nothing when I select them. No password prompty or anything.

     

    Whatever the issue is, it's only in login, because my users work fine in Lion once I'm booted in root. Anyone know how to fix that?

  • 8. Re: stuck at login screen after Lion install
    Gordito73 Level 1 Level 1 (0 points)

    Just to confirm you are not alone, not that it helps, I have the same issue. I installed Lion on my MacBook Air (late 2010) and all went well. A bit hesitant, I did the same on my iMac 27", 16GB RAM, 256GB SSD+2TBHDD with wired apple keyboard and the wireless magic mouse, but things stopped at the login screen. While I can move the mouse around on the screen, I can't click anywhere and the keyboard does not react to anything. The password window has the light blue around it as if it was selected. I only have one user account created so I do not see anything else.

     

    I managed to log in once via Screen Sharing from the MacBook Air, but when I rebooted the iMac the same probleam appeared and I couldn't get to the iMac via the MBA anymore.

     

    I restarted the iMac several times and at times it would let me log in. I noticed that when after the restart the iMac showed "Mouse Connected" I was able to log in and use the keayboard to type the password. If that didn't show, I was stuck and had to restart.

     

    I did reboot into the Recovery partition (by holding Alt during restart) and repaired permissions but this did not help. I also rebooted to the Recovery partition and Reinstalled Lion, but the problem remains the same.

     

    I do not have a solution, but just wrote all details so there is more info available. Any help is greatly appreciated!

  • 9. Re: stuck at login screen after Lion install
    Alay Level 1 Level 1 (25 points)

    @Gordito73: You're not alone, either. I encounter same problem while rebooting my Mac mini and being stuck in the login screen. With Apple bluetooth keyboard, I could select different commands by pressing Up/Down keys, but the "Return" key never functioned. Also, my Magic Mouse didn't react at all.

     

    This problem also came to my MacBook Pro (Unibody, 15"). The Return key on MBP didn't function, and neither did the trackpad. In the end, a wired mouse solved this problem.

     

    How could this happen, I wonder. Apple shouldn't have let this come stupid.

  • 10. Re: stuck at login screen after Lion install
    Casa De Trevino Level 1 Level 1 (0 points)

    Same thing happened to me.  Do this.

     

    When you are at log in screen and it won't respond when you are clicking on the the user icons -

     

    Press Command+Option+Control+Enter

     

    This will bring up a generic login field.  Enter your name and password - boom you're in!

     

    I had to first remove my password in System Preferences under Users & Groups  This would allow Lion to boot up directly, bypassing the login screen.

     

    I then added my password back in system preferences and I am in business!  No more problems to this point.

     

    Hope this works for you!

  • 11. Re: stuck at login screen after Lion install
    Casa De Trevino Level 1 Level 1 (0 points)

    I don't know if removing and changing my password was necessary.  It is just the sequence I went through.  The solution may be this:

     

    Under User & Groups, select Login Options (has little house next to it).

     

    In the Automatic login field, select your name.

     

    This should cause Lion to bypass the login screen when booting up.

     

    After doing this I was able to go back in and turn Automatic login off.  Now at login I get the user login icons at boot-up.  When clicking on them the password field now appears.

  • 12. Re: stuck at login screen after Lion install
    reddog708 Level 1 Level 1 (0 points)

    After getting into my user's desktop, resetting the password, disabling automatic login, and re-enabling it fixed it. I was then able to change my password and now everything seems to work fine. What an insane workaround!

     

    Thanks everyone for your input!

  • 13. Re: stuck at login screen after Lion install
    DJRhinofart Level 1 Level 1 (10 points)

    I have a similar issue. When I enabled Filevault 2 on the whole disk, my Apple Wireless Keyboard and Magic Mouse would no longer function at the welcome screen. When I turned off Filevault, they worked at the Welcome Screen again.

     

    Also, when trying out the workaround on this discussion, my Autologin is greyed out and I can't select it.

  • 14. Re: stuck at login screen after Lion install
    gtmagnet Level 1 Level 1 (20 points)

    DJRhinoFart, what kind of system do you have?

1 2 Previous Next