Previous 1 2 3 Next 130 Replies Latest reply: Aug 7, 2013 1:26 AM by oae__
cp_whaley Level 1 Level 1

This is NOT good.  Granted I keep tens of thousands of messages in dozens of folders, but they're all important to me in one way or another.

 

With the Mail conversion that took place as part of my Lion install (conversion by itself took an hour or two), I was left with a message that said my Mail index was screwed, but that it would be recreated after the next restart.  Not so! Or at least there's no evidence that anything is happening. When I launch Mail, no windows or messages appear... just the bar at the top.  If I right-click the icon in the dock, it says "application not responding". 

 

I know that "application not responding" doesn't always mean that nothing is happening, so I'll probably wait overnight to see if anything has developed by morning.

 

Anyway, I neeed to prepare for the worst. How do I back out of this new Mail app altogether, so that I can restore my email from Time Machine?

 

...Charles

Solved by cp_whaley on Jul 23, 2011 12:45 PM Solved

****... I had a nice detailed version of this prepared and it disappeared before I could click the Add Reply button. I don't have the patience to re-enter it all again, so here's the short version.

 

I started this thread, and I've finally resolved my situation. There are two basic problems it seems.

 

  1. The new Mail fails in the middle of the migration. Some have solved that by quitting Mail and simply deleting the files begining with "Envelope" in the Maildata folder inside the Mail folder in your Library. That resets Mail to try the migration again.
  2. Separately or in combination with #1, when you subsequently launch Mail, only the Mail bar at the top appears.. no mail Window, so you don't know what's going on. This seems to be related to Mail failing to migrate SmartMailBoxes correctly. If you didn't have any before, this probably isn't an issue. Mail goes into an infinite loop trying to do something with SmartMailBoxes, so it has no time to build you a window, and it's even difficult to do a force quit. Force it to quit somehow!

 

If you've experienced both problems (as I have), make sure Mail has been forced to quit and go into Finder>GoTo>~Library/Mail/MailData and remove anything starting with Envelope and anything with SmartMailBoxes in the file name.

 

In my case, the migration routine started again and when it was finished, my Mail window opened with the results. Nice!  I still had to re-enter all of the account info for my dozen accounts or so, but I think the dust has settled.

 

As usual, no guarantees! We're all just users helping users here, so I won't accept liability for anything.  Where I say "delete", just move the files to your desktop. If the solution doesn't work for you, you can always move them back, and you can't blame me!

 

It's a pity that the Apple folks don't seem to read what's going on here and update their support files accordingly.

 

BTW... if this doesn't work for you, there's a long tedious way to do this too... as suggested by others above (in greater detail).

 

  1. Quit Mail, and move the Mail folder with everything in it to your desktop.
  2. Move your email preference file (com.apple.mail.plist) as well to the desktop from Preferences under Library.
  3. Restart Mail

 

As I understand it, this should start mail as if you never had email before. You'll need to set up your account(s), then use Import Mailboxes under the file menu to copy in your messages from within the Mailboxes folder in the Mail folder that you moved to the desktop.  This should be your last resort, since it'll take you forever to get back to where you were just a few days ago with the previous edition of Mail.

 

With all this grief I hope the new Mail really does have some good features, because I'm sure not seeing any yet!

Reply by RodneyW on Jul 20, 2011 4:52 PM Helpful

The only way to revert to the old Mail app is to go back to Snow Leopard.

 

In terms of the problem you are experiencing, if it does not fix itself by running all night, then I suggest that you simply restore your email data from Time Machine and try again.  If it screws up again, we can start troubleshooting from there.

 

Cheers,

 

Rodney

 

p.s. I have migrated 4 IMAP email accounts and 1 Exchange account and thousands of associated emails without a hitch so far - so I am hoping that this is a glitch rather than a systemic problem.  Time will tell!

Reply by The Ambassador on Jul 24, 2011 9:53 AM Helpful

Ok, I have been struggling wiht this nightmare since Thursday, but finally, put all the pieces together from various posts.

 

1. Use the Go to Folder trick to get to your Mail Library, remove the Envelope file

2. EMPTY THE TRASH (this was the clue that made everything work

3. Move the SMARTMAILBOXES files to your desktop

4. Remove the MAIL icon from the dock

5. Launch Mail from Applications

6. Wait until the migration is complete..... this FINALLY worked for me

7. Add Mail icon back to dock

8. Move SMARTMAILBOXES file back the Mail Library

9. Launch Mail

 

Then, you will need to get used to the new Mail UI - yes, it's different and good. I didnt find any tutorials that were worth watching longer than 30 sec.... I figured it out.... you will too.

 

Thanks to all the people who are helping support others (which is why I am wrting this, maybe someone will find it helpful.)

All replies

  • RodneyW Level 4 Level 4

    The only way to revert to the old Mail app is to go back to Snow Leopard.

     

    In terms of the problem you are experiencing, if it does not fix itself by running all night, then I suggest that you simply restore your email data from Time Machine and try again.  If it screws up again, we can start troubleshooting from there.

     

    Cheers,

     

    Rodney

     

    p.s. I have migrated 4 IMAP email accounts and 1 Exchange account and thousands of associated emails without a hitch so far - so I am hoping that this is a glitch rather than a systemic problem.  Time will tell!

  • cp_whaley Level 1 Level 1

    I'll definitely reply with either the overnight results or the solution you suggested.

     

    I assume that would mean a re-install of Lion from scratch? Otherwise how would I get the new Mail app (which isn't working right now) to re-convert my old files?

     

    And, for that matter, this is the first time I've downloaded an OS X version. Can I re-download it without being charged for a second copy?

  • timothy adam Level 1 Level 1

    I receive the following message when I launch Mail and try to upgrade/import:

     

    The import failed.

    An error occurred during the import.  Make sure you have available space in your home folder and try again.

     

    I looked in Console.app (in Applications/Utilities) and found the following error:

     

    Mail: Copy from /Users/myuser/Library/Mail/V2/MailData/Envelope Index to /Users/myuser/Library/Mail/V2/MailData/Envelope Index-4 failed with 14: not an error

     

    It continues to increment each time I attempt to run the import.  The file permissions on "Envelope Index" seem kind of interesting:

     

    myuser (Me) Read & Write

    myuser (Me) Read only

    everyone Read Only

     

    Compared to the permissions of the copies its made:

     

    myuser (Me) Read & Write

    staff Read Only

    everyone Read Only

     

    Does this mean anything to anyone?

  • deivy Level 4 Level 4

    help mail is your friend:

     

    Mail uses files called “Envelope Index files” to keep track of messages in your local mailboxes. If there are problems with information in your mailboxes, you might see an alert message saying that Mail needs to repair your mailboxes by reindexing your messages for you.

    At other times, you may want to reindex messages yourself—for example, when searching mailboxes using Subject, To, or From doesn’t return the correct results.

    1. Quit Mail if it’s open.
    2. In ~/Library/Mail/V2/MailData, delete any file that begins with “Envelope Index,” such as Envelope Index or Envelope Index-shm.Your home Library folder is hidden by default. To display it, choose Finder > “Go to Folder” and then enter “~/Library.”
    3. Open Mail.Mail creates new Envelope Index files. This process may take a few minutes, depending on how many messages Mail is reindexing.
  • deivy Level 4 Level 4

    Timothy,

    Try to repair your permission.

    If you have an ACL found but not expected, let me know.

  • RodneyW Level 4 Level 4

    G'day Charles,

     

    You can download Lion again, but it should not be necessary for this problem.

     

    To restore your email from Time Machine, I would  enter Time Machine from Finder, and browse backwards in time to the last backup under Snow Leopard.  Then select the /Users/yourusername/Library/Mail folder, and restore it.

     

    This will replace your corrupted email store on Lion, and give you the chance to do it again.

  • cp_whaley Level 1 Level 1

    Just a quick update to anyone who may still be following this tonight.

     

    Timothy, I really think that your problem is totally different from mine, so if deivy's suggestion for your issue doesn't work for you, you might get more responses by opening a new topic.

     

    deivy... yes I know there is Help documentation if I could access it. The new Mail is dead to me, including Help. Thanks for copying over the relevant sections.  I tried that without success.

     

    I wish there was something... anything... displayed when I launch the new mail. All I get is the standard bar of menus at the top.. none of which will open. And no windows at all.  You'd think that if it couldn't find mail, it would act like it was starting from scratch... waiting for me to set everything up.

     

    Unless there are any further suggestions tonight, here's my plan...

     

    1. Quit being impatient. At midnight, I'll shut down all apps, do a restart, and only launch the new Mail. I'll repeat deivy's instructions again if necessary to eliminate those files. Then I'll wait to see if it has done anything by morning.

     

    2. Failing that, I'll try Rodney's suggestion on the Time Machine restore, but if the new Mail is totally unresponsive now, I'm sceptical about it reactivating and attempting the conversion again. We'll see.

     

    3. Download and install Lion again. Since I haven't done an OS install from a download before, I assume that the installer isn't still sitting on my Mac somewhere? I'll have to do it from the Mac store again?

     

    More to report tomorrow.

     

    ...Charles

  • deivy Level 4 Level 4

    Charles,

    sorry to hear it is so bad.

    I don't know if you tried  trashing(*) mail preferences file.

     

     

     

     

     

     

     

     

    (*)Trash in this case is quit Mail and rename com.apple.Mail to com.apple.Nail (for instance).

    Now launch Mail. If the probelm persists then you know is not the preferences file and you can rename it to "Mail" s as not to have to do all the selections again

  • timothy adam Level 1 Level 1

    Trashing the envelope files did the trick.  Although, I did try repairing my permissions that did not inevietably solve the issue.  Thanks deivy.  Didn't mean to hijack your thread.

     

    The new Mail is cool. 

  • JasonGA Level 1 Level 1

    I was having the same problem: Upgrade to Lion, run Mail, at various points while "upgrading" my previous emails, Mail.app would just quit.

     

    I did the following, though I don't know if both were necessary:

     

    1. Downloaded SpeedMail.app and ran it. (in short, runss sqlite3 command in terminal)

    2. Removed "Envelope Index" from ~/Library/Mail

     

    Opened Mail.app, and now it is importing 102,000+ emails. Thanks!

  • markfromlynchburg Level 1 Level 1

    I deleted all of my Envelope Index files in ~/Library/Mail and reopened Mail.  IT WORKED!!!

  • DwhiteGP Level 1 Level 1

    deivy, Thank you!!  Although I wasn't able to find my Library in the way you described, I did eventually find it.  Your solution worked perfectly.  Thank you soooo much.

  • Aintree9 Level 1 Level 1

    Hi

     

    Can you help someone totally out of their depth!

     

    When I click on the Mail icon a message box appears:

     

    Restore Windows

    The application "Mail" was forced to quit while trying to restore its windows. Do you want to try to restore its windows again?

    The options are: "Don't Restore Windows" or "Restore windows"

     

    Which ever option I select I get the spinning beach ball and nothing happens thereafter.

     

    I desperately need to access emails so has anyone get any suggestions pleas - I am not very technical so any help would be appreciated.

     

    Steve

  • markfromlynchburg Level 1 Level 1

    Steve,

       I had the exact same thing happen to me.  What I did was:

    1) Quit Mail

    2) Right click on the finder icon in the dock

    3) Choose go to folder

    4) Type in ~/Library

    5) Open the Mail folder

    6) Delete everything that has the word "Envelope Index" in front of it.  (Depending on how far the upgrade process went through you might have to click on the folder "V2" before you do this step)

    7) After you have deleted these files, re-open Mail and it should work.

     

    Hope this works for you too.

     

    Mark

Previous 1 2 3 Next