Previous 1 2 3 4 5 6 Next 130 Replies Latest reply: Aug 7, 2013 1:26 AM by oae__ Go to original post
  • cmsmith Level 1 Level 1 (0 points)

    I'm having the same problem. I reinstalled my Exchange account last night, and now I can only access e-mail on that account that is new from today on. All old e-mail, as well as saved messages I have in sub-folders is not accessable via Mail in Lion. All of my mail is still up on the server, I checked via web access and through Outlook on my windows computer.

     

    Mail was working fine initially for me last night, but I was having calendar issues.

  • cp_whaley Level 1 Level 1 (0 points)

    deivy... the Import Mailboxes routine seems to be working, although it's sure going to take a lot of time.

     

    All of the folders I'm restoring are being put inside of Import folders, so I'll have to restructure everything once I'm done.

     

    It's a pity that this is necessary since everything is already in the same ~Library/Mail/V2/ folder already.

     

    I guess what I'm doing is manually re-indexing everything.

  • faubelster Level 1 Level 1 (0 points)

    Salute to JasonGA. Followed these steps verbatim and viola!...Mail retrieved all of my messages intact.

     

    To kill pesky hidden Library enter the following in Terminal: chflags nohidden ~/Library/

  • chandlerfrombaton rouge Level 1 Level 1 (0 points)

    I am missing my Mail folder in the Library folder. I went to the library folder and looked everywhere for the Mail folder and it isn't there after upgrading to Lion. Regretfully I don't think I have a back-up of all my email (folders that I made in Mail, etc.) Did I lose everything?  HELP!

     

    Thanks

  • deivy Level 4 Level 4 (2,365 points)

    Charles if that is the case, then delete all the Envelope Index, it might build it back with all the messages in the mailbox.

    Reindexing the mailbox might bring back all the messages to the Message Viewer.

    Check my first message with the Mail help.

    It might be faster.

  • jainpiyushjain Level 1 Level 1 (0 points)

    Still indexing and Mail is still migrating data after 30 minutes of starting the app. Please help ?

     

    Below is the text from console;

     

    22/07/2011 01:51:55.200 com.apple.launchd.peruser.501: ([0x0-0xab0ab].com.apple.mail[1022]) Exited: Terminated: 15

    22/07/2011 01:58:07.910 Mail: Using V1 Layout

    22/07/2011 01:58:10.712 com.apple.launchd.peruser.501: ([0x0-0x43043].com.apple.mail[313]) Exited with code: 255

    22/07/2011 01:58:14.830 Mail: Using V1 Layout

    22/07/2011 01:58:21.308 com.apple.launchd.peruser.501: ([0x0-0x45045].com.apple.mail[317]) Exited with code: 255

    22/07/2011 01:58:51.858 Mail: Using V1 Layout

    22/07/2011 01:58:53.249 Mail: Upgrading Library from 4.93 to 4.93

    22/07/2011 01:59:12.162 Mail: unresolvedBaseMailDirectory /Users/pj_scindia/Library/Mail

    22/07/2011 01:59:12.162 Mail: resolvedBaseMailDirectory /Users/pj_scindia/Library/Mail

    22/07/2011 01:59:33.925 Mail: Capturing diagnostics to trace took 21.762702

  • deivy Level 4 Level 4 (2,365 points)

    ChandlerFromBR;

    You do not fool with your computer without backup.

    Anything you do has the potential risk of completely crashing your system, no backup is playing with fire.

    As for your question, I can not tell if you lost or not.

    If it is not here see if you can find it anywhere else.

    Otherwise, Mail is gone.

    Did you open the Mail app?

    If you did it prompt you for your mail accounts?

    If not, it is reading them from somewhere.

     

    ---> I am trying hard to be optimist...

  • AppleStar Level 1 Level 1 (45 points)

    If found another solution for me:

     

    First I only deleted "com.apple.mail.plist" in ~/Library/Preferences

     

    But then I realized I had a "ByHost" configuration left as well, you find it in  ~/Library/Preferences/ByHost and it will have a name like "com.apple.mail.plist.XXXXXX". Make sure you delete it as well if you have one or more there.

  • cp_whaley Level 1 Level 1 (0 points)

    deivy... your latest suggestion made so much sense to me, that I quit the tedious process I was going through, quit Mail, trashed the Envelop files (totally), restarted, and launched Mail.

     

    Now I'm back to where I was at the beginning of this complaint.  I can't open Mail at all (just the unresponsive bar appears at the top), and this time there are no more pesky System Preference Mail accounts to get rid of, because they're already gone!

     

    I tried the Preferences trick again too without success.

     

    The worst part of all this is all the time that I'm losing from the work I should be doing to pay my bills.

     

    ...Charles

  • The Ambassador Level 1 Level 1 (5 points)

    I thought I had this resolved when I removed the Envelope file - Mail then spent an hour importing the mailboxes when it finished, it crashed. So, I removed the Envelope file again, waiting another hour and it crashed.

     

    I went to the Apple Genius bar and they were unprepared for this - 3 people were at the bar with this problem. One Genius said, leave the laptop with us and we will see what we can do. They had no warning about this issue. And there are no support memos on this from Apple - so they are looking at these posts much like you and I -

     

    Hoping someone can help.

     

    This is what I am seeing in Console, which I am running concurrently:

     

    7/21/11 4:12:16.008 PM Mail: *** Assertion failure in -[MFMailMigrator _migrateFromV1ToV2Layout], /SourceCache/Message/Message-1244.3/Library.subproj/MFMailMigrator.m:698

    MailAccounts were initialized before migration from V1 to V2!

    (

        0   Message                             0x00007fff96200fdb -[MFAssertionHandler _handleFailureWithPreamble:description:arguments:] + 116

        1   Message                             0x00007fff96201171 -[MFAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 185

        2   Message                             0x00007fff962050dd -[MFMailMigrator _migrateFromV1ToV2Layout] + 392

        3   Message                             0x00007fff96203465 +[MFMailMigrator migrateFromV1ToV2Layout:isComplex:progressDelegate:] + 87

        4   Message                             0x00007fff961b2146 -[LibraryUpgrader run] + 1590

        5   CoreFoundation                      0x00007fff9543690c __invoking___ + 140

        6   CoreFoundation                      0x00007fff954367a4 -[NSInvocation invoke] + 132

        7   Message                             0x00007fff9604d047 -[MonitoredInvocation invoke] + 196

        8   Message                             0x00007fff96029891 -[ThrowingInvocationOperation main] + 33

        9   Message                             0x00007fff96029837 -[_MFInvocationOperation main] + 449

        10  Foundation                          0x00007fff971c80b0 -[__NSOperationInternal start] + 705

        11  Foundation                          0x00007fff971db3d2 ____NSOQSchedule_block_invoke_2 + 124

        12  libdispatch.dylib                   0x00007fff9248290a _dispatch_call_block_and_release + 18

        13  libdispatch.dylib                   0x00007fff924837e9 _dispatch_worker_thread2 + 255

        14  libsystem_c.dylib                   0x00007fff913343da _pthread_wqthread + 316

        15  libsystem_c.dylib                   0x00007fff91335b85 start_wqthread + 13

    )

    7/21/11 4:12:16.097 PM Mail: *** Assertion failure in -[LibraryUpgrader run], /SourceCache/Message/Message-1244.3/Library.subproj/LibraryUpgrader.m:554

    MailAccounts were initialized before the Library was ready!

    (

        0   Message                             0x00007fff96200fdb -[MFAssertionHandler _handleFailureWithPreamble:description:arguments:] + 116

        1   Message                             0x00007fff96201171 -[MFAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 185

        2   Message                             0x00007fff961b30dd __-[LibraryUpgrader run]_block_invoke_5 + 151

        3   CoreFoundation                      0x00007fff953f9b5c __CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK__ + 12

        4   CoreFoundation                      0x00007fff953b1c52 __CFRunLoopDoBlocks + 322

        5   CoreFoundation                      0x00007fff953d98f6 __CFRunLoopRun + 934

        6   CoreFoundation                      0x00007fff953d9216 CFRunLoopRunSpecific + 230

        7   HIToolbox                           0x00007fff956f24ff RunCurrentEventLoopInMode + 277

        8   HIToolbox                           0x00007fff956f9c21 ReceiveNextEventCommon + 355

        9   HIToolbox                           0x00007fff956f9aae BlockUntilNextEventMatchingListInMode + 62

        10  AppKit                              0x00007fff9165c191 _DPSNextEvent + 659

        11  AppKit                              0x00007fff9165ba95 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

        12  AppKit                              0x00007fff91911a4d -[NSApplication _realDoModalLoop:peek:] + 610

        13  AppKit                              0x00007fff91911681 -[NSApplication runModalForWindow:] + 120

        14  Mail                                0x0000000103c057b9 Mail + 1050553

        15  Mail                                0x0000000103c05671 Mail + 1050225

        16  Mail                                0x0000000103b08aa9 Mail + 15017

        17  Mail                                0x0000000103b0833c Mail + 13116

        18  Foundation                          0x00007fff97196716 __-[NSNotificationCenter addObserver:selector:name:object:]_block_invoke_1 + 47

        19  CoreFoundation                      0x00007fff953ed51a _CFXNotificationPost + 2634

        20  Foundation                          0x00007fff971829cb -[NSNotificationCenter postNotificationName:object:userInfo:] + 65

        21  Mail                                0x0000000103b06b49 Mail + 6985

        22  AppKit                              0x00007fff91660779 -[NSApplication _postDidFinishNotification] + 212

        23  AppKit                              0x00007fff916604df -[NSApplication _sendFinishLaunchingNotification] + 78

        24  AppKit                              0x00007fff9165f250 -[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:] + 242

        25  AppKit                              0x00007fff9165efb1 -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 330

        26  CoreFoundation                      0x00007fff95436f51 -[NSObject performSelector:withObject:withObject:] + 65

        27  Foundation                          0x00007fff971b91c7 __-[NSAppleEventManager setEventHandler:andSelector:forEventClass:andEventID:]_block_invoke_1 + 101

        28  Foundation                          0x00007fff971b814e -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 283

        29  Foundation                          0x00007fff971b7fdc _NSAppleEventManagerGenericHandler + 105

        30  AE                                  0x00007fff98d0da85 _Z20aeDispatchAppleEventPK6AEDescPS_jPh + 200

        31  AE                                  0x00007fff98d0d963 _ZL25dispatchEventAndSendReplyPK6AEDescPS_ + 38

        32  AE                                  0x00007fff98d0d857 aeProcessAppleEvent + 250

        33  HIToolbox                           0x00007fff9570112d AEProcessAppleEvent + 102

        34  AppKit                              0x00007fff9165c3dd _DPSNextEvent + 1247

        35  AppKit                              0x00007fff9165ba95 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

        36  AppKit                              0x00007fff916583d6 -[NSApplication run] + 463

        37  AppKit                              0x00007fff918d652a NSApplicationMain + 867

        38  Mail                                0x0000000103bddc34 Mail + 887860

        39  ???                                 0x0000000000000006 0x0 + 6

    )

    7/21/11 4:12:16.110 PM com.apple.launchd.peruser.502: ([0x0-0x12a12a].com.apple.mail[3004]) Exited with code: 255

  • deivy Level 4 Level 4 (2,365 points)

    Charles, I am really sorry. It seemed to be the right thing to do.

    Apparently something else is hosed in your account.

    The most important stuff is to get you back and working.

    So, here is what I suggest, save all your old mails to a differnet folder/disk/USB/DVD whatever, make sure it is reliable.That is copy everything inside the ~/Library/Mail/V2/ folder to another (SAFE) location

    Then, and breath deep, delete everything from ~/Library/Mail/ all the Mail preferences.

    Start Mail as if it was your first time. Create your accounts.

    work with mail for a while and then start trying to import the mailboxes again, one by one.

    If you have Time Machine you can try that as well.

     

    By the way, look at your console to see what you see in terms of mail

     

    Good luck Charles, I am sorry if some of my advice were not good!

  • deivy Level 4 Level 4 (2,365 points)

    Ambassador,

    Please let us know what are the contents of your ~/Library/Mail/  folder.

     

    Finder-->Go-->Go To Folder…--> enter  "~/Library/Mail/ " without quotes.

  • doug38 Level 1 Level 1 (0 points)

    For what it's worth, I had the same problem - I got the failed to upgrade error and couldn't open Mail.  I tried the tips in here but it didn't work until I took one additional step.  So, here's what I did:

     

    1. Deleted two envelope index files.  One was in the ~/Library/Mail folder.  The other was in the V2-Temp.noindex folder.

     

    2. Renamed the V2-Temp.noindex folder to V2

     

    3. Open mail. Voila!  It worked.

     

    Thanks to those who got me to this place.

  • The Ambassador Level 1 Level 1 (5 points)

    This is the directory listing of ~/Library/Mail

     

    Envelope Index

    Bundles (Disabled 1)

    SmartMailboxes.plist

    VersionedSmartMailboxes.plist

    BackupTOC.plist

    OpenedAttachments.plist

    SearchHistory.plist

    SyncAlert

    MessageRules.plist

    IMAP-mark.sylvester@tedxamericanriviera.com@imap.gmail.com

    AvailableFeeds

    Metadata

    Bundles (Disabled)

    LSMMap2

    Bundles

    MessageUidsAlreadyDownloaded3

    POP-mark@intronetworks.com@owa.mailseat.com

    DefaultCounts

    AvailableFeeds.corrupt

    RSS

    Mac-marksylvester

    Mailboxes

    Signatures

    MessageRules.plist.backup

    SmartMailboxes.plist.backup

    VersionedSmartMailboxes.plist.backup

  • sw10mm Level 1 Level 1 (0 points)

    God bless you Doug!!!  Mail would not work -- installed Lion.  I open Mail - it goes through the following sequence:  "Import messages…  Upgrade mail…  Upgrade failed - click Continue to open Mail Import Assistant"  I do that and the Import Assistant told me "Mail Index damaged. Quit Mail and it will repair itself on restarting".  I Quit - Restart Mail - and got the same sequence, except this time the number of messages "imported" is increased by roughly 75%.  Quit and restart again -- number of messages increases, but Mail will not work - upgrade fails, index still damaged -- number of messages increases every time I try it.  Meanwhile, I have no email - cannot even open Mail.  The number of messages "imported" was originally around 4500 - my last attempt it was increased to 96,000+.  Then I got to your post... I had tried everything prior to this point and nothing worked.  I did exactly what you said --- and Mail worked - my mail was there - my accounts - the works -- all synced from MobileMe.

     

    Thank you.

Previous 1 2 3 4 5 6 Next