Previous 1 5 6 7 8 9 Next 130 Replies Latest reply: Aug 7, 2013 1:26 AM by oae__ Go to original post
  • spyleader149 Level 1 (0 points)

    I did what you said, I found three files that began with "Envelope Index":


    Envelope Index

    Envelope Index-shm

    Envelope Index-wal


    I delted all three of these items, but the problem continues.

  • ebinellis Level 3 (685 points)

    Not by any means, this indicates your OS, as well as the are functional.


    Your problem resides somewhere in your user.


    /Users/yourname/ contains all your personal data.


    /Users/yourname/Library/ is like the spine of your user, all the settings you use, files used by applications that store your data, etc.


    Something within your user library is causing the issue.


    (~ = /Users/yourname)

    ~/Library/Mail/ = the folder that contains all the messages, and data of your mail accounts, signatures, rules, etc.

    ~/Library/Mail Downloads/ = The folder that contains your downloaded attachments

    ~/LIbrary/Preferences/ =the file that stores your account information, servers, etc.


    these files are usually the first targets for user specific issues, although there are more.


    Also applications or processes that your user it set to start automatically (often in the background) can conflict with the function of the


    look at my previous post of steps to see if they help you!



  • niella Level 1 (0 points)



    I had the same problem, Mail would open but I would be unable to open a viewer window. The console log showed:


    2011/07/23 4:43:24,092 AM Mail: An exception occurred during invocation of -[MailboxesController _writeSmartMailboxesToDisk]


    Anyhow, I force quite Mail, navigated to ~/Library/Mail/V2/MailData and moved SmartMailboxes.plist to my Desktop for the problem to be resolved. RELIEF.


    Hope this helps.



  • Liquid_015 Level 1 (0 points)

    At Dievy,


    I just doubled checked my ~/Library/Mail folder, and I will note the differences between my directory and yours because it might give us a better understanding as to what went wrong while transitioning from SL to Lion.


    - Inside my ~/Library/Mail/ folder, I do not have a V2 folder; in fact, it is called "V2-Temp.noindex".


    - Inside my V2-Temp.noindex folder, are IMAP-(myemail address), Mail Data, and a file named: V1MigratedItems.


    - Inside my MailData folders, I will list the extra files I have in my MailData folder: Accounts.plist.synced, AvaliableFeeds.corrupt,, SyncAlert


    - What I don't have in my Directory compared to your directory is the following: Enevlope Index -shm, Envelope Index -wal, MessageUidsAlreadyDownloaded3 -shm, MessageUidsAlreadyDownloaded3-wal, SearchHistory.


    - As for Mailbox folder: I have only Deleted Messages.mbox, Notes.mbox, Outbox.mbox, and ToDos.mbox.



    I hope this helps solving this nasty problem.

  • Liquid_015 Level 1 (0 points)

    By the way, is the Mailbox folder supposed to be in V2 folder? If so, my V2-Temp.noindex does not have the Mailbox folder; on the contrary, it is in the ~/Library/Mail folder.


    I would assume if I were to import my old mailboxes I would have to get the path from my Snow Leopard Time Machine Backup?

  • rlv360 Level 1 (0 points)

    Fantastic this immediately fixed the problem for me too.


    • I had the same problem, Mail would open but I would be unable to open a viewer window. The console log showed:
    • 2011/07/23 4:43:24,092 AM Mail: An exception occurred during invocation of -[MailboxesController _writeSmartMailboxesToDisk]
    • Anyhow, I force quite Mail, navigated to ~/Library/Mail/V2/MailData and moved SmartMailboxes.plist to my Desktop for the problem to be resolved. RELIEF.



  • deivy Level 4 (2,365 points)
    By the way, is the Mailbox folder supposed to be in V2 folder? If so, my V2-Temp.noindex does not have the Mailbox folder; on the contrary, it is in the ~/Library/Mail folder.


    Yes, I believe the Mailbox folder should be inside the V2 folder.

    Actually rename the "V2-Temp.noindex" to "V2", then it will index the files.

    You can trash the "xxx.corrupt" file too.


    I am starting to think that most of the problems that you guys are facing arise from the fact that Mail is not fast enuogh to import all you old Mail and then it causes all this mess.


    I wrote in an earlier post what to do to import all your mailboxes after your mail is working. ebinellis suggested an alternative method, either way it should work.

  • Liquid_015 Level 1 (0 points)

    Ah, ok. The reason why I am asking is because I made a backup of the working "V2" folder and when I checked the contents inside the folder, there were the following: IMAP-(myemailaddress), Mailboxes, MailData, POP-(myemailaddress), RSS, and V1 MigratedItems. It is completely different from the V2-Temp.noindex.


    As for the import, where should I get the mailboxes from? From my old Snow Leopard backup files? Is it possible to post a more detailed instructions?



  • William Hamilton Level 1 (90 points)

    THANK YOU, THANK YOU, THANK YOU!   That did it for me as well.  Somehow I would think the trapping routines in Mail could handle identifying the problem a little better.

  • Jeff Mark Level 1 (5 points)

    I had the same issue as Steve above. This appears to be not uncommon. I stumbled around a bit, but dumping the "Envelope Index..." files solved it. What shook me up was the "disappearance" of my Library folder (not mentioned in any of the "get ready for Lion" articles I read). I eventually concluded it had been made invisible. If you hold down the option key when you click Finder's Go menu, "Library" becomes available. See also:

  • cp_whaley Level 1 (0 points)

    ****... I had a nice detailed version of this prepared and it disappeared before I could click the Add Reply button. I don't have the patience to re-enter it all again, so here's the short version.


    I started this thread, and I've finally resolved my situation. There are two basic problems it seems.


    1. The new Mail fails in the middle of the migration. Some have solved that by quitting Mail and simply deleting the files begining with "Envelope" in the Maildata folder inside the Mail folder in your Library. That resets Mail to try the migration again.
    2. Separately or in combination with #1, when you subsequently launch Mail, only the Mail bar at the top appears.. no mail Window, so you don't know what's going on. This seems to be related to Mail failing to migrate SmartMailBoxes correctly. If you didn't have any before, this probably isn't an issue. Mail goes into an infinite loop trying to do something with SmartMailBoxes, so it has no time to build you a window, and it's even difficult to do a force quit. Force it to quit somehow!


    If you've experienced both problems (as I have), make sure Mail has been forced to quit and go into Finder>GoTo>~Library/Mail/MailData and remove anything starting with Envelope and anything with SmartMailBoxes in the file name.


    In my case, the migration routine started again and when it was finished, my Mail window opened with the results. Nice!  I still had to re-enter all of the account info for my dozen accounts or so, but I think the dust has settled.


    As usual, no guarantees! We're all just users helping users here, so I won't accept liability for anything.  Where I say "delete", just move the files to your desktop. If the solution doesn't work for you, you can always move them back, and you can't blame me!


    It's a pity that the Apple folks don't seem to read what's going on here and update their support files accordingly.


    BTW... if this doesn't work for you, there's a long tedious way to do this too... as suggested by others above (in greater detail).


    1. Quit Mail, and move the Mail folder with everything in it to your desktop.
    2. Move your email preference file ( as well to the desktop from Preferences under Library.
    3. Restart Mail


    As I understand it, this should start mail as if you never had email before. You'll need to set up your account(s), then use Import Mailboxes under the file menu to copy in your messages from within the Mailboxes folder in the Mail folder that you moved to the desktop.  This should be your last resort, since it'll take you forever to get back to where you were just a few days ago with the previous edition of Mail.


    With all this grief I hope the new Mail really does have some good features, because I'm sure not seeing any yet!

  • nicke-nyfiken Level 1 (0 points)

    I think you captured also my experience and conclusion of this mess really well cp_whaley – was just going to write something similar. Agree there seems to be (at least) two separate issues at play, which has confused the problem solving quite a bit.


    On the first problem -- incomplete migration – I reimported the old mail folder from my Time machine, removed preferences and cache files and then let Mail try the migration again, from scratch by starting Mail, and then it worked. It seems to me that this is a somewhat arbitrary procedure that may sometimes work well directly, and for some it doesn't get through all. Maybe it has something to do with the size of the mail folder/mailboxes (mine are more than 30 GB in total).


    Once the migration has worked as it should -- which one can tell from having a neat V2 folder with folders for each account, a Mailbox folder and a Maildata folder, one need to prevent from ending up with problem 2: Mail getting confused by the smart mailbox files. This happened to me (Mail unresponsive with only menu bar and need to force quit) and forced me to move the whole mail folder away form Library and begin the tedious manual import which would probably take days with my 140 000 messages... I then saw earlier posts on the smart folder issue.


    Had luckily backed up the original mailfolder on a fast firewire disk, and could easily again replace the mail folder with the original one from Snow Leopard. This time I removed the smart mailfolders from the mail data subfolder BEFORE opening mail and letting it do the migration again. Sweet -- it now worked perfectly, and after migration mail opened with all my previous mailboxes in the correct place and with correct hierarchies.


    However – my new Lion Mail did not have the past accounts intact. So, now began some hours of additional work. I recreated the original accounts (and paid close attention to the pop-server name) so that the recreated accounts corresponded perfectly with the existing folders for the accounts (which has the mail username and the popserver in them). Once the accound was created the Inbox for the account filled up with what it could download from the corresponding mailserver ( a week's worth of mail). However, in order for it to actively look for and index/include the existing thousands of messages in the exsiting inbox in the account subfolder  I had to select the new Inbox in Mail and then go to Mailbox>Rebuild. Voila -- my old mails magically appearing and pouring into the mailbox (took some minutes for the biggest ones). Then had to do this for each of the mailboxes - both inbox, sent mail boxes and mailboxes on the Mac - which in total took quite a bit of time. Yet -- much, much faster than manually importing (it also works to select several mailboxes in a go before doing the rebuild command; however, does not seem to work to select a parent folder and have the subfolders automoatically rebuild). Attachements and everything also as it should be.


    So, now quite happy, with Mail seeming to work as it should. But what a waste of time -- 2 full days of work wasted. Good luck.

  • Liquid_015 Level 1 (0 points)

    Hey Cp_whaley,



    Finally, we have a better grasp on the issue at hand. As for me, my migration fails quarter of the way, and at the same time I am trying to preserve the previous mails (13,000+), so when you completed this process did Mail preserve your "X" amount of previous emails?



    So, what exactly is the process if I am encountering migration failure, and trying to preserve my previous mail?



  • William Hamilton Level 1 (90 points)

    I'm not the expert the previous posters appear to be, but I solved my problem by eliminating the following files from ~/Library/Mail/V2/Maildata:

    Any file with "Envelope" in it's name

    Any file with "Smartmailboxes" in it's name.


    Worked for me.

  • cp_whaley Level 1 (0 points)



    I'm glad you provided all of that additional information. My summary is basically correct, but I've subsequently found that I do have a lot of missing email still. I will be trying your solution.


    The basics, as several of us have discovered, are getting rid of SmartMailboxes files and Envelope files to restart the process of migration.


    All of my self-created mailboxes (the ones under On My Mac) look like they've been restored perfectly. That is most of my email since I have many rules to route incoming messages to those boxes, and I also do that manually with many others.


    However, I was a bit sloppy when re-entering all of my account information, unlike you.  So I'm still missing previous inbox/sent messages for each account. I've started to restore those manually for each account (with the Import mailboxes feature), but I'm now thinking that repeating your process may be quicker.


    I'm surprised that the account information isn't automatically migrated over too. It must have been for those who haven't experienced the problems that we have.




    PS Gmail is now acting a bit weird now. Any messages from any accounts (including Gmail) where I've tried sending via have failed and I've had to use another smtp server. I used to use Gmail exclusively for smtp since it was the most reliable. That's a tangent, but have any of you found that too?

Previous 1 5 6 7 8 9 Next