Previous 1 2 3 4 Next 132 Replies Latest reply: Sep 4, 2015 4:02 PM by travel4life08 Go to original post
  • DLH2 Level 1 Level 1

    Rafael - have you been able to utilize Citrix Gateway Access on Lion yet?  I am still unable to do so since installing Lion - and I haven't ran the unlaunch that Roger suggested.  

  • Nate Harrison Level 1 Level 1

    Sorry if I'm a little dense but could someone explain how to do the "sudo launchctl unload -w /Library/LaunchDaemons/com.citrix.agadminservice.plist" removal process? Is this some sort of code I type into the terminal app or something? Sorry not much of a code guy, but am, like many others here, experiencing a noticably hotter MBP with fans running after installing Lion. Many thanks!

  • PhangirloftheOpera Level 1 Level 1

    Where do i go to enter this command? (completely non-technical teen who has used mac for less than a month and is only familliar with windows)

  • BeatriceK Level 1 Level 1

    Start Terminal (you can search for it under Spotlight) paste the command l

    aunchctl unload -w /Library/LaunchDaemons/com.citrix.agadminservice.plist

    into the window. You will be prompted for your password. Type it in and hit enter. I had to close down the lid of my MBA and reopen it again for the fan to stop.


    Terminal is a unix shell if you are used to Win you could compare it with Command prompt (DOS).

  • tasosm Level 1 Level 1

    I paste the command,i get promped for my password but it won't let me type or paste my password.

  • fullmetaljester Level 1 Level 1

    This did the trick, I immediately saw a 30 F drop in CPU temps

  • Robert Richardson Level 1 Level 1

    Thanks for this!  I had the same problem and Googled "AGAdminService Mac".  This thread is #1 on the search results not.  I used the advice and my MBP is quiet as a mouse.  Yay!


    Citrix Gateway was not working in Lion even before I found this issue.  Luckily, I still have access via Parallels/Windows XP, so I am not screwed as far as accessing hospital data.


    Hopefully, Citrix will step up soon with a solution.

  • Robert Richardson Level 1 Level 1

    @tasosm:  As noted earlier in the thread, the password you enter is your admin password.  "sudo" performs the command as a root/admin user and so a password is requested.

  • McNik_de Level 1 Level 1


    if you don't want to use the terminal - there is a easy way to solve the CITRIX / Lion Problem (if you don't want to use it anymore):

    1. deinstall Citrix (also deaktivate the plugin in firefox)

    2. open finder

    3. go to directory /Library/LaunchDaemons

    4. delete com.citrix.agadminservice.plist

    5. restart


    Now the process should be away -- > and we have to wait for a Citrix LION Version


    Thanks to the apple support! They helped me with this issue!

  • christiancee Level 1 Level 1

    Hi I've tried the method on Terminal and didn't work. This was what I got from it.


    launchctl: Couldn't stat("/Library/LaunchDaemons/com.citrix.agadminservice.plist"): No such file or directory

    nothing found to unload


    I've also tried McNik's method but could not locate the com.citrix.agadminservice.plist file.


    Please help, think my MBP's life span is getting shorter as we speak.


    Thanks in advance!

  • j0lly Level 1 Level 1

    Thanks a lot for posting this... problem is, before I read further into this thread and saw your post I took action into my own hands and deleted the LaunchDaemons folder. Obviously now that its gone, I can't unload it...


    Arghh.. I feel like an idiot - is there any way I can fix this?

  • McNik_de Level 1 Level 1



    to find the folder, open FINDER than "go to" in the menu bar (in german this is "gehe zu" - I hope this is go to in the english version) --> computer.


    Now you should find this directories!

  • joelparkin Level 1 Level 1

    my terminal will not let me enter the password on request after the command either!



  • joelparkin Level 1 Level 1

    Thats not his problem or mine.  terminal will not let you type your password in  even when its requested

  • christiancee Level 1 Level 1

    I have manged to locate the from Library>LaunchDaemons> but I don't see the com.citrix.agadminservice.plist file neither that there's any from the search result. It's just not there. Can it be a hidden file?


    I've called Apple and they asked me to bring it to the service centre or downgrade to OS X SL.What a hassle.

Previous 1 2 3 4 Next