Previous 1 5 6 7 8 9 Next 132 Replies Latest reply: Sep 4, 2015 4:02 PM by travel4life08 Go to original post
  • nrv333 Level 1 (0 points)

    i tried doing the citrix thing with the link in the original post and  i keep getting an error the error is "Error unloading: com.citrix.agadminservice" i really need help cause my battery dropped from 6-7 hours to a solid 2hours

    plzzzzz help!!!

  • WhiteTiger00 Level 1 (0 points)

    I had the same problem too.  I couldn't get my MBP to land(damned jet plane.)  I found the Citrix Access Gateway installer .DMG and ran the uninstaller.  BOOM!!!!!!  My MBP had come in for a nice quiet landing.  No more jet engine reving up in my MBP. Rebooted of course to be safe.  Now it looks normal in Activity monitor.

  • rafaelsantoni Level 1 (0 points)

    Hi everyone,

     

    I am don't know if anyone has mentioned this before in the thread, but Citrix IS NOT an application that gets installed. Citrix is a company that sells software and hardware. If I am not mistaken, the application that is found to be the culprit here is called Access Gateway. It might appear with Citrix as part of the name, but the application is not called Citrix. If you access a VPN, you could be using Citrix's Access Gateway to connect to it. If you have used any of Citrix many applications, you might also have installed a similar Citrix application to use the software.

     

    They are:

    • XenDesktop
    • XenApp
    • AppDNA
    • XenClient
    • Citrix Receiver
    • VDI-in-a-Box
    • GoToMyPC
    • XenServer
    • CloudStack
    • CloudGateway
    • CloudBridge
    • CloudPortal
    • NetScaler App Delivery Controller
    • NetScaler Access Gateway
    • NetScaler Branch Repeater
    • NetScaler App Firewall
    • NetScaler CloudConnector
    • GoToMeeting
    • GoToWebinar
    • GoToTraining
    • GoToAssist
    • GoToManage
    • HiDef Corporate
    • ShareFile

     

    I don't think that the Mac operating system includes any of the Citrix applications. In fact, I was told that indeed, OS X (any versions) does not include any of Citrix's applications that use the AG software. If Apple does include Receiver, or any related apps, then I am mistaken.

     

    So, if you have used any of the applications I just listed, there is a good chance that as part of the installation (for those apps that are used for remote computing), you installed the software tat is at fault. I spoke to two of the developers in Citrix, the company, and they told me that there were last minute changes in the new version of the operating system that triggered the problem. Before those updates, everything was fine during the pre-release versions.

     

    I know none of this information really helps anyone here, but at least it should provide an additional explanation of why you might have had a Citrix-related application installed in your system prior to the OS upgrade.

     

    Apple has very high standards when it is time to release a new OS, so I find it hard to beleive that they would launch the new version with a pre-installed application known to have issues.

  • WhiteTiger00 Level 1 (0 points)

    rafaelsantoni WELL SAID!!!!!  You are right on target.  Thanks for posting this!

     

    WhiteTiger00

  • Norwich city FC Level 1 (0 points)

    You are a genius thanks a lot

  • Norwich city FC Level 1 (0 points)

    I think you are right but the problem with the citrix (agadminservice) running 100% of the cpu in my case started after I upgraded to Lion.

  • ronnyl Level 1 (10 points)

    @xwitek I got this problem on a new MBP that came with Lion preinstalled. So it looks like it's not only an upgrade issue.

    I had Citrix Access Gateway 1.2.0 (58) installed.

    Got rid of the problem by running 'sudo launchctl unload -w /Library/LaunchDaemons/com.citrix.agadminservice.plist' and then running the uninstaller that came with the installer. I don't use Access Gateway at the moment, so the easiest solution was just to get rid of everything.

  • Augesthi Level 1 (0 points)

    Hello,

    This heating problem at MBP after installing Lion is due to incompaitable softwares. If we do a clean install then this problem will never ever arise. But that is not only the way. We always wanted to upgrade our OS with the softwares already existing. Quick solution is go to Activity Monitor (Search in spotlight) and see which application (process) is taking heavy load on CPU, he is the culprit. Quit that process usign activity monitor. If required uninstall that application and reinstall a compaitable version. For me its due to KIES (KiesViaWiFiA process) application fo Samsung. I tried multiple blocks before resolving the issue and did multiple remedies when remedy is a second away. Now my mac is running smooooooooooothly as before....

  • Augesthi Level 1 (0 points)

    Guys do not go for a reinstall or some system reset options.... the remedy is seconds away... read this...

     

    https://discussions.apple.com/message/17737387#17737387 the one posted by me....

  • issanni Level 1 (0 points)

    Thank you Roger. Works for me.

    Still don't know why it happened though.

  • csaltos Level 1 (0 points)

    Thanks !! ... My MBP is now cool and great !!

  • 1JK1 Level 1 (0 points)

    I have to use Citrix for my work as well so I couldn't junk AGAdminservice even tho it was using 100+% cpu.

     

    CPUThrottle let me specify/limit the process to a specified %. (I did 25%)

     

    I can still access the VPN and my MBP is soooooo much happier

  • 1JK1 Level 1 (0 points)

    Link for CPUThrottle

  • JoeDaHackinBot Level 1 (0 points)

    Copy it into terminal

  • bucks1999 Level 1 (0 points)

    When I paste the above command on TERMINAL;

    I get the following message

     

     

    launchctl: Error unloading: com.citrix.agadminservice

     

    Do you know how to solve it.

    Thanks.

Previous 1 5 6 7 8 9 Next