Previous 1 140 141 142 143 144 Next 2,670 Replies Latest reply: Apr 23, 2014 2:58 PM by ElJefeGrande Go to original post
  • wrrn Level 1 Level 1 (0 points)

    BillyBBone wrote:

     

    wrrn,

     

    Have you tried configuring other DNS servers? I'm wondering if there's something special about the IP address 8.8.8.8, or whether adding *any* DNS server manually fixes the problem.

     

    For instance, if you run a tool like namebench (http://www.macupdate.com/app/mac/32784/namebench) and use one of the recommended DNS servers, does the problem also disappear?

     

    - B

     

    I have not tried any other IP's, but the article said you could use any IP. They promoted Google's IP because it would be rock solid. I'd try it out, as it's an easy enough change.

  • javsckkc Level 1 Level 1 (0 points)

    Well... my problem seems to have been fixed with the new dns entry. thanks for the help and I hope the voodoo solution sticks.

  • Nogueira Level 1 Level 1 (0 points)

    After reading this post, what makes me really angry and unsatisfied with Apple, is that the Apple web site http://www.apple.com/why-mac/better-os/ says the following: "Since the software on every Mac is created by the same company that makes the Mac, you get a fully integrated system in which everything works together perfectly." Apple claims it makes the best computers. But for what I see "Apple also makes the best jokes." Shame on you Apple. I have already sold my MacBook pro because the wifi problem. Now, I am seriously thinking in selling my iPhone 4s, just because I don´t trust Apple anymore.

  • RealEinstein Level 1 Level 1 (0 points)

    ...also struggling with this for a while. Like others have posted elsewhere and I have now confirmed there is a workaround which saves rebooting the hub

     

    The lease expires and renewal requires pings sent to the hub

    - to (re)establish wifi connection

     

    Open Network Utility/Ping Tab

    enter your router's IP address (192.168....)

    send unlimited number of pings (these will be shown in the window) and keep this running

     

    (alternatively you can also run

    the Terminal application, if you don't know the router Ip for example)

    (copy/paste the command)

    ping `route get default | awk '(/gateway/){print $2}'`

     

    your pings will then be running

     

    Then

    In network preferences/advanced/(TCP/IP)

    IPv4 tab choose: Using DHCP

    then click on RENEW DHCP lease.

     

    An IP should then be allocated and your wifi connect fine.

     

    Not a solution, but a work around.

    More importantly a very clear pointer to the cause of the wifi bug in OS X Lion.

     


  • William Kucharski Level 6 Level 6 (14,890 points)

    It's pretty obvious some routers aren't properly reporting DNS server information to clients, which is why manually specifying one solves the problem fr some.

  • ferulee46 Level 1 Level 1 (0 points)

    Hello all,

    I have the same annoying problem.

    Does anyone know if it's going to be fixed any time soon?

    Thanks

  • snipjo Level 1 Level 1 (0 points)

    Hello,

    Also tried changing DNS manually as recommended in the latest posts...Well, it doesn't make it for me I am afraid...since buying my ever first Mac in June last year  to get all worried solved....still patiently waiting for Mac BREAKTHROUGH update....

     

     

    So Disappointing...

     

    J

  • henrialfa Level 1 Level 1 (0 points)

    I just managed to solve this by resetting Airport Express with Airport Utility: for some reason it forces to create a new network first which doesn't help but then editing it and changing it to join to my wifi network, all work then ok.

     

    My problems started when I connected a new iPhone to my wifi network. After that my Macbook Pro and Powerbook couldn't get access to the wifi anymore, but the other iPhone and iPad connected fine.

     

    I hope this helps someone!

  • CnmiC Level 1 Level 1 (0 points)

    Hello my fellow people with issues,

     

    I just wanted to add my two cents to this incredibly frustrating problem.  I purchased a 2011 27" iMac with Intel processor and have been experiencing the same WiFi problems.  The WiFi just randomly disconnects after a few minutes and will not automatically reconnect after sleep unless resetting Airport.  Connections are unstable lasting only minutes.  The one difference is that I am still running Snow Leopard 10.6.8.  I refuse to update since it seems Lion just has the same problems.  Like others, I have multiple Apple and non-Apple devices with stable connections to my D-Link DGL4500 router with NO issues.

     

    First, I tried to change the router settings per other advice on the threads.  I deconflicted the channel with the neighbors, turned off the auto mode for channel switching, and set the router to pure n mode on 2.4GHz.  I also tried creating a new network location in my network preferences, moved the airport conncetion to the top of the list of preferred connections on top of bluetooth and others, and deleted the network preferences plist file. None of this worked.

     

    Then, I finally bit the bullet and dragged the machine all the way to the closest Apple Store 1.5 hrs away.  The Genius Bar worker was extremely pleasant and understanding but did NOT acknowledge ANY WiFi issues with the iMac.  Of course, my iMac stayed connected to their WiFi connection through the entire process.  Of note was the fact that he used a *USB* keyboard and mouse with my iMac vice using the bluetooth keyboard and mouse which comes standard.  He did offer to replace the wireless card and antenna in the iMac with virtually no prompting from me so I took Apple up on that offer.  Of further note was the Genius Bar worker's statement when I inquired about the bluetooth keyboard/mouse.  He asked if I had tried the 5 GHz channel on my router since bluetooth also uses a 2.4 GHz freq.  I had not tried that yet, I couldn't help but wonder why he would ask me that?

     

    After another 3 hr round trip journey to the Apple store, I eagerly retrieved my "repaired" iMac. The connection worked for 15 minutes, then the same problems recurred.

     

    What I did next solved my problem, at least for the past 48 hrs, which is the longest I have had a "problem free" WiFi experience since purchasing my incredibly expensive iMac.

     

    I hooked up a generic USB keyboard, plugged in a wireless USB mouse, and disabled the bluetooth on the iMac.  Since then, NO WiFi problems.  I'm talking ZERO.  Streaming music as long as I want, uninterrupted streaming movies, computer sleeps and wakes up and the WiFi reconnects instantly.

     

    This definitely must be an issue with the bluetooth interfering with the 2.4GHz WiFi connection--in my humble, non-computer-engineering-literate opinion.  I have not tried my router's 5 GHz signal with the iMac bluetooth kb/mouse but perhaps I will.

     

    In the meantime...to APPLE: fix your Sh$t and stop denying your equipment has an issue when it clearly does. Until then, my black, bulky, wired logitech keyboard, and grey, wireless usb belkin mouse is disrupting the image of your holistic APPLE computer zen. Not that I really care. I just want my $1900 computer to work as advertised.

     

    Regards~CC

  • wrrn Level 1 Level 1 (0 points)

    CnmiC, that's a sad tale of woe, and I'm not being sarcastic. It's strange that so many different tweaks are working for people. I rarely have my bluetooth turned on and so this was never an issue for me.

     

    I'm curious ... how did you resolve router channel conflicts? I'm assuming you changed a setting in your router admin, but what setting?

  • Massi123 Level 1 Level 1 (0 points)

    I am using a new dual band router since 3 weeks now. I am connected to the 5Ghz band and since then I have no more WI-FI problems. Not a single drop! I also use a bluetooth mouse and keyboard. So, I also think it was an issue with bluetooth and the 2.4Ghz I used before.

  • michaelintexas Level 1 Level 1 (0 points)

    Hi everyone,

    I've fixed my problem.

    (I've been following this thread for a week and tried everything, FYI)

    So I called Apple, as I have apple care.

    Here is my situation--"A connection timeout occurred" is what I would get on my MacbookAir. But my wife could access the internet wirelessly (and uses lion on a macbook) and I could also on my MacPro.

     

    What did it for me:

    Open Airport Utility.

    Clicked on Time Capsule (I have time warner internet, and it feeds into a Airport base station which is hardwired to the Time Capsule in my office--so even though internet comes into the Base Station they had me use the closest router, which was the time capsule)

    Then I went to the menu bar, clicked on base station tab, and clicked on restart. (I did all of this using my Mac Pro, obviously, because I had not access on my MBAir).

    That did it.

     

    Before that, Apple had me restart my MBAir, hold down the option key, when given the option to go to recovery disc, I chose it. And then tried to see if the network could be accessed. Because it could not, he was sure it was not a software issue. So, if the above does not work, then consider doing this, which apparently allows you to try to log on to the network without all of the other software competing.)

     

    Good luck.

  • RichBP Level 1 Level 1 (0 points)

    I just noticed that this thread has been accessed over 300,000 times and has over 2000 written responses. Surely that tells Apple that something other than user ignorance is the problem here.

     

    I have 2 recently purchased iMacs. One was purchased about a month before Lion came out and has Snow Leopard installed.  I have not had any problems with it at all. The second one was purchased about a month after Lion came out, and came with Lion installed, and has had nothing but problems with it's wifi connection. The Feb. 24th fix worked for a while, but I now am having the problem where when it awakes from sleep, it can't find the wifi connection.  If I click on the signal strength meter, the drop down menu always shows my wifi address and if I click on it, it will then connect. Sometimes after a complete shutdown, at startup it can't find the wifi connection and sometimes it can. All the while, the Snow Leopard iMac has worked without a hitch. Thank god I didn't upgrade it to Lion.  I'm fortunate that I don't seem to be having the problems that so many others are having that are listed here.

  • Markus Oliver Level 1 Level 1 (0 points)

    Well, Apple does have a serious problem with it's quality management. I thought it was unimaginable Apple would some day sell a buggy OS like Lion with such a problem.

     

    Furthermore this problem last since Lion was released and even all this "updates" offered no help at all.

     

    When I walked into the city center of my hometown last week, I heard a guy telling his friend walking next to him, that he has a problem with the wifi of his brand new iMac...

     

    someone can hear people talking about this problem on the street. Again: unbelievable. I really can't believe what I have to read here now for months. Apple, a brandname well know for quality and such a thread. Lion clearly was the last OS I installed with the release and the iMac I bought in late 2009 was definately the last Mac I bought. Why? Because I can get 2 PCs with working wifi for the price of one buggy iMac.

  • Markus Oliver Level 1 Level 1 (0 points)

    Well, lots of "solutions" and "tweaks" and whatshowevers...

     

    my point is: I didn't buy an iMac for doing all this or even for reading 20 Pages of Problems. I want my iMac to work if I turn it on. And it doesn't.

     

    No configuration, no tweaks, no reading of forum pages... non of them all.

     

    I want my iMac to work if I turn it on. Because time is money. Apple, please fix that problem or offer an easy way to roll back to snow leopard without the danger of losing data.