Previous 1 156 157 158 159 160 Next 2,670 Replies Latest reply: Apr 23, 2014 2:58 PM by ElJefeGrande Go to original post
  • grgrant Level 1 Level 1

    There is a big difference between deleting:


    HD>System>Library>System Configuration


    as you suggested and


    HD>Library>Preferences>System Configuration


    as has been suggested elsewhere.  The former will cause your system to be unresponsive on reboot and require you to recover the System Configuration folder that was deleted.


    The latter will clear the network settings as others have suggested and let you system keep working.


    Warning to all -- read carefully and have a backout plan.  I recommend renaming the System Configuration folder rather than deleting it in case you follow the wrong path and delete the wrong System Configuration folder.  I lost use of my MBP for about 2 hours while I troubleshot the problem in single user boot.  Fortunately the System/Library/System Configuration folder I had deleted was still in my trash folder and I was able to recover the use of my laptop.  I've since successfully renamed /Library/Preferences/System Configuration and rebooted and had a fresh Network Settings.


    For what it's worth.  I'm having issues where at work the Cisco Access Points do both 2.4 and 5 Ghz with the same SSID -- not able to change as some have suggested to different SSIDs fore each band.  I can see the connection switch back and forth between 2.4 and 5Ghz and reconnect to wireless each time it does.  I also have had difficulty connecting at all after roaming to a new AP in the enterprise mesh.


    Too soon for a real test but it seems like the connection is sticking better after letting the /Library/Preferences/System Configuration folder get rebuilt.


  • putnik Level 3 Level 3
    Mac OS X

    My apologies. I hope your post prevents others from making the same mistake as earlier ones avoided stating the path at all.

  • grgrant Level 1 Level 1

    No problem.  I learned some things from the experience so it was not all bad.


    I have now verified that my wireless issues improved substantially after renaming the directory SystemConfiguration at /Library/Preferences/SystemConfiguration and rebooting to have things recreated.  Unfortuantely that resets a lot of probably unrelated things such as Power Preferences etc.


    Because I renamed the directory I am able to reproduce my earlier problems by renaming the directory back and rebooting so I'm pretty sure that one of the preference files in that directory are at fault.  For the record my system started out at Lion (MBP Retina) and was upgraded to Mountain Lion and I definitely started having more issues with wireless at that point in time.  So I suspect that some earlier preference setting is causing problems with a later release of software for the airport card in my laptop.


    I have tentatively identified the one file that seems to help my configuration work again as /Library/Preferences/SystemConfiguration/   When renaming that file and rebooting I have at least some of my wireless problems solved.  My initial impression is that there is something else in the directory because a complete rebuild of the preferences seemed to make my wireless reconnect more quickly when roaming but that is to be further verified.


    This preferences file seems to go along with the instructions to create a new location except that didn't seem to work in my case so there is something else going on.


    I hope this helps someone else.

  • mirovaz Level 1 Level 1

    Drop outs here to randomly...

    Hope a fix came really fast from apple... :S

  • PepperSalsa Level 1 Level 1

    UPDATE: OUR PROBLEM SOLVED - It was the wifi ROUTER not compatible with ML


    Per my previous post, we had tried everything and I mean EVERYTHING listed on these forums as well as four calls in to Apple Support, reinstalling ML, etc.  I have three iMacs (2 on Snow Leopard, 1 on ML).  The upgrade to ML gave us the wireless issues.  After trying everything, we stopped by our local Apple store to talk to them about it.


    They suggested we purchase an Apple router.  We didn't want to because our current Cisco router was working just fine with my other iMacs, but we were so fed up, we finally agreed to purchase a Time Capsule (wireless hard drive) with built in Airport Extreme Base Station.


    After setting it up the problem was completely gone.  That was five days ago.  Not one single problem since.  I have to admit that even my Snow Leopard iMacs seem to be running better on the new router.


    It was not $300 that I wanted to spend, but it solved the problem and we are also able to back up our macs (which we needed to do since Apple got rid of iDisk).


    So the bottom line for us was either wait for Apple to issue a fix, or just get the base station.  Good luck!

  • gsspike Level 1 Level 1

    That would only be a fix for me if Apple paid for the Router. LOL

  • gphonei Level 1 Level 1

    Humm, you paid for the router you have now.  Are you certain that it is 100% compliant with all associated WiFi standards?  Did you test it your self, or did you rely on the vendor to have done that testing?  I am not trying to be flippant, I'm just trying to suggest that this comment insinuates that Apple is creating the problem, when it could also be that the WiFi radio on the other end is not compliant with standards, and the Apple developers just missed testing for or effectively handling an error condition which has existed for quite some time, and which, perhaps your other devices have software work arounds for.


    I'm not trying to say Apple has no responsibility, I'm just saying that these kinds of statements have no merit when we still don't know what the actual issue is.

  • DonnaP Level 1 Level 1

    My situation :  fine at home with my Apple Router....  but NO connection at the local coffee shop.  Crazy. I can go down the street to the pub and get on, but back to the coffee shop? Nothing.  My old lappy did fine EVERYWHERE! Very frustrating.

  • William Kucharski Level 6 Level 6
    Mac OS X

    DonnaP wrote:


    My situation :  fine at home with my Apple Router....  but NO connection at the local coffee shop.  Crazy. I can go down the street to the pub and get on, but back to the coffee shop? Nothing.  My old lappy did fine EVERYWHERE! Very frustrating.


    Sounds like the coffee shop has a non-compliant router.


    Everyone needs to adhere to the same standards for things like this to work; many Windows vendors have a "Hey, if it works on Windows, ship it!" test methodology.


    It's like being upset at your auto manufacturer if your car dies if you fill it from an old tank somewhere that still serves up leaded gasoline.

  • calebfromqld Level 1 Level 1

    Hi Donna


    Ask your coffee shop whether their router has wifi mode 802.11n (2.4GHz) enabled, and if so to disable it and allow only mode 802.11g.  There is little benefit to using the 2.4GHz mode n anyways, and my direct experience is that own router's flaky 2.4 GHz mode n caused problems with Lion for me (Lion would try to use it in preference to mode g).


    If you do manage to ask, and they make the change and it fixes your problem, please post back here to say so.




  • Augend Level 1 Level 1



    One year ago I had the same problem. This was related to my ISP ( I had wifi connection with continually disconnections and I could successfully ping .

    Go to a coffee shop , airport or library with WIFI and check if your problem resolves. If so, find out which ISP they are using and just change to that one.

    Since last year I have not had even one drop down.

    I know someone may say " This is not our responsibility to change our ISP and Apple should care about this issue, " but I prefered to stop complaining and just changing my ISP and now I have no problem with my wifi.

  • BenHart67 Level 1 Level 1

    Finally an update to my earlier posts about a fix:


    Working with Aruba and Apple. there was quite a bit of finger pointing but in the end, Apple had to work directly with our router vendor to find a workaround for the problem. It lies in the .ini file that most enterprise level routers use and there was a major change in Lion that was not apparent in the previous releases. If anyone is interested, I can ask our network team to give me the relevant piece of the .ini file to post here (it's possible they might tell me it's confidential). As of now Washington and Lee University has finally fixed the problem with a workaround from Apple about their issue.


    We weren't satisifed with just purchasing new routers because Lion didn't want to play nice, they had to fix their bug and while they did, they only did for our network (in script form, not OS patch form). Your mileage may vary, but both PCs and Apples have been stable as the new school year has come around. This includes about 3000 total computers with about a 60-70% Apple presence.


    I'm still a little peeved that Apple wasn't ripped to shreds in the media over this one (a la MS Vista), but hey, if the students are happy, we're happy.

  • calebfromqld Level 1 Level 1

    Please ask your network team for the precise technical explanation of the cause of the problem, as well as the workaround, and post that here.  Without this, there is nothing in your post that can help people still struggling with the problems.

  • BenHart67 Level 1 Level 1

    I'll see what I can get from them without compromising any network security. My only warning is that unless you have a heavily customizable router, this might not work for home users. I would definitely recommend this for anyone in the enterprise circuit. Will post more tomorrow...

  • Augend Level 1 Level 1

    I really agree with you. I had a very simple TP-LINK modem which worked fine for me. After changing to a customizable Linksys, suddenly I lost my Home Sharing and finally had to go back to my old TP-LINK.  Your post is completely in agreement to  my own post . I changed my ISP one year ago and during the last year had not any problem with internet connection. I think this problem is related to mismatch between Apple settings and some networks.