Previous 1 2 3 Next 256 Replies Latest reply: Oct 19, 2014 1:05 PM by TheB741 Branched to a new discussion.
belosh Level 1 Level 1

I've installed OS X Lion and now when I click on an icon on my desktop and drag it, it follows along nicely, only letting go of the mouse button doesn't drop it.  In fact, nothing does.  Instead the icon hangs onto the cursor as if I have kept holding down the mouse button.  If I want to drag something to the trash, when I hover over the Trash icon and let go, it acts like I'm still holding down the mouse button and instead opens up the Trash folder.  It's not limited to trash, it's just where I first noticed it.  I can't move files between folders. 


This pretty much happens across the board, too.  Drag an icon off of the dock to remove it, it just hangs onto the mouse pointer and never goes away.  Drag an icon from the icon bar at the top (command-click) and you can pick up the icon and move it, but never drop it.  Is there a solution to this?

MacBook Pro, Mac OS X (10.7)
Reply by sachl on Jul 20, 2011 8:42 PM Helpful

Quick fix for the drag and drop: sleep and wake your MacBook. For whatever reason everything is fixed when I do it. But if I restart, I lose it again. It must be some type of startup issue.

All replies

  • sachl Level 1 Level 1

    Just letting you know that you're not alone. I have the same problem. Can't find a solution anywhere. It sometimes happens with desktop files as well for me. Please holler if you find a solution.

  • Uthacalthing Level 1 Level 1

    Same here.  I'll be sure to post a response if (when! I'm an optimist) I get it fixed.


    Quick question to everyone else - What's your setup?  Perhaps there's a common theme here...


    My rig:


    • Mid-2009 Macbok Pro 15"
    • OS X Lion (obviously)
    • Magic Trackpad
    • Apple USB Keyboard with Numpad
    • External Monitor running via DisplayPort to DVI Adapter


    I should note that this behaviour occurs on both the internal and external trackpads.  Also, it's definitely not application specific.  I've had the same "failure to drop" in:


    • Firefox - dragging a bookmark
    • TextEdit - dragging selected text
    • Safari - dragging a bookmark
    • Finder - dragging a desktop icon
    • This post - dragging selected text inside the edit form


    I think we can agree it's Lion, not App, specific.


    WORKAROUND (of sorts) -


    I've also found that, once you release the drag, if you press Escape, then left-click, the dragged item will go back to where it started from.


    Hope this helps.



  • sachl Level 1 Level 1

    Quick fix for the drag and drop: sleep and wake your MacBook. For whatever reason everything is fixed when I do it. But if I restart, I lose it again. It must be some type of startup issue.

  • mjisrawi Level 1 Level 1

    Wow for some ridiculous reason the sleep/wake solution worked. I was about to reinstall, but now that I found this thread I may hold off on that...

  • belosh Level 1 Level 1

    The Sleep/Wake worked for me as well.  Thanks for that one.

  • FlorentAlexandre Level 1 Level 1

    I'm in the exact situation, will post back if I find anything. Apparently, this hapenned to some users with snow leopard, maybe they found a way to fix it.

  • DominicO Level 1 Level 1

    Same here my friends. It is extremely bad, my machine is totally inoperable. Randomly decides to grab onto anything clickable (icon, mail attachment, mail message, layer in photoshop) and refuses to let it go. Until I slam on my keyboard like a monkey and it finally returns (with a slight animation to the movement, oddly. Is this a Mission Control issue?)




    Late 2008 unibody 15 inch MacBook pro, with the graphic processor factory upgrade.  


    Using  Better Performance  Nivdia9600mt card


    My main monitor is a cintiq 12wx, which I was positive caused all this but now not to sure. This happens with rhe cintiq, the track pad, other wacom intious, multiple driver reinsalls, etc.


    I too have a DisplayPort to Dvi attached but not in use (but the drier runs in the background for some reason.)


    I use both my mbp keyboard simultaneously with  the apple Bluetooth keyboard.


    Olmert sleep and report back. 

  • patricefrombern Level 1 Level 1

    Have the same problem too. And I have the german version of lions. Must be a bug...?

  • patricefrombern Level 1 Level 1

    The Sleep/Wake worked for me as well.

  • techdag Level 1 Level 1

    How amazing... I have EXACTLY the same problem...


    My Rig


    Macbook Pro 15", Mid 2009, 2.66 Ghz. (Dual Graphics - GeForce 9400M & GeForce 9600M GT) running OS X 10.7 Build 11A511 - The Gold Master and eventually Retail version.



    I have been running Snow Leopard and its subsequent updates, since its release. I have never had any issues with it at all, it was just the idiosyncrasies of the 3rd party software that would cause problems, but only minor, By the time Lion came around (I am a Developer so I got the GM in early July) I actually had a very stable rock solid computer


    I am very methodical backing up, so when Lion was publicly released, I did the final Snow Leopard Migration assistant update, did a complete time machine backup.

    I noticed that the build of the newly released Lion was the same as the development GM, so I decided to do what a normal customer would do, download it from the app store and install it on my now very stable Snow Leopard installation.


    After the download finished, I clicked the install, nothing else and as per normal, thirty or so minutes pass and a restart happens, Lion is installed successfully over the top of my Snow Leopard.


    Now here is when the problems started :-


    When Lion booted, I just got a gray thatched screen, the login window was obviously there bust I couldn't see it, so typing blindly, I typed my password and the computer then loaded up my user account.


    When that had finished, It looked nearly identical to the old Snow Leopard (a good thing). but when I clicked and dragged ANYTHING, in the Finder or in an App, what ever I was dragging stuck to the cursor and will not go away. I had to force quit the Finder or the App in question to get the cursor to "drop" the icon. (The problem in this thread)


    the Second issue, was nothing with video or photos displayed... If I launched Safari 5.1 for example, and go to YouTube, the YouTube page would load, but as soon as it finished, It would flick to a blank white unclickable page.


    Even the System Preferences were effected... If I went to Desktop & Screensaver the screensaver examples would just be a white box, nothing in them.. Desktop pictures were white. Even in the Finder, all the ICONS were white boxes.. no matter which view you put them in...


    So these 2 combined issues are are pain...


    anyway I solved the white page / Icons / screensaver / Flash / Youtube / problem by going to System Preferences, Energy Saver and turning the Graphics option to "Higher Performance"

    If you have it set to "Better Battery Life" - the white screen problem reoccurs.


    So I am now at the same stage as all of you. I have icons, text, browser elements, etc all sticking to the cursor when I go to drag them.. They just will not let go..


    My temporary workaround :-


    Create another user account on your computer


    Log into yours (which will be experiencing the stuck icon issue) then just switch to the newly created account and back to yours again.


    That fixes it...I don't know why, but it does.


    I tested it the other way as well... If you log into the newly created account first, it WILL experience the sticking icon problem.. Switching to your account and back again, fixes it...


    All of this is really unnecessary and totally annoying... so I hope someone figures out what the **** is going on... I don't want to keep switching accounts every time I boot up the laptop...

  • FlorentAlexandre Level 1 Level 1

    I guess switching accounts does the same trick as putting it to sleep and waking it up, you should try that it's less painfull.

  • gianfranco66 Level 1 Level 1

    The Sleep/Wake hasn't worked for me.

    My Mac mack Book Pro is Mid 2010 with both internal and external magic trackpad and Lion, obviously.

    The problem is present even when trying to resize windows.

    In the meanwhile I'm using the "Move with three fingers" in the Trackpad configuration preferences

    Thanks for any help.

  • techdag Level 1 Level 1

    Just tried the simple sleep / wake thing... it worked.. go figure?


    I know from the switching accounts method, that this problem is related to the hardware or the system software, it has nothing to do with the general 3rd party software...


    Maybe we all have a common System Level  Driver / Preference Pane / Plugin / Application enhancer / Extension / font etc that may be causing this...


    I Have the following Pref Panes:



    Application Enhancer


    Flash Player

    Flip4Mac WMV



    Vuzix iWear

    Yamaha USB-MIDI


    all of which are the latest versions


    Contextual menu Items



    Speed Download Contextual Menu



    Heaps of frameworks (maybe its one of them)


    I might look at all the system logs and see if any of the UI or Controller APIs have crased or failed to initalise due to some weird thing...

  • sneeo Level 1 Level 1

    Worked for me.

Previous 1 2 3 Next