Previous 1 2 3 4 5 Next 256 Replies Latest reply: Oct 19, 2014 1:05 PM by TheB741 Go to original post Branched to a new discussion.
  • FlorentAlexandre Level 1 Level 1

    Try to check for .kxts files in your /System/Library/Extensions and move them out of it then restart, it seems that some other plugins can cause the problem.

  • JasonCampbell Level 1 Level 1

    It was DisplayPad

  • techdag Level 1 Level 1

    **** RESOLVED ****


    Laundry Bleach is the man!.. His suggestion of Displaypad or iDisplay was my issue...


    I have iDisplay.


    Now removing the application WILL NOT solve the problem, you need to get rid of all the ktxts as well and all the other support files.


    Just either open the iDisplay Desktop 1.3.1.dmg you have, or download it again from shape services website :



    then just run the iDisplay un-install from the dmg.


    It will remove the app & all support files, fixing the problem.


    I have emailed Shape Services about this problem, with a link to this thread for them.. lets hope the update the software so it works...


    The Current version as of this post, is iDisplay Desktop 1.3.1 which DOES NOT WORK with Mac OS X 10.7 Lion.


    remove any instances of it until its updated.

  • Uthacalthing Level 1 Level 1

    For me it was a driver for a 3rd-party USB External Display adapter ("DisplayLink.kext").  Uninstalling did the trick!


    Perhaps there's some code in Lion that disables drag & drop for every driver that contains the word "Display" :-)


    Seriously, though, it does seem to be an issue with external display drivers of various kinds, and only seems to affect Macbook Pros (although Laptop users are more likely to use these sort of drivers, it may just be that no one on a desktop mac has this setup).


    Good work to everyone in troubleshooting this tricky bug, especially LaundryBleach for the suggestion of DisplayPad, which really got things going!

  • belosh Level 1 Level 1

    It was DisplayLink for me as well.  Thanks LaundryBleach and everyone for figuring this out.

  • Uthacalthing Level 1 Level 1

    belosh, I think 10 points for correct answer should go to LaundryBleach, we could've been mucking around with this for days if not for that suggestion...

  • belosh Level 1 Level 1

    Now the question is where do we go for a solution?  Is it OS X since it seems to be a problem across the different USB display drivers.  Or do we go to the display driver writers and ask for a solution?  I need my third monitor.  For now I'll live with the sleep/wake workaround.

  • Uthacalthing Level 1 Level 1



    In our particular case (the DisplayLink drivers), there is a forum on the DisplayLink website covering this issue.


    I have already posted there (in response to someone else posting about drag-and-drop), and cross-linked this thread, explaining that it's not unique to the DisplayLink driver.


    Hopefully, this will get resolved soon.  After all, DisplayLink's Lion driver is stil in beta, and this is the sort of issue that betas are designed to resolve...


    FYI, here is a link to my post on the DisplayLink forums:



    As for me, I don't use drag-and-drop enough to give up my third monitor at work.  I'm gonna get used to using Cmd-X and Cmd-C for a while





  • My voice is my password Level 2 Level 2
    Old Hardware

    not sure if anyone is still having problems but if you are, have you removed or re-installed AirDisplay, AirPay or DisplayLink?



  • patricefrombern Level 1 Level 1

    Yes , i do still have the problems! I dont have installed AirDisplay, AirPay or DisplayLink. I tried everything written in this forum but it still doesn't work. I also tried to eliminate different plugins in the extension folder but nothing worked.


    I don't know what to do. I think i will have to wait the first lion update!


    My mac is a MacBookPro 2009 (beginning). Maybe somebody has another idea. Thanks and sorry for my bad english! I'm swiss!

  • gianfranco66 Level 1 Level 1

    Same thing for me.

    I still have the problems and I dont have installed AirDisplay, AirPay or DisplayLink.

    As for Patrice I tried to apply everything has been suggested in this forum but it still doesn't work.

  • belosh Level 1 Level 1

    For me, it's the displaylink driver. But I still use it.  The sleep/wake technique works for me until they get it fixed.  Since it's not limited to a single driver, I'd bet there are others that cause the issues as well.  It's just the USB display drivers were what's been identified.  I sort of claim this is still a Lion problem, though, so I'm hoping Apple fixes whatever the bug is.

  • patricefrombern Level 1 Level 1

    The only question is when...! The sleep/wake techninique works but its troublesomely. I just wonder why apple released an incomplete system software. That should not be and leads to a bad image!!!

  • maputo Level 1 Level 1

    Deleting the screensharing program (in my case iscreen, guess airdisplay, etc are the same) did solve all my issues -- as mentioned before drag and drop did not work, white screen in several programs, not menu bar in full screen, etc.


    Lion is now running smoothly - so everybody having the same issue just delete airdisplay and co :-))))))


  • belosh Level 1 Level 1

    Some of us don't have the luxury of deleting the programs in question.  I mean, I *could* but I do development work and rely on having three screens at once. It's clear there needs to be some form of fix to this.

Previous 1 2 3 4 5 Next