Previous 1 2 3 4 Next 48 Replies Latest reply: Aug 31, 2013 8:18 PM by WinForTheWin Go to original post
  • JonBOY26 Level 1 Level 1 (10 points)

    Nice one Spiritunicorn, that's made a massive improvement!

     

    Thanks mate.

  • Jedijoe Level 1 Level 1 (0 points)

    Hi,

     

    Found a work-around for my Logitech Performance MX, turn off 'Enable Smooth Scrolling' in the Setpoint control panel and presto, scrolling in Safari works again...

  • dherran Level 1 Level 1 (0 points)

    What Spiritunicorn said totally works. Thanks man!

  • JMR77 Level 1 Level 1 (0 points)

    Running Windows 7 Pro with MS Intellimouse, I do not have an option for Smooth Scrolling... Any ideas?

  • ChrisWNY Level 1 Level 1 (0 points)

    For Microsoft Intellipoint within Windows 7, you can add EXCEPTIONS for applications that do not work with smooth scrolling. To disable smooth scrolling JUST for Safari 5.1 (which corrects the scrolling lag), open up the "Mouse" Control Panel, click on the "Wheel" tab, and underneath the "Enable Vertical Scrolling" checkbox, there is a hyperlink for "Identify programs that don't scroll correctly...". Click on this. Then click "Add..." to add an application exception, and scroll down until you see "Safari" in that list. Go ahead and click "OK" to add Safari to the list of exceptions, and you'll no longer have a scrolling lag within Safari for Windows 7 (x32 and x64 editions).

     

    Of course, the assumption here is that you have the latest Microsoft Intellipoint software installed on Windows 7. You can download Intellipoint from Microsoft's "Downloads" area, it's free software and Windows 7 will update it automatically for you. Make sure you download the correct version, depending on whether you have the x32 or x64 edition of Windows 7.

     

    Safari does not work properly with "smooth scrolling", until Apple updates Safari to include smooth scrolling compatiblity, smooth scrolling must be disabled or mouse wheel scrolling within Safari will not work.

  • Nikos Lazaridis Level 1 Level 1 (5 points)

    Indeed, adding Safari to the exceptions list using Microsoft Mouse (as indicated above by ChrisWNY) did make things better (Windows 7 Ultimate 64-bit).  However, "scrolling" is now much more "jumpy", which is annoying to say the least.

     

    I do not recall Safari having such issues in its previous versions.  Let's hope that Apple can sort this out because it is degrading an otherwise excellent browser (and I don't want to go back to IE on my Windows computer...).

  • ChrisWNY Level 1 Level 1 (0 points)

    That's correct, scrolling is still pitiful in Safari, even after adding Safari as an exception to smooth scrolling. At least the scroll button does something after the exception is added,  I've reduced its use significantly since the problem surfaced as a result of the 5.1 update.

     

    I'm hesitant to use Safari for other reasons beyond just scrolling, it loads certain web pages horrendously slow, I've reported every website with "slow loading" problems as bugs to Apple via Safari's "report a bug" feature. The same websites (that load slow in Safari) load in a blink with Firefox (with CACHE completely disabled). I have a 50Mbps connection, an a top of the line 6-core system, 32GB of RAM, bandwidth/system performance isn't the problem here.

     

    Safari 5.1 is still very lacking in terms of performance, other browsers (such as Chrome and Firefox) run circles around Safari for webpage load times for most websites. Safari is just a fraction of an inch away from the trash can, either it doesn't play well with Windows 7 x64, or it doesn't play well with any version of Windows.

  • mattissotrendy Level 1 Level 1 (0 points)

    I've not got 'Identify programs that don't scroll correctly' anywhere on my options. =[

  • rdlinky Level 1 Level 1 (0 points)

    That worked for me as well.  hanks for the information.....

  • timbosta Level 1 Level 1 (0 points)

    Yep, WIndows 7 Ultimate, just bought a Wireless MS Mouse and KB, and it no longer scrolls in Safari pages. The thing is, it scrolls on the iGoogle opening screen, but not on results...? Chrome, Opera & IE9 (which isn't half bad) are fine. Firefox I binned ages ago - I just don't like it There's no Smooth Scrolling Option on the Mouse properties, so I'm stuffed until Apple sorts it

  • iberglund Level 1 Level 1 (0 points)

    Spiritunicorn is right. This works with the Logitech - MX Revolution too.

     

    My scroll wouldn't work unless I rolled the wheel real fast. After disabling "Smooth Scrolling" the scrolling worked.

     

    Open Setpoint - My Mouse - Pointer & Scrolling settings - Uncheck smooth scrolling.

     

    It didn't seem to mess with the other apps "smoothness" as far as I can tell.

     

    I hope this helps someone because I was just about to stop using Safari befor I got it to work.

     

    Windows 7 Pro

    Logitech - MX Revolution

    Set Point Control Center - Ver. 6.30.41

    Driver - 5.30.67

  • dbhoosier Level 1 Level 1 (0 points)

    I had the same issue (Logitech mouse) and disabling "smooth scrolling" did the trick.  Thanks!

  • AppleWhine Level 1 Level 1 (0 points)

    Perfect solution!  Thanks.

  • timbosta Level 1 Level 1 (0 points)

    Nope. Might work with a Logitech Mouse, but not with a Microsoft Wireless. Thing is, it now scrolls perfectly in Chrome. Don't know what I did, but it's just Safari. It's not the only problem I have with Safari. Guess I'm just gonna have to bin it.

  • AppleWhine Level 1 Level 1 (0 points)

    I have a wireless Microsoft mouse (and Keyboard), followed the instructions in ChrisWNY's post and it that fixed it for me.  Maybe you don't have the latest version of Intellipoint.