Previous 1 2 3 4 Next 48 Replies Latest reply: Aug 31, 2013 8:18 PM by WinForTheWin Go to original post
  • BigJtrue Level 1 Level 1

    I have a wireless Microsoft mouse... Download latest version of Intellipoint from microsoft website (free). Fixed the problem for me.

    Thanks ChrisWNY. Was a great help.

    Cheers

  • timbosta Level 1 Level 1

    Yep, solved it for me too. Thanks. I didn't realise Intellipoint worked for Mouses (Mice?) that weren't labelled 'Intellimouse'. But it does. Great.

  • Kazper2840 Level 1 Level 1

    I use a Logitech Performance Mouse MX with Windows 7 Premium (64 bit) and was having the same problem. I went into the "SetPoint" program and under "Pointer and Scrolling Settings" unchecked "Enable Smooth Scrolling." Scrolling works fine in Safari 5.1 now.

  • iSeba Level 1 Level 1

    Thanks man! This worked!

  • alexfromportsmouth Level 1 Level 1

    Worked for me too, after BOTH adding Safari to the list of problem programs (etc) AND unchecking the 'enable smooth scrolling'.

     

    SO, curious, I went back and REMOVED Safari from said list (had to re-enable smooth scrolling to do this, then un-enable it again afterwards)..... ie, with JUST the 'enable smooth scrolling' box UN-checked.... my MS wireless mouse wheel works in Safari!

     

     

  • Brian in DC Level 1 Level 1

    There is one problem with this so-called fix.  That is if you have an older MS Mouse.  I have a MS Wireless IntelliMouse 2.0 and even the latest version of the software does not have the smooth scrolling option so this fix will not work.  I like Safari, even though it is by far the slowest browser available, for the multiple web page view which I think is awesome.  The only solution for me that fixed the problem was removing v5.1.2 of Safari and installing an older version like 5.0.5 from 10 months ago.  This fixes the scrolling problem.

     

    Once Apple gets this fixed in a future version of Safari I will re-upgrade to that.

  • Magicianic Level 1 Level 1

    Hi,

     

    In order to benefit from "smooth scrolling" - even ater disabling it in the mouse properties, just install MagicMouse extension.

     

    Works like a charm!

     

    and tnx again to spiritunicorn for the solution

  • Joelrz Level 1 Level 1

    I installed the mouse's software from Microsoft and the scrolling got fixed.

  • Leo Shurtleff Level 1 Level 1

    Thanks for the tip. It worked perfect. I am using Win7 and Logitech M705 mouse (with SetPoint software). This problem has been driving me crazy for months!

     

    Thanks again!

  • rynerhoden Level 1 Level 1

    Awesome... Thank You!

  • seattlematt76 Level 1 Level 1

    Thanks for the information!!!  Your workaround worked great! 

  • PedroStephano Level 1 Level 1

    Thanks for all the input everyone! Sorted on my W7 64b with Logitech MX Anywhere Mouse by changing smooth scrolling to off. Sorted. Praise all round :-)

  • gprayback Level 1 Level 1

    Good one.  That fixed it!

  • xdunlapx Level 1 Level 1

    I unchecked smooth scrolling in the SetPoint software for my Logitech Marathon M705 mouse. It worked. I now have scrolling in Safari 5.1.7 Thanks!

  • Nikos Lazaridis Level 1 Level 1

    I am a bit confused with all the people that go "Ah, yes, now it works.  Thanks!!!! :-)" etc.

     

    In my case, when I do the thing that spiritunicron suggested, the problem was not fixed, it only improved somewhat but the behaviour is still not right.

     

    I have Safari v5.1.7 on a Windows 7 Ultimate 64-bit system, using a MS Natural Wireless Laser Mouse 7000 and Intellipoint v8.2 (for 64-bit).

     

    Even after applying the "solution", the scrolling is not smooth at all.  The functionality basically moves from downright horrible & unbearable to bad.

     

    I am only mentioning this not to degrade other people's comments but only to ensure that Apple doesn't get the message that this workaround resolves the problem (and hence, they don't need to do anything to fix it).

     

    They in fact have to provide a fix for this Safari bug.  So, Apple, please work on it.