Previous 1 2 3 4 Next 48 Replies Latest reply: Aug 31, 2013 8:18 PM by WinForTheWin Go to original post
  • onehas Level 1 (0 points)

    I believe I was the first one to report this problem after a Safari upgrade about a year ago.  The "fix" only works on some microsoft mouses.  I am sure that Apple is aware of the contiuing problem.  Obviously problems relating to microsoft products are not a high priority. 

  • Nikos Lazaridis Level 1 (5 points)

    I'd tend to agree that they are not going to jump on issues that relate to Microsoft products.  After all, it is better for Apple if someone is using Safari on a Mac rather than on a PC.


    However, I own a Mac and because I've had a positive experience with Safari on my Mac, I've made the consious choice to use Safari on my PC as well, keeping to the side Internet Explorer, Firefox, Chrome etc.  Clearly doing Apple a favour here.  So even though in general Apple will not prioritise MS-related issues, there are cases where Apple stands to benefit from fixing issues on the Windows platform.

  • WestAussieRob Level 1 (0 points)

    I found that disabling the wheel "Button" option actually fixed the issue in the settings of my microsoft mouse.

  • WinForTheWin Level 1 (0 points)

    I dealt with this same problem for a long time.  I use a blue Microsoft Mobile Mouse 4000 with the IntelliPoint software active.  To fix this issue easily and quickly add safari to the list of programs that have mouse issues, and install an extension known as 'Magic Scroll' from the apple website.  The extension can be found under 'productivity' about 2/3 of the way down.  Go to preferances and under extensions you will find the settings for scrolling.  Smooth scrolling also works really well!!  That's it!




    When you are adjusting your settings, you MUST close out of the preferences window and RELOAD the webpage you are testing your scroll settings on.


    Anyway, hope this helped!

Previous 1 2 3 4 Next