Skip navigation

After Lion upgrade, having network issues after wake from sleep

49003 Views 213 Replies Latest reply: Aug 16, 2012 11:35 AM by SpectreOne3 RSS
  • ctomer Level 1 Level 1 (35 points)

    William Kucharski wrote:

    Note that the odds of your problem being fixed in a future Lion release go down if you haven't contacted AppleCare, that's why I urge people having issues to do so.

     

    It's only in that way that commonalities will be revealed to Apple's engineers.

     

    Thanks for your advice.  I raised a bug with Apple weeks ago.

  • vdev Calculating status...

    I am having similar issues with two 10.7.1 systems. I am not having problems with AirPort so I'm not able to comment on that. But DNS lookup after wake-from-sleep is certainly an issue.

     

    What I see is that, after waking from sleep, some DNS lookups fail but not all. Safari fails and says I'm not connected to the internet. Google Chrome is more specific in its diagnosis and says that the DNS lookup failed. However when I tried Mail, it worked. And "ping" in Terminal found the correct address. Also, "dig" worked but it uses its own resolver code so that doesn't count (except to ensure that you *are* connected to internet and that name resolution *can* work).

     

    My main system uses static IP and wired Ethernet. The simplest way I have found to make things work is to go to Apple menu -> Location and choose a location. Even reselecting the current one brings things to life.

     

    My laptop has the same problems when wired. But with no Ethernet, it reliably associates using Airport (base station is AirPort Extreme, uses WPA2). There's no DNS problem in this case.

  • Kevin Hussey Calculating status...

    Hi

     

    I went into my local Applestore today where I had made an appointment to see a Genus. Im having a few issues with my Imac and MBP.

     

    The first is connecting to a Network from sleep on my MBP. The genius sugested that I go to my Macintosh Hardrive, then Library, then preferences, including system config. I deleted all the contents of the preferences folder with the exception of Xsan as directed. My laptop now connects immediatley to my Network and internet from sleep.

     

    The second issue (Imac) I have is that my second G Raid drive (4TB) which is daisy chained via Fire 800 on my Imac to a G Raid 2TB (the 2TB is for my time machine backups) keeps producing incorrect disconnection messages and I have had to repair the drive on each occasion.

     

    I would rather not daisy chain, but I think the Imac has only one Firewire port and USB is to slow for my liking for moving files about.

     

    The 4TB drive has already been replaced last week and they are suggesting it could be a faulty Firewire controller on the 2TB G Raid which is directly connected to the Imac.

     

    Any suggestions for the second issue appreciated.

  • Russo017 Calculating status...

    Okay well looks like 10.7.2 did it for me. Haven't had any DNS/Wake issues since upgrading. This issue was also mentioned in the 10.7.2 changelog.

     

    Good work, Apple. Could've been fixed a little quicker though.

  • lorandreas Calculating status...

    Looks lik 10.7.2 didn´t fix it for me

  • Adeel Calculating status...

    The issue has been resolved after 10.7.2 for me. Thanks Apple.

  • William Kucharski Level 6 Level 6 (14,405 points)

    I tested this earlier and at least for me the "put to sleep while backing up using a Time Capsule/no Wi-Fi on wakeup" issue was definitively fixed by 10.7.2.

  • zenpen Calculating status...

    I'm having pretty much exactly the same issues as described in the original post - but only AFTER upgrading to 10.7.2. Everything was running fine under 10.7.1 - at least as far as waking from sleep was concerned. Anybody else affected the same way?

  • CSamontreal Calculating status...

    Mac OS X 10.7.2, connected to router through a cable.

    In case it is relevant, Time Machine is active on a WD 1 TB USB drive.

    The Mac looses conection every time it wakes from sleep.

    The original problem was "another device is using the same IP address" (which happened to be the Apple TV).

    I hard coded the Apple TV and the Mac addresses, and the symptom changed to this (no connection).

    I can fix it without rebooting by changing the IP address.

     

    On the LAN, I have two MS Windows laptops, Apple TV, the Mac and one iPad.

    One laptop and the Mac are hardwired to the router, the rest use wi-fi.

    The Mac is the only one with this problem.

     

    In short, 10.7.2 did not fix my problem.

  • e-mil Calculating status...

    It seems there is more than one problem being discussed here.

     

    I had none of theese problems before. Only right after I updated to 10.7.2 none of the apple programs can connect to internet. Including iTunes, Mail, App store, Facetime.

    The problem is not that the internet connection would be lost. Firefox works fine, so does transmission and any other 3rd party program as far as I can tell.

     

    I don't have timemachine running or any external drives installed.

     

    What makes this so much more annoying is that in result of a program not being able to connect, it stops responding. So every time I want to shut down I have to manually kill iTunes, Mail etc.

    The only way I've been able to fix the problem is to do a reboot (logout didn't help). Though the problem comes back right away (probably after wake from sleep, I havn't tested much yet).

  • zenpen Level 1 Level 1 (0 points)

    In response to the above, I tried Firefox. It seems that just having Firefox present on the desktop at sleep/wake up is enough to persuade Mail & Safari to work normally on waking up as well.

     

    I don't have the time to fiddle about too much at present but when I can, I'll see if I can narrow things down a bit more before contacting Apple with some better information.

     

    Incidentally, my broadband connection is via an Apple Airport Extreme with a wired link to my Mac Pro. All the other items connecting wirelessly to the Airport Extreme are unaffected by these issues.

  • chessop Calculating status...

    I am running 10.7.2 and see an issue when waking up from sleep.  DNS lookup fails but everything else works.  The interim solution that works for me is to disable/enable wireless or network connection.

  • AshleyTarver Level 1 Level 1 (0 points)

    You say "interim", but this thread is 4 months old now, and some people have suffered the same problem since Snow Leopard.

     

    I am truly amazed Apple haven't fixed it yet. Each week that goes past I am relieved I went back to Snow Leopard.

  • zenpen Level 1 Level 1 (0 points)

    There's no doubt for me that updating to 10.7.2 really upset my system. Up to that update, everything seeemed quite stable. I'm still working through all the issues I have but I cope with the above problem by shutting down Mail (or any other piece of Apple software accessing the internet) before I sleep the computer, which is generally just overnight. If the issue persists through the next update, I'll solve it by going to different e-mail software. Firefox seems to have no problems accessing the internet if it is running on waking. The other most noticeable issue is losing the Bluetooth connection to the Magic Mouse on restarting even though the Magic trackpad connects normally.

  • brendan237 Calculating status...

    Got the same issues with no connectivity on wake from sleep.  Both on Wifi and Wired gigabit.

     

    Connectivity does come back after a while - maybe 30 -40 secs delay.  All the apps complaining in the process..

     

    Generally having a heap of issues with mac book pro not sleeping or waking properly.  Was ok until recent Lion update.

     

    On 10.7.2

     

    Have read mentions of some apps causing it to play up so testing with no apps running, still issues on starting from sleep.  Woud get keyboard light up, but no screen.  Or it seems to be reveresed.  I.e. close lid and it wakes up!!  Go figure. 

     

    Closing and opening lid a few times seems to wake it up eventually.  Very frustrating.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.