Previous 1 2 3 Next 140 Replies Latest reply: Apr 25, 2015 7:24 PM by grokstarr
SCCThreeIII Level 1 (0 points)

I just upgraded my i7 MBP to Lion.  I connect to an Airport Express running in dual mode.  I can connect to 802.11g but I get this error when I try to connect to the 802.11 5ghz side.


Failed to join "network"

A connection timeout occured


I have rebooted the Mac and the Airport Express.  No luck.

MacBook Pro, Mac OS X (10.7)
  • SCCThreeIII Level 1 (0 points)

    Forgot to mention 802.11n was working fine before the upgrade. 

  • SCCThreeIII Level 1 (0 points)

    I tried deleting the keychain entry for the 802.11n connection.  Didnt work.

  • wifiguru Level 2 (240 points)

    Try this. Launch Terminal app and enter


    sudo /usr/libexec/airportd debug +alluserland +alldriver +allvendor

    sudo /usr/libexec/airportd logger


    Now reproduce the issue and then paste the output of the Terminal app. here so we can try to decode it and help.


    Another thing to check:
    Make sure you use WPA2-Personal as your security method. If you use WPA-Personal, then the Mac won't connect in 11n mode. So set your wireless router to 802.11n and pick WPA2-PSK as the security.

    On your Mac, delete the network from Preferred Network List's and then re-join using the WiFi Menu Extra. ( Scan and click on the network to join).

  • SCCThreeIII Level 1 (0 points)

    wifiguru - Thanks for your help.


    I was going to post the full screen scrape but now the 802.11g gives the same error so I can not connect that machine to the internet now via wifi.  I will drag the ethernet cable out tomorrow and post the full results if you need more information.  Too tired right now. 


    Long story short, it was giving a -3905 error.


    I am posting this from my MBA which I just upgraded to Lion and it is on the 5ghz network no problem.  Strange.

  • SCCThreeIII Level 1 (0 points)

    Also, just tried changing the channels on n and g.  Same result for the MBP.  The MBA still works fine.

  • SCCThreeIII Level 1 (0 points)

    One last thing before bed.  No antivirus is running on the MBP that is having this issue.

  • fattakin Level 1 (0 points)

    Same problem here with 2010 i5 MBP.  can't connect to home router or my Samsung galaxy s2 in paired mode. the wifi has always droppedon my mac have been through a linksys, netgearand dlink. i will try the advice above and report back. If i try a neighbours secured wifi i at least get password prompt but my own gives instant connection timeout.

  • SCCThreeIII Level 1 (0 points)

    Well I fixed it.  I reset the wpa2 key on the router to something a little less complex.  After that it connected up.  Bizarre. 

  • Callumy Level 1 (0 points)

    I am having the exact same issue with a 5Ghz network , My router generates both and it conencts to to the G Network fine but dies when its on the N All this has happend since upgrading to Lion

  • toddpi314 Level 1 (0 points)

    I had the same issue only on an IMac, not the macbook pro, when upgrading to osx lion.


    When the router auth is on WEP, Lion fails with the connection timeout error.

    When on WPA2, lion connects just fine.


    But, the fix only worked for a few minutes. Lion connected and was happy for about 10 minutes of browsing time.

    After that, same issue with WPA2.


    Looks like a big OSX Bug.



  • rjvaughn Level 1 (0 points)

    I have this issue with my mac air. I've connected to my Netgear G/N router once -- just briefly -- on N since upgrading to lion. But 99% of the time it connects on G. I've tried all the suggestions -- remove all the "known" connections, add them back in etc. etc.  But none of this help. For me, my mac air doesn't even see the N broadcast, just the G. I'm sitting 10 feet from the router.


    This was absolutely broken in lion. The behavior started immediately after the lion upgrade.


    Everything else on lion is fine for me. But this is really annoying on a mac air that heavily depends on wireless.

  • Callumy Level 1 (0 points)

    Same as above but with a mini! I'm not liking lion at the moment!

  • dchill_weblinc Level 1 (0 points)

    Same error for me on a mini since the 10.7 upgrade. This computer cannot get on any type of wifi network. Not an 802.11a/b/n/5Ghz. My base station is a time capsule but I also tried my neighbors network and comes up with the same network timeout error.


    Anyone using eyetv by chance? I had an issue similar to this a couple of years ago that had something to do with eyetv on startup.

  • rjvaughn Level 1 (0 points)

    Everyone should go to and submit a bug report. I just did. Apple needs to understand they have introduced a serious regression that they need to address.

Previous 1 2 3 Next