Previous 1 6 7 8 9 10 Next 140 Replies Latest reply: Apr 25, 2015 7:24 PM by grokstarr Go to original post
  • nashman Level 1 Level 1



    I appreciate your thoughtful reply - However, I'm not a newbie to all of this. An ex-Apple Systems Engineer and have had a Mac since the very first 1984 days. (Yes, I'm old!)


    But for the education of those following this thread, let's walk through what was suggested.


    1.  The MacBooks in question work fine on my home network, wired or unwired, as well as in many businesses offering WiFi.


    2.  Systems are always kept up to date - latest version of Mountain Lion on all machines.


    3.  Familiar with the authentication phase you describe - however, the problem occurs when I attempt to connect to that retailer's network using either the Network pane of the System Preferences application or by using the WiFi config option in the menu bar. The system won't stay on the selected network - that's when I get the "Connection Timeout" error has occurred. The system then goes back to having NO WiFi network selected. So I can't get to the retailer's landing page to agree to anything.


    Coincidently, I will sometimes have a problem with my 3rd generation iPad also failing to connect to these same problemmatic networks.


    Still scratching my head!

  • Dave Hansford Level 1 Level 1

    Hi, I was also having this issue with my mid 2010 MBP after Sky upgraded my router with a 802.11n comaptible model.

    the solution turned out to be something i'd seen suggested on an Xbox forum years ago when problems occured connecting to 802.11g routers.


    go into your routers setup and locate the advanced settings.


    find the option for UPNP and disable it.


    as soon as i turned of UPNP my Mac book Pro signed onto the wifi first attempt.

  • Starr_fire Level 1 Level 1

    We have 3 macs and all of them have the same problem.  Aside from the many solutions recommended here we also tried upgrading our 1 year old Netgear to the latest Cisco wi-fi router -- and still encountered exactly the same issue.  Non-mac clients seem to be fine.

  • gbonics Level 1 Level 1

    Had the same problem with Cisco AP's and OSX.  I noticed everthing was fine until I changed from WEP to WPA2.  Did everything I seen in these post then I noticed that I only had the problem with AP's that were 2.4GHz.  The AP's with dual radios of 2.4GHz and 5GHz have no problem.  The connections at 5GHz are working solid now that I have replaced all the APs. 

  • screamingmeanie Level 1 Level 1

    Me again.  I just kept dealing with the problem.  I'd always get on....might take a minute or so, but I'd get on.


    Problem finally solved itself when I got a new modem.  Boom badda bing.  Problem solved.  A joke that it has to be this way, but sometimes the best solution is just dump the old equipment I guess.  Good luck to everyone deciding NOT to do that.

  • screamingmeanie Level 1 Level 1

    Forget THAT last solution.


    Starting up the network after the computer goes to sleep leads to various failures to connect with aforementioned manueuvers to finally get it to connect (including the ALWAYS successful shut down and restart...ugh!)


    My first real crummy problem with my Mac. 


    Snow leopard reliability is missed.

  • Level 1 Level 1

    I have a solution which works for me. Follow these steps:


    • Wire your computer into the router with an ethernet cable.
    • Figure out the IP address of your gateway router
      • Open Terminal
      • Type this command: route -n get default
      • The IP address next to gateway is your gateway IP address
    • Open your web browser
    • Go to (replace with your gateway IP)
    • Log into the router. If you don't know the username / password, look on the bottom of your router or contact your ISP
    • Now you want to go into the wireless setup utility on the website and change the radio to use a specific channel ranging from 1 to 11 instead of using auto.
  • RNDRND Level 1 Level 1

    As i wrote in another thread, please read this, hope it will help you.


    I've had the same problem with my Macbook Pro, and also with my iPhone 5, couldnt connect to Wifi.


    After I spent days to finding the solution, you can't imagine what caused this problem. I'm using since a few weeks  an A/V transceiver  to send audio video signal to one room to another. Its operating on 2.4  GHz, and unfortunately it was set to the same channel which was selected automaticly by the router...


    After 2 seconds, when I pulled out the power plug from the transceiver, both MAC and iPhone has been joined to the Wifi without any error. I plugged the power back, both lost the connection, and couldnt connect back.


    So probable there was some interference between the router and the transceiver device, and probably at you also, Maybe a lots of router or AP using that same channel range which youre router want to use, or some other device in youre area causing some interference.


    Try to select another channel in youre router Wifi configuration, if isnt working, try another, and another, if you find a clear channel, it should solve youre problem also, like my.

  • RNDRND Level 1 Level 1

    By the way, since yesterday, after I unpowered the AV device, which caused the interference, both Mac and iPhone are on the Wifi, without any error.


    Its funny, because my friends Samsung phone never have got connection problems to my Wifi...


    Probably Apple's procedure to build up a wifi connection is to sensitive for any occured problem in the line, and rather drops the line and wouldnt build an uncertain connection...

  • wifiguru Level 2 Level 2

    What make and model was the AV receiver ? I am looking to buy one and want to make sure I don't get the one you saw all these issues with.

  • RNDRND Level 1 Level 1

    MAXIMUM digital technology


    Model No.: AV-T2G4B

    If you type the model no in Google picture search, u will find it on the first three photo.


    But i dont think this is about the device, its more like the configuration of the devices.

  • joan1957 Level 1 Level 1

    Been fighting this error for over a week now..... Have two iMacs two iPhones 4&5 and a dell netbook only one that has this problem is the older iMac which is only 3 y/o....  I've restarted every thing a dozen times and something finally works but it is getting to the point I am about to plug back in the ethernet cable on that one and say I'm tired of playing this game!!!!  Please Apple, get a fix for this problem.

  • TL1GT Level 1 Level 1

    I dealt with this for over a month


    After trying everything mentioned in these posts, what worked for me is setting the "Channel" of my 5GHz network to a specific channel rather than using "Auto"


    After that, my MacBook Pro connects quickly everytime

  • screamingmeanie Level 1 Level 1

    where is the "channel" of your 5GHz network found?  Is this a setting in the MacBook or the modem/router?

  • Reinout Vrijhoef Level 1 Level 1

    You can find it in the settings of your Airport. In the Airport configuration utility, go to 'wireless', then choose 'wireless options'. Setting the channels of the network (instead of auto) fixed my issue with not being able to connect. For now... I would appreciate an update of the config util, where one can choose a channel that is 'available'.

Previous 1 6 7 8 9 10 Next