Previous 1 2 3 4 5 Next 67 Replies Latest reply: Apr 27, 2014 8:08 AM by Dr Jason Harrison Go to original post
  • adolfocota Level 1 (0 points)

    Gracias Mochilongo, seguí al pie de la letra las indicaciones de Dwight W. y también me funciono perfecto.


    Gracias, de verdad te lo agradezco mucho.


    Dwight W. thanks a lot!


    Best regards

  • VaughnGo Level 1 (0 points)

    Thanks! Deleting the 'fetching' user and restarting worked. Cheers!

  • Hugh Level 1 (5 points)

    Same for me. After Lion upgrade both Texedit and Preview crashed when launched.


    But thanks to your genius Dwight, the problem is resolved. Followed in general the steps set out above:


    1. Option-Go to open Library (hidden now by default in Lion)
    2. File-Properties to see permissions.
    3. As you state, my user was missing.
    4. Unlocked properties (padlock at the bottom)
    5. Press + sign and added myself. Then (and be patient as takes a little while for OSX Lion to catch up) set my permissions to be Read+Write.
    6. After closing the properties window I retarted Finder (Apple-menu-Force Quit-highlight Finder-click Relaunch).
    7. Running Texedit did ineed create a Containers folfer and both Texedit and Preview running fine.


    Thanks again Dwight.

  • Oceanconcepts Level 1 (0 points)

    None of the permissions fixes above helped in my case. I found that there was nothing in the "Containers" folder in my library.


    I created another user on my system, and found I could open both Preview and Text Edit fine in that account. I copied (duplicated) the two folders that were created in the new account inside Containers ( and, changed permissions on the copies using get info, and moved them over to my original user account.  That worked.


    However, after making some other changes related to permissions that had me spending 4 hours on the phone with Apple, issues now forwarded to engineering, I started experiencing the same error, crash on opening.


    I went to those container folders ( and and trashed their contents. After that both applications opened normally, and the missing files were recreated.


    Hope this helps someone.

  • DeepYogurt Level 1 (35 points)

    I'm in the same boat as Oceanconcepts - nothing worked here, so just created another user (which worked fine for both Preview and TextEdit), and then removed the two folders in my real user account ~/Library/Containers folder and copied over the ones from the new user and things are working OK so far, but in case things happen like Oceanconcepts, will remove the Container folders again and see if things start working as they originally should have.


    Seems like Apple would know exactly what the problem is here - I'm guessing it's only with people who migrated their User account from a previous version of Mac OS X and something funny is happening - possibly with Preferences or ???


    Anyway, thanks everyone for all the suggestions. It's nice when people take the time to relate their experiences and what they discovered helped them.



  • John Hammer1 Level 4 (2,805 points)

    Canon released updated drivers for Lion on October 24th. TextEdit and Preview can now print normally to my Canon MF4350d.


  • rbrugos Level 1 (0 points)

    Still no luck.  I tried to create the root user and also to reset the password in terminal.  But still nothing. Needless to say that the whole sistem is also very slow.    I guess I will endup re-installing the system but I just do not have the time to deal with it.

    Silvertoe wrote:


    The fix. . .

    The problem is a Permissions problem. All you have to do is:


    1. Right click on the root /Library Folder and selct 'Get Info'

    2. Unlock the pad lock in the lower right hand corner.

    3. Click on the + symbol to add a user.

    4. When prompt add the 'root user'.

    5. Give the root user Read/Write privaledges.

    6. Lock the pad lock and open Preview.



    This worked for me and I hope it works for you to!

  • Oceanconcepts Level 1 (0 points)

    Did you try the fix I posted above? If there is nothing in the Containers folder in your Library, the apps won't open.


    "None of the permissions fixes above helped in my case. I found that there was nothing in the "Containers" folder in my library.


    I created another user on my system, and found I could open both Preview and Text Edit fine in that account. I copied (duplicated) the two folders that were created in the new account inside Containers ( and, changed permissions on the copies using get info, and moved them over to my original user account.  That worked."


    I've done this a couple of time now, and it's worked. Quick and simple to try, anyway.

  • DeepYogurt Level 1 (35 points)

    I believe the ultimate problem has to do with having symbolic links in one or more of the important folders in your home directory - like Downloads, Documents, Music, Movies or Pictures (perhaps others). The Lion version of Preview and TextEdit crash when they are first run if these symbolic links are present, and keep crashing until the links are gone. You can either temporarily remove the symbolic links the first time you run both applications, then just exit the app (this creates some new files and folders in the ~/Library folder that have to do with the new "versions" feature of Lion, then recreate the symbolic links. You can also login as another user that does not have these symbolic links present and run Preview and TextEdit and copy the two folders mentioned above to the correct location in the original problematic user.


    Apple should fix this bug, as their is no technical reason why it should crash just because there are symbolic links involved. The failure is Apple's mistake in the "open" call I'm guessing when the item opened is a symbolic link and the inability to deal with it.


    Symbolic links are not the same as "Aliases" although their purpose is similar - just the underlying way that both are implemented are different.


    It's very possible there are mulitple causes, so if any particular method that works for other people doesn't work for you, try one of the other "solutions" that have worked for someone else.


    As far as the overall speed, or lack thereof, I've not really noticed anything all that noticeable with Lion  inabout two months of usage, except for an increased memory utililization, so am having to log out or reboot the computer more often now than I used to do with Snow Leopard or Leopard when free memory gets low. When your system is running "slow" check the memory graph in Activity Monitor and see how much "Free" memory you have - perhaps an increase in memory might help? Memory is a lot cheaper now than it used to be and is an easy way to upgrade your computer.



  • rbrugos Level 1 (0 points)

    Thanks Bob,


    I tried almost everything but I think it is impossible at this point to fight against Lion.  It does not work with my hardware and previous settings.  Since I upgraded to Lion everything goes wrong, slow and painful.  I love my Mac and loved Snow Leopard, and like a lot the new things in Lion, but the truth is they do not work well jet.


    I am going to re-install (something I hate) Snow Leopard and stay with it until 10.7.4 or 10.7.5...


    By the way, did yo study at UM. Your last name sounds familiar.

  • Hugh Level 1 (5 points)

    Don't go back to Snow Leopard. Stick with Lion. The advantages so outweigh the learning / adjustment curve.


    (I know I was sceptical at first but could not now go back)


    If the fix did not work, cut to the chase back up all your data (copy, don't use Time Machine) and do a fresh install.  An upgrade with the common fix worked on one machine but on my MacBook Air I had problems. Since re-installing from scratch everything works more reliably (and faster).


    Best of luck from London (Happy Thanksgiving).

  • problemwithalias Level 1 (0 points)

    Just a sincere "thank you" to Oceanconcepts, I followed all the steps mentioned everywhere including changing ACL, deleting preferences, but failed to fix it.


    Only did I try it out with a new account, and then duplicated the Preview files in the Container folder, changed permission, then copied everything back to original user's Container folder did I fix it.


    Actually, it didn't fix it immediately, I had to trash the newly created files before Preview would launch, but all is good now!


    You all saved me hours of research, thanks again.

  • seaneee Level 1 (0 points)

    Just upgraded this past weekend with the same issues with Textedit and Preview. NONE of the above fixes seemed to work, even trashing the preferences file in the data folder.


    That actually was the issue. The apps never re-created the prefs file. 


    Created a new user, then logged in as Root and copied over the plist from each data folder then changed permissions to reflect the correct user.  Works like a charm.


    Hope that helps.

  • JFraser Level 1 (0 points)

    After granting the root user Read & Write privileges for the Library folder I still had a problem, so I went into the Containers folder after Option->Go->Library and I deleted the plist folders for Text Edit and Preview in the Containers folder.  Then I went into the Terminal and typed 'killall Finder' and then I was able to launch Preview and Text Edit.  Try this procedure if nothing else worked for you so far.