Previous 1 2 3 4 5 Next 67 Replies Latest reply: Apr 27, 2014 8:08 AM by Dr Jason Harrison Go to original post
  • Das Geek Level 1 (30 points)

    Removing symbolic links for Documents and Downloads folders worked. I removed the links in terminal. Opened TextEdit. Then re-linked the forlders. Hope Apple fixes this bug. More and more users are switching to SSD system drive.

  • Macoupc Level 1 (0 points)

    Doesn't work for me... TextEdit crashes every single time I Launched it !

     

    Wonderful !

  • Oceanconcepts Level 1 (0 points)

    The Symbolic links fix didn't work for me either, but check what did in my posts a number ( 10-15) of posts up (no post #'s to reference is not very user friendly).

     

    Did you try the fix I posted above? If there is nothing in the Containers folder in your Library, the apps won't open.

     

    "None of the permissions fixes above helped in my case. I found that there was nothing in the "Containers" folder in my library.

     

    I created another user on my system, and found I could open both Preview and Text Edit fine in that account. I copied (duplicated) the two folders that were created in the new account inside Containers (com.apple.preview and com.apple.TextEdit), changed permissions on the copies using get info, and moved them over to my original user account.  That worked."

     

    I've done this a couple of time now, and it's worked. Quick and simple to try, anyway.

  • Macoupc Level 1 (0 points)

    Hi

    Thanks oceanconcepts, you helped-me to solve my issue with textedit.

     

    I simply trashed evrything which was in the file "com.apple.TextEdit" located in the users/macoupc/library/containers file... and empty the trash then I launched Textedit and it worked !

     

    Simple when you know how (but I still don't know why and I don't really care)

     

    Thanks again.

  • cameron4x2 Level 1 (0 points)

    Hi All

     

    Everytime I try to print from Mail or Preview the application crashes.

    I've just upgraded from 10.6 (Snow Leopard) to 10.8.3 (Mountain Lion).

     

    I've tried most of the solutions outlined in previous posts, and none seem to work.

    1. Checking Users and read and write permissions.

    2. Deleting the various files from the Containers folder.

     

    Please help!

    Thanks

  • arthurvisser Level 1 (0 points)

    cameron4x2 wrote:

     

    Everytime I try to print from Mail or Preview the application crashes.

    This is due to an old and unsupported printing plug-in. The EFI EF525162 (FF).plugin was famous for this. Just remove and trash the plug-in. You should get a warning about the file that's the problem when you crash.

    Printing plug-ins are found in /Library/Printers/(brand of your printer)/.

    So NOT in the user/Library/

    And get an updated driver!

  • arthurvisser Level 1 (0 points)

    One user had crashes with Mail, TexEdit, Preview etc. with the same error (Exception type EXC_BAD_INSTRUCTION (SIGILL)).

    I also found the line 'could not create a folder for a sandboxed application' interesting.

    This is a new MacBook Pro with OS X 10.8.4 and a SSD.

     

    None of the above tips worked for me, but this did:

     

    In /private/var/folders/ (Use Finder menu Go: Go to Folder… and type: /var/folders/) there are folders for the users on this Mac. If there is only one user there are probably two folders, one for the user (two digit name) and one called zz, this one is used by the Spotlight user.

    These folders had bad permissions. Use command-I to see and change them.

    These were set to user: 'nobody', group: 'nobody'.

     

    So first find out which, if there are more than two, is your folder. How did I find out? I tried before to solve the 'sandbox' problem by trying to install the combo update for OS X 10.8.5. Being logged in as a user I got a installation error stating it couldn't create (or access?) a certain folder, including the pathname, so I knew where.

     

    Solution

    Correct the permissions for your folder (mine is called '58') in /var/folders/. Select the folder, Get Info… and unlock (bottom right).

    Owner should be you with Read & Write privileges. First add yourself as a user with the plus-sign below-left. Then make yourself the owner by selecting your user name and choosing 'make (me) the new owner' from the cog, below-right.

    If the group is 'nobody' or something wrong just delete it (minus sign).

    everyone should be set to Read Only.

    Now use the cog and choose: 'apply to enclosed items…'.

     

    Open this 'your' folder in folders. There is one folder with a long 'random' name. Open this folder, this contains the folders O, C and T. O I don't know (empty), but C seems to be for Caches and T for Temporary files. These are the folders that matter and why the error occures when the permissions are wrong.

    I checked on my working Mac and the folders C and T have 'No access' for everyone, so I changed that on the problem Mac, but only for these two folders C and T.

     

    User is happy again!

  • Dr Jason Harrison Level 1 (0 points)

    After much googling, and checking permissions on various folders I found this solution which requires the terminal:

     

    open terminal:

     

    type the following four commands:

     

    sudo -s
    chown -R root:wheel /Applications/Preview.app

    chmod -R 755 /Applications/Preview.app

    exit

     

    Repeat this for the TextEdit.app by replacing "Preview" with "TextEdit"

    These commands are changing the ownership of the application bundle to root:wheel and changing the access rights to the application bundle so users can read and execute the application.

     

    Best of luck,

    -Jason

Previous 1 2 3 4 5 Next