13 Replies Latest reply: Oct 23, 2013 10:42 AM by ERoberts
Chris-UK Level 1 Level 1 (0 points)

I seem to be getting random problems with mail threads in Mail on LION 10.7

 

When viewing the thread, organized by conversation, on the far right I get the related messages OK - great.

 

In some cases I can see all the content of the messages and in others I can only see the headers and none of the message content - seems to be random on different message threads - some work and some dont.

 

Is this a problem others have experienced?

 

Thanks, Chris.


MacBook Pro, Mac OS X (10.7)
  • Hendersonr Level 1 Level 1 (0 points)

    Chris,  I am having the same problem.  The original message is still on my ISP (Bell Canada's Mail server).  The Lion Mail Program downloads the header of the message but not the content.   

     

    This is happening the minute I installed Lion, having downloaded my mail just previous to the Lion install.

     

    You will still be able to see your mail through a browser connected to your ISP's mail systemserver.  So, all is not lost untill this gets fixed.

     

    Robert

  • colmaclean Level 1 Level 1 (0 points)

    I've got the same problem with MobileMe mail.


    I _think_ it may be happening if the original message in the chain was HTML and it is still attached to any replies. Subsequent messages only show the header...

  • gomaccrazy Level 1 Level 1 (0 points)

    I am having the same issue with Mail. Some messages showing the content while others all I can see are the headers. I can't find a pattern yet. If I reply to the message I can see their message (in preference I have chosen to include the thread in my replies). However, if they have included an attachement I can't get to that. So this is a very important issue to resolve. Anybody have a solution? Apple?

  • medwriterdg Level 1 Level 1 (0 points)

    Did anyone get a response to this? I'm having the same problem; use Exchange server; have preferences set to make all email and attachments available for offline browsing, yet mail is only showing headers of several messages whether online or offline.

  • Chris-UK Level 1 Level 1 (0 points)

    I still have the issue.

     

    Only workaround I have found is turn off the Oragnize Messages by Conversation - I have the button on the menu bar and when it plays up I flip this on/off so I can read the latest message

     

    I have also found that if you leave the conversation thread open for long enough the content eventually does appear so seems some issue in how it is loading up the threaded conversations

     

    Its a real pain and serious weakness of Mail on Lion compared to what the benefit should be - hope they are fixing it!

  • lupunus Level 3 Level 3 (995 points)

    Chris-UK wrote:

     

    When viewing the thread, organized by conversation, on the far right I get the related messages OK - great.

     

    In some cases I can see all the content of the messages and in others I can only see the headers and none of the message content - seems to be random on different message threads - some work and some dont.

     

    Do you use IMAP or POP to access your e-mail provider? Or eventually IMAP for one e-mail account and POP for a different one like e.g. hotmail?

     

    POP always download the whole message to your computer. IMAP (depending on your settings and mail provider's settings) eventually only the header or a portion of the e-mail.

     

    If you use IMAP, eventually check the account settings in Mail according to the picture below (the "Keep Copies" one) to have the complete e-mail on your system.

    screen-capture-20.png

     

    Lupunus

  • w2m3 Level 1 Level 1 (10 points)

    I have the same problem with accounts through Exchange. It does appear to be related to whether the organize by conversation setting is checked.

  • Chris-UK Level 1 Level 1 (0 points)

    The account that seems to have this issue is IMAP however I do have those settings checked. Its like there is some delay before it downloads the latest messages when they are threaded.

  • lupunus Level 3 Level 3 (995 points)

    Chris-UK wrote:

     

    The account that seems to have this issue is IMAP however I do have those settings checked. Its like there is some delay before it downloads the latest messages when they are threaded.

    I had forgot one thing.

     

    The search and compilation of mails in MAIL is based on Spotlight. If you got mail between two Spotlight indexing runs, the compilation will not show up, as the Spotligth index are not updated at that time.

  • adamk111 Level 1 Level 1 (0 points)

    Having the same problem.  Any solution yet?

  • Scott Dye Level 2 Level 2 (175 points)

    I'm running to this too, and it's really frustrating.

     

    In my case it is an exchange account, and I am using "classic layout" with "organzie by thread" checked.

     

    In my current situation, I really need the organize by thread active to allow me to keep track of our company's issue resolution system. But multiple times a day I have to switch views and/or relaunch mail.app in order to be able to see the correct email.

     

    I also have situations where it will show the mail in the group, but one of the individual messages is ALSO above the main group item (not just the header, the header is there, and then one of the sub-mails are below AND above the header). When it does this, and I clear it out, the extra mail was actually a completely different message that wasn't showing up.

  • mvargas79 Level 1 Level 1 (0 points)

    I was also having this frustrating problem as well.  I even tried rebuilding the mailboxes and tried to switch back to the Classic View.

     

    What worked out for me is to disable the option "Display remote images in HTML messages", under Preferences>Viewing.

     

    Hope it helps you guys out!

  • ERoberts Level 1 Level 1 (0 points)

    Tried that, didn't work for me. Still not displaying message content or attached files. My work-around is to use the iCloud internet mail client. Total pain, but it works until Apple fixes this bug.