Previous 1 23 24 25 26 27 Next 399 Replies Latest reply: Apr 28, 2014 6:40 AM by thebigticket Go to original post
  • dizm Level 1 (0 points)

    Is it just me, or have the latest updates finally fixed this? I've had no problems for a few weeks now, and there's been no real traffic here for a while.


    After all the complaining we did, I thought it would be nice to acknowledge that. After all, it only took a little over a year to fix! Must have been a tough one for the engineers.

  • John Galt Level 8 (46,000 points)

    dizm wrote:


    Is it just me, or have the latest updates finally fixed this?


    From what I have been able to determine, there were a number of potential causes that conspired to preclude a quick resolution. Apple always fixes their problems, naturally it takes longer than we would like.


    It would be uncharacteristic of them to announce "everything's fixed now". Whenever problems like this arise, the complaints quietly subside.

  • Ocalawill Level 1 (0 points)

    The Mountain Lion upgrade fixed this WiFi issue for me. My iMac is functioning as it should. Only bug I have now is choppy- jerky video when flipping workspaces - but that is for another thread.

  • youseful Level 1 (0 points)

    I reckon it is finally fixed @ OSX 10.8.2, but it has taken forever.  Every now and again when I wake the Mac form sleep it can be a littel slow finding the mouse or reconnecting, but NOTHING like before.

  • mrquoad Level 1 (15 points)

    Just to say, this issue definitely *is not* resolved for me, despite being fully upgraded.


    I'm experiencing repeated wifi failures. Not only when I put my iMac to sleep, but - currently - pretty much every 10-15 minutes and often more frequently.


    I've had about 10 wifi outs in the last 2hrs. Which is utterly, utterly dysfunctional. I've tried pretty much every fix I can find, and nothing's worked.


    My and my partner's iPads and iPods are connecting just fine. My Macbook Pro (early 2012, Mountain Lion) and my partner's MBP (2009, Leopard) are connecting just fine. My partner's netbook (Windows 7) is connecting just fine. My iPhone is connecting just fine.


    It's only my iMac that seems to've been effectively bricked for most online purposes. And, by God, it's irritating. I cannot believe Apple have not released a fix yet.


    I'm DLing ML again, with the intention of doing a complete clean install.

  • Priyan from Switzerland Level 1 (0 points)



    I can recommend you two things, that helped me.


    Try deactivating Internet connection sharing if it's activated.


    Try changing the wireless radio mode to 801.11n only mode in the WLAN router.

    If you are using an Apple router like AirPort express. The setting is in Airport utility in Wireless tab.

  • PTH14 Level 1 (0 points)

    I too am still having this issue. Repeated wifi disconnects / drops. Only occurs on my iMac which connects to an airport extreme.  Other Apple devices (iPad, 2 iPhones, 2 ipod touch) and non-Apple device all working fine.  Please Apple fix this issue!!! VERY annoying and frustrating.

  • TeamHCN Level 1 (0 points)

    I've been having this same issue for going on 6 months now, and no news from Apple. I've spent hours scouring the Internet for a solution, and reading line after line of Console entries, without success.


    I have 2 2011 iMacs (OS X 10.6.8) and a 2008 Macbook Pro (OS X 10.8.2) sharing a 5GHz N network; my router is an Asus RT-N56U. The iMac located in the same room as the router is connected to 2 printers via USB, which are then shared over the network. For months now, none of the other computers have been able to print to the shared printers, no matter how many times I rebuild my network configurations or recreate printer definitions. The iMac connected to the printers was also suffereing mDNSResponder crashes on a daily basis which rendered it unable to access the Internet. A week ago I did a complete reinstall of OS X 10.6.8 which appeared to fix the DNS issues, however now printer/file sharing no longer works, and the computer loses its wifi connection when waking from sleep. I've pinged the iMac from other computers on the network, which results in failure, even though the iMac still has a functioning WAN connection. OS X Firewall is disabled on all the machines, so I have no idea what could be blocking the computers from communicating.

  • mrquoad Level 1 (15 points)

    The *only* thing that is currently working for me is keeping a 'Network Diagnostics' window open. I'm not sure how to access it independently; the 'open network diagnostics' option has occasionally appeared under my wifi signal strength indicator, particularly (IIRC) when I've been renewing my IP address in the hope that'll work, and my iMac has tried to connect to wifi in the intervening.


    Anyway. For so long as I keep network diagnostics open, and don't accidentally close it after running through the 'diagnostic' process (which is a bugbear, as closing it means I've got to find a way of reopening it - and I haven't yet found out how to do that with any predictability / replicability), I can usually get my network running in a few seconds - by running the 'network diagnostics.'


    Almost without fail, wi-fi, wi-fi settings, network settings, and ISP are all identiifed as green / good / ok. Almost without fail, it's the last two 'network status' boxes - internet and server - that're flashed red / not-ok.


    Going through the diagnostics proces has - so far - fixed it quickly every single time. Otherwise, I find myself turning wifi off and on again, and that'll usually only work one time in every two. (And it's slow...)


    This is *not* a fix. But it's a semi-functional fudge that's been working for me for some time.

  • ninanth Level 1 (0 points)

    I had the the same WiFi issues after wake from sleep. Mine is 21" iMac 2011 with Mountain Lion 10.8.2. I tried most of the solutions in the forum with no success. So today I was going through the various settings and unchecked "Wake for network access" under "Energy Saver" in "System Preferences." After that I tried few times to wake from sleep and didn't see the WiFi connection issues. But will report how things goes in the next few days.

  • ninanth Level 1 (0 points)

    Inorder to prove the solution in the previous post, I went and enabled "Wake for network access" and put the computer to sleep and wake process again. and I had WiFi issues come back. So went back and unchecked "Wake for network access" in "Energy Saver" and went through the sleep and wake process again, and didn't see the WiFi issues. For me it looks this option is working, but not sure it's for everone.


    I have in "Bluetooth" and in "Advanced" the option "Allow Bluetooth devices to wake this computer" is also unchecked. I think unchecking both "Wake for network access" in "Energy Saver" and "Allow Bluetooth devices to wake this computer"  in "Bluetooth, Advanced" is making a difference for me.

  • John Galt Level 8 (46,000 points)

    ninanth, in case you haven't found this suggestion buried elsewhere in the lengthy thread, try waking your iMac by pressing the power button instead of using the keyboard or something else to wake it.


    I am no longer experiencing this problem after upgrading to Mountain Lion, but when I did this workaround was reliable for me.

  • Ocalawill Level 1 (0 points)

    It is my belief you will need to reinstall your OPSYS.

  • Imac borked Level 1 (0 points)

    I have 21.5 2011 iMac. Mountain Lion did fix the problem for a while but the last few days the problem has returned. My Mac mini, My wifes Macbook, My iPad  and both our phones have never had a problem but the iMac will intermittantly not work. I have tried all the suggestions in this and other threads includine using a ethernet cord. Nothing will fix it.

  • Nubee1 Level 1 (5 points)

    As long as you insist on setting the iMac to sleep, the problem will exist.

    The name of this problem, is an inability to restore wifi after sleeping.


    So, don't allow the iMac to sleep. That does not mean that you cannot save energy by allowing the screen to darken.

    Since you allow the system to sleep, you will have the problem until Apple finds the time to fix this.


    I suggest:  15 minutes to darken the screen, set sleep to NEVER, set screen saver to NEVER.


    Let us all celebrate when it gets fixed. Let us not be concerned until it is fixed.