Previous 1 23 24 25 26 27 Next 399 Replies Latest reply: Apr 28, 2014 6:40 AM by thebigticket Go to original post
  • aspector Level 1 (0 points)

    Sorry - my mid 2008 iMac is set NEVER to sleep.  It sleeps regardless.  I had to add Caffein to keep it from sleeping - which, of course, has resulted in screen burn-in.  Apple could care less.

  • Nubee1 Level 1 (5 points)

    Sorry- I did not use the proper terms.

    On my mountain  lion system there are TWO options.


    1. The screen "sleep"


    2: the computer "sleep"


    I suggest setting the screen sleep for 15 minutes or so.

    No screen burn.


    I suggest the computer sleep to NEVER.

    Safe return to wifi after screen goes dark and the mouse is wiggled.


    Oh, and BTW, screen saver to none, or never.


    Is there something I missed?  If I am off base, I need to be corrected.

  • aspector Level 1 (0 points)

    Allowing the screen to sleep on the mid-2008 iMac allows the entire computer to sleep, despite the fact that that should not occur.

  • mrquoad Level 1 (15 points)

    Oh, lord, setting your computer to 'never sleep' seems a bit like the old 100% surefire method of stopping headaches - cutting your head off.


    Even if doing so wouldn't significantly reduce the life of the computer (I can't believe it wouldn't?! My iMac is only fully off when we're out of the country / on holiday!), you've just described the only means I've so far discovered of replicating Windows' infamous BSOD.


    If I set it to never sleep (as I have done a couple of times whilst recording hour-long programmes), I'll routinely come back to a computer that's running filthy hot and which refuses to wake up; and which needs a complete hard reset using the power button.

  • rvjacobs Level 1 (0 points)

    Hello you all,


    I also had the problem of a disconnecting wifi while my imac was sleeping. I did not have the reconnecting issue after sleep, but the lost connection issue during sleep which made it impossible to reach my imac for things like homesharing, apple tv or remote desktop. I have a late 2012 iMac with a clean ML 10.8.2 on it and wirelessly connected to an apple time capsule (same as an airport extreme). My partner has a mid 2007 iMac, also with an ML 10.8.2 on it.


    I tried every single solution I could find on the internet, such as changing the router's security from wpa2 to wpa, changing the MTU from automatic to manual 1453, router reboots, re-installations, re-configurations, keychain clean-ups, everything.


    Eventually I solved my problem with these steps and now it works as a charm. I can still find the iMac with the remote app, even after 12 hours of sleep:


    My time capsule router is set on automatic MTU and encrypted with WPA2 and I use  the 5Ghz network!

    1. Cleaned all the wifi passwords in keychain on my iMac

    2. Created a new network location in system preferences

    3. In this location I deleted the bluetooth pan and bluetooth dun connection.

    4. In this location I changed the preferred connection-order to wifi on #1 and ethernet on #2.

    5. Restarted my iMac.


    Now I still have a connection when it sleeps and I can wake it to low profile using the remote app (homesharing) and everything works fine.


    Hope more people wille be helped by this.

  • morpheuzlal Level 1 (0 points)

    I solved my  problem with a simple thing


    Turning off my Router Firewall and it works like a charm.

  • ricksca Level 1 (0 points)

    I had this problem on both my Macbook Pro's. I tried all sorts of fixes including Nubee1's and none of them worked. Sometimes it would take 5 minutes to reconnect to the Internet after being asleep. This went on for YEARS. Last month, I switched from ATT Broadband to Comcast. Problem GONE. That alone would have made the switch worth it. The extra 25 mbps I got is just icing. (Oh, and half the cost).

  • uaesthetics Level 1 (0 points)

    Hello all I am the latest to suffer this so annoying problem. Just today when I came home it's not connecting. I have a late 2012 iMac model - OS X 10.8.5


    I have tried many things from what I have read in this thread but it's not connecting to the wifi network


    My ipad mini is connecting....what I am writing from now


    I have an iphone5 and that is also not connecting to the wifi - so only the iPad is connected like normal but imac and iPhone are not connecting


    Can anyone advise please :(

  • adeluca73 Level 1 (0 points)

    After 10 months of desperation I seem to have found the problem causing the wifi problem...and NOT thanks to apple support nor my internet provider.


    The problem is the router! By changing the frequency from 2.4 GHZ to 5 GHZ the imac finally stays connected. The router however needs to have the 802/11 protocol.


    Best of luck to all!!!

  • thebigticket Level 1 (0 points)

    Best solution ive found for the imac is once youve setup your wifi access point

    go to

    >System Preferences

    >Energy Saver

    >uncheck 'Wake for Network Access'

    this allows you to be able to connect to internet through your mac whilst it is sleeping from what ive seen so far

Previous 1 23 24 25 26 27 Next