1 2 3 Previous Next 36 Replies Latest reply: Apr 25, 2014 6:51 AM by BernardDerom
Jiggleboose Level 1 Level 1 (0 points)

After installing Lion, Finder went nuts and started prompting a 'Restore Windows' warning. I've tried everything but but just doesn't go away... Other programs work but Finder. I'm in the process of reinstalling Lion again from Recovery.

If anyone has had the same problem please advise me. Thank you


iMac, Mac OS X (10.7)
  • 1. Re: Finder keeps prompting a 'Restore Windows'
    Tony Stinson Level 1 Level 1 (15 points)

    I am having the same problem. I have tried quitting the process in Activity Monitir, rebooting, force quitting the finder. Nothing works. I really don't want to reinstall Lion. Any suggestions?

  • 2. Re: Finder keeps prompting a 'Restore Windows'
    Jiggleboose Level 1 Level 1 (0 points)

    I reinstalled Lion from Recovery. Problem still persists... it's driving me mad! I'm going to reinstall Snow Leopard and then wait for a Lion update when that comes out! If you get around to fixing it please let me know.

  • 3. Re: Finder keeps prompting a 'Restore Windows'
    Tony Stinson Level 1 Level 1 (15 points)

    I deleted the Finder preference file via the Terminal and rebooted. The problem persists. I logged in with a different account and the error message does not appear. Obviously it is something to do with a particular user and not the system. I don't have any other ideas to fix the problem. The only solution I can think of is to reinstall Snow Leopard and the install Lion again.

  • 4. Re: Finder keeps prompting a 'Restore Windows'
    Jiggleboose Level 1 Level 1 (0 points)

    I think I have finally found the answer!!!

     

    Follow the steps to TERMINAL TRICKERY on this page:

     

    http://www.macyourself.com/2009/12/27/trash-wont-empty-the-ultimate-guide-to-del eting-stubborn-files/

     

    I think it may have to do with files that are still in the trash!

     

    After going through these steps, my trash emptied and then I clicked the 'Don't restore windows' option in Finder popup. Seems to be working now!

     

    Good Luck!!!

  • 5. Re: Finder keeps prompting a 'Restore Windows'
    pdyholman Level 1 Level 1 (0 points)

    I'm afraid that deleting Trash didn't help me.

     

    We're still getting the loop of Finder crashing and restarting with the "Restore Windows" prompt which disappears before we can click on an option.

     

    Currently using Spotlight to run commands like Console !

     

    I've tried Repiaing Permissions and restarting with the Restore Windows button unchecked to no avail.

     

    - Paul

     

    Console shows

     

    ============================

    26/07/2011 08:07:55.489 com.apple.launchd.peruser.502: (com.apple.Finder[4390]) Job appears to have crashed: Segmentation fault: 11

    26/07/2011 08:07:55.843 ReportCrash: Saved crash report for Finder[4390] version 10.7 (10.7) to /Users/niki/Library/Logs/DiagnosticReports/Finder_2011-07-26-080755_kitchenmac. crash

    26/07/2011 08:07:55.846 ReportCrash: Removing excessive log: /Users/niki/Library/Logs/DiagnosticReports/Finder_2011-07-26-080722_kitchenmac. crash

    26/07/2011 08:07:57.106 com.apple.launchd.peruser.502: (com.apple.Finder[4392]) Job appears to have crashed: Segmentation fault: 11

    26/07/2011 08:07:57.483 ReportCrash: Saved crash report for Finder[4392] version 10.7 (10.7) to /Users/niki/Library/Logs/DiagnosticReports/Finder_2011-07-26-080757_kitchenmac. crash

    26/07/2011 08:07:57.489 ReportCrash: Removing excessive log: /Users/niki/Library/Logs/DiagnosticReports/Finder_2011-07-26-080723_kitchenmac. crash

    26/07/2011 08:07:58.929 com.apple.launchd.peruser.502: (com.apple.Finder[4394]) Job appears to have crashed: Segmentation fault: 11

    26/07/2011 08:07:59.454 ReportCrash: Saved crash report for Finder[4394] version 10.7 (10.7) to /Users/niki/Library/Logs/DiagnosticReports/Finder_2011-07-26-080759_kitchenmac. crash

    26/07/2011 08:07:59.462 ReportCrash: Removing excessive log:

    :

     

    and

     

    Process:         Finder [3263]

    Path:            /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder

    Identifier:      Finder

    Version:         ??? (???)

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [218]

     

     

    Date/Time:       2011-07-26 07:47:25.138 +0100

    OS Version:      Mac OS X 10.7 (11A511)

    Report Version:  9

     

     

    Crashed Thread:  4  Dispatch queue: com.apple.root.default-priority

     

     

    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

  • 6. Re: Finder keeps prompting a 'Restore Windows'
    Tony Stinson Level 1 Level 1 (15 points)

    Empyting the trash didn't work for me either.

     

    My IT guy spent almost two hours trying to fix this problem.

     

    Fortunately, I had made a SuperDuper backup right after I upgraded to Lion, so I was able to restore my drive to the pre-problem state. Since then, the problem has not reoccured.

     

    Very strange bug. Hopefully, Apple will find it and fix it.

  • 7. Re: Finder keeps prompting a 'Restore Windows'
    Jose Cordero Level 1 Level 1 (0 points)

    Thank you, Jiggleboose, for the Terminal Trickery link. It's what finally stopped my looping finder issue. The trash icon on my dock showed "empty," but I guess there was still something in there mucking things up. You have saved the day (for me at least!)

     

    By the way, my restarting finder loop problem began after I removed some old PowerPC apps that are no longer supported in Lion. I was using AppZapper to remove them. Maybe this info will be helpful to others.

  • 8. Re: Finder keeps prompting a 'Restore Windows'
    Praseodymium Level 1 Level 1 (0 points)

    Hi All. Thanks for your great input. I rarely post to forums but this problem was so incredibly frustrating that I figured it was my *duty* to share the solution that worked for me...

     

    After my boss' iMac was upgraded to Lion, he was transferring a large amount of files, and also installed a program called "TouchCopy". The behaviour described above, with a constantly crashing Finder and "Restore Windows" dialog, began almost immediately. Restarting, repairing disk, etc. had no effect. Deleting prefs using the terminal did not work either. However, after creating a new admin account on the same machine, this new account did not have the problem.  To me this meant that the problem was isolated in the specific user's data.I was then trying to "Share" the desktop folder using Sharing in System Prefs, so I could manipulate it with the newly made Admin account. When trying to Share the original user's desktop folder, System Preferences crashed.

     

    Final solution was to remove most of the files from the desktop folder of his user account. Apparently one of the many files on the desktop was corrupted, and any time the Finder tried to display the files it would crash and restart itself in an infinite loop.

     

    After moving the files from the desktop folder to the folder above it, the Finder would behave normally until one tried to look at the files in a window, and then the problem began again. By deleting the offending files (I just nuked the majority of them using the "rm" terminal command), the problem was resolved. I also used the "Terminal Trickery" described to empty the Trash after all that, just for good measure. I had to learn how to use the terminal to do this as the finder was non-functional. Used following terminal commands: rm, cd, mkdir, mv - google them or use the "man" command (e.g. man rm) in termnal to get syntax descriptions if you're not familiar with the Terminal.

     

    I found most of the useful information which pointed me to this solution at this (old) forum link:

    http://hints.macworld.com/article.php?story=20040624224239286

     

    Also, because the menu bar would function when inside other programs (which ran properly), I would start Safari, or System Prefs, and then use Spotlight to open Terminal.

     

    Hope this helps for those of you who still had the problem after dumping the trash.

  • 9. Re: Finder keeps prompting a 'Restore Windows'
    Praseodymium Level 1 Level 1 (0 points)

    Further to my last post, the behaviour returned when saving new files to the desktop from Outlook. This was solved using the terminal command:

     

    rm -rf .DS_Store

     

    while in the user/desktop folder

     

    Now apparently things are working properly...

  • 10. Re: Finder keeps prompting a 'Restore Windows'
    pdyholman Level 1 Level 1 (0 points)

    Thanks for the tips.

     

    Unfortunately, cleaning the Desktop and removing all my Preferences didn't help.

     

    (I used "ls -la ~/.Trash/  ~/Desktop/" to ensure no invisible files were missed)

     

    I can't use Finder in other programs either - when browsing for a file in Finder in Pages (for example), Pages will crash too.

     

    However, loggon as another user did work.

     

    This is a bit worrying - my next plan was to install the OS from scratch (:-() and then bring over my files - if the problem is Finder failing over an existing file then I may well hit the same problem.

     

    This is pretty nasty !

  • 11. Re: Finder keeps prompting a 'Restore Windows'
    Jose Cordero Level 1 Level 1 (0 points)

    pdyholman, I hope you are able to find the corrupted file that keeps crashing your finder. Like you, I was able to run a different account without any problems, so I was pretty sure it was something in my home folder, most likely on the desktop, but ultimately it turned out to be something invisible in the trash. One thing that helped was while I was in the other account I used the "login" command in Terminal to login as my main account within the terminal window, even though Terminal was running in a guest account. That allowed me to "mv" and "rm" and "mkdir" with the permissions of my main account, without having to use the dreaded "sudo." I really hope you don't have to go file by file to determine which file is corrupted, but if you do I wish you the best of luck. Good hunting!

  • 12. Re: Finder keeps prompting a 'Restore Windows'
    pdyholman Level 1 Level 1 (0 points)

    Hi Jose,

     

    Thanks for your supportive words.

     

    Luckily, in the depths of time I started on UNIX systems, and so am happy to work at the command prompt.

     

    Looking at http://en.wikipedia.org/wiki/.DS_Store  my current theory is that removing these files might be the solution.     (Given they are related to Finder, and from Praseodymium's post)

     

    eg sudo find / -name ".DS_Store" -depth -exec rm {} \;

     

     

     

    - Paul

  • 13. Re: Finder keeps prompting a 'Restore Windows'
    pdyholman Level 1 Level 1 (0 points)

    PostScript:  

     

    sudo find / -name ".DS_Store" -depth -exec rm {} \;

     

    Fixed my problem.      Finder was in "All my Files" mode, so could have been anything.

     

    - Paul

  • 14. Re: Finder keeps prompting a 'Restore Windows'
    PTT69BIO Level 1 Level 1 (0 points)

    Thanks Jiggleboose, this little trick solve my problem. I think some corrupt file got stucked in the trash bin.

1 2 3 Previous Next