10 Replies Latest reply: May 25, 2012 7:17 AM by Rich in Berlin
jrosenblum Level 1 Level 1 (0 points)

After completing the Lion update, I attempted to login into my primary account. After getting the spinny for a while in the password box, the screen turned grey with a "faded" login photo for my account, then went completely grey, then I was returned to the login screen.


Fortunately I have a separate account on my machine and have been able to log in with that account.


Both of these accounts are FileVaulted. The administrative aspects of this primary account still seem functional, since I'm able to do things like (once I'm logged into the secondary account) open Software Update. I can also ssh into my primary account. But If I try to User-Switch using the user-switching menu in the upper-right corner of the screen to my primary account, I see very similar behavior. I get a grey screen, followed by a flash of the standard spiral-galaxy background, followed by a grey screen and a return to the login screen.


It seems like trying to go through one of the initialization steps on my primary account is failing.


Obviously, I'm pretty disappointed with this outcome. Anyone else seeing anything like this? Any pointers on how to further diagnose?

MacBook, Mac OS X (10.7)
  • jrosenblum Level 1 Level 1 (0 points)

    Some further things to note:


    1. I flashed my PRAM
    2. I started in Safe Mode
    3. I disabled login items holding down shift when logging in.


    I am still unable to login (graphically) to this account. That I can ssh in suggests that there is some part of the graphical login process that is causing a crash and return to the login screen.

  • jrosenblum Level 1 Level 1 (0 points)

    As a further update, there appear to be these messages in Console around the time of every failed login attempt:


    7/21/11 5:11:00.239 AM com.apple.launchd.peruser.502: ([0x0-0x3f03f].com.apple.iTunesHelper[1203]) Exited: Killed: 9

    7/21/11 5:11:00.243 AM com.apple.launchd.peruser.502: ([0x0-0x53053].com.apple.AppleSpell[1311]) Exited: Killed: 9

    7/21/11 5:11:00.254 AM com.apple.launchd.peruser.502: (com.apple.mdworker.pool.0[2890]) Exited: Terminated: 15

    7/21/11 5:11:00.259 AM com.apple.launchd.peruser.502: (com.apple.talagent[1115]) Exited: Killed: 9

    7/21/11 5:14:05.191 AM com.apple.launchd.peruser.502: (com.apple.quicklook.32bit) Unknown key for boolean: DisallowDataExecute

    7/21/11 5:14:05.191 AM com.apple.launchd.peruser.502: (com.apple.ReportCrash) Falling back to default Mach exception handler. Could not find: com.apple.ReportCrash.Self

  • michaelfromeagle Level 1 Level 1 (0 points)

    I'm getting the exact same thing, except I don't have a second username and therefore can't login at all. Good times.

  • jrosenblum Level 1 Level 1 (0 points)

    As an update, an Apple Senior Advisor called me yesterday. While he was very patient and helpful, we were unable to make meaningful progress.


    As a further update, I tried to restore my machine using TimeMachine to a backup of 10.6.8 just before the install, and now that restored system will not boot (hangs on the Apple-logo-grey-background-spinning-gear forever). See Unable to restore to 10.6.8 after upgrade to Lion .


    Now I'm very concerned. If I cannot restore my system to a backup, then I've done everything that Apple has asked before doing an upgrade and have a brick and a backup that isn't really a backup.

  • michaelfromeagle Level 1 Level 1 (0 points)

    I was talking to Apple this morning but didn't have time to finish.  I will be calling them later.  I'll let you know how it goes.  Who knows? Maybe Steve will have pity on us and hook us up with new Mac Pros or something.

  • michaelfromeagle Level 1 Level 1 (0 points)

    From MacRumors Forums.  Sounds like a similar-enough issue to give this a try (http://forums.macrumors.com/showthread.php?t=1191239):


    I got the answer here


    Ok step 1


    Boot your mac with Option + R holding it will boot into recovery mode

    Step 2 go into disk util and take terminal


    write resetpassword


    Choose root and put a password to log on root


    Reboot the mac and log in as root and root password that you've done


    Go in System Preference then users and group


    Create a new account with the SAME NAME and SAME PASSWORD as your old account and put it as an administrator



    When you accept it will say that in MacHD you already have an account with the same name do you want to use THAT folder


    You say YES it will take 3 mnutes about.


    Then log off and your account will be there, select it and put the password


    It will log and all your files will be there.


    That is what i done and it worked, my desktop docs and itunes is all there


    And for the time i took


    They refunded my Lion purchase and will send me a 50$ itunes store card


    Gotta love it hehe



    Sorry for the bad english


    Message was edited by: michaelfromeagle

  • michaelfromeagle Level 1 Level 1 (0 points)

    Another link.  This one is about the Developer Previews and the only systems it affected were ones with an nVidia GPU.  I'm not sure which kind I have.



  • socalspartanrunner Level 1 Level 1 (0 points)

    Had the exact same problem, the only way I fixed it was to autologin for the primary.  You could try a fresh install of Lion, via USB or DVD route of the installer.

  • Rich in Berlin Level 2 Level 2 (290 points)

    This was exactly my problem too, after upgrading to Lion. I originally solved it by booting in recovery mode, renaming my library folder (not deleting so as to keep backup of all prefences and app data) and logging back in. Followed by 4-5 hours reconstructing my account, from the Library backup. Even then, only about 80% of original account config, but at least I was up and running. For about 1 month...


    This morning I restarted (not for the first time, since restoring my account) and guess what... yes AGAIN! To say I'm angry is an understatement.


    Same symptoms as noted by jrosenblum. I can ssh, but otherwise always grey for a couple of secs, before switching back to login screen. The suggested solution I'd already tried. That is for when lion has "lost" your account. In our case, the account is there, as proved by ssh. Hence you can't even do the above mentioned, osx won't let you because the "account name already exists". It's IMPOSSIBLE to enter SAME NAME / PASSWORD.


    In contrast to jrosenblum what I see in the console is a loginwindow crash. Every time. And always KERN_INVALID_ADDRESS at 0x000000000000001c


    Googling that confirms my suspicion it's a driver problem but hasn't helped much beyond that. Most perplexing is that I can't even log in in safe mode.

  • Rich in Berlin Level 2 Level 2 (290 points)

    Nailed it!!! (for me at least)


    A couple of work colleagues have had the same problem; it turned out to be a wonky keychain! Man, man, man!!!


    Solution was to rename the old Keychains folder, then I could login in. That was all! Then from KC Assitant open the old keychain, set it as default, and delete the new empty one created at log in. All my passwords and certs and keys restored.


    Maybe because I often run a developmennt script for building apps, which adds and removes a keychain. Something must have got screwed up. Would explain why 3 of us here at work have had the problem, which otherwise doesn't seem to be too common.


    Nevertheless... SL never had this difficulty. I don't like Lion.