Previous 1 2 Next 21 Replies Latest reply: Dec 21, 2012 10:12 AM by scoutts
_serg Level 1 Level 1 (0 points)

This happens on every application I open. The focus goes away about every 2 to 4 seconds. Then I have to regain focus again and it will lose focus within 2 to 4 seconds. This is as a result of upgrading to Lion.

I have not found a setting for me to change to correct this issue and re-booting does not change the issue (I have macbook pro core2duo).

MacBook Pro, Mac OS X (10.7)
  • bart1963 Level 1 Level 1 (10 points)

    Mine too... this has rendered my laptop useless..!!!

  • bart1963 Level 1 Level 1 (10 points)

    My probelm ended up being HyperSpace.  Once I removed HyperSpace the problem went away.

  • _serg Level 1 Level 1 (0 points)

    I removed HyperSpace. The problem ended.

    Thank you!

  • okcompute Level 1 Level 1 (0 points)

    Yep, that solved my problem too. Thank you!

  • KyleESmith Level 1 Level 1 (0 points)

    When you say you "removed" Hyperspace, are you referring to simply deleting the app from the applications folder and then rebooting. I ask, because, I'm having the same issue of lost focus after just a few seconds, and I had Hyperspace originally installed.  However, I guess OS X Lion turned it off, even though it was set to run on login.  So, the app is no longer running, but I still have the issue with losing focus, which makes the system unusable. It's hard to imagine how an application, isolated within the application directory could possibly be causing this conflict, unless it has installed software into system directories, or altered system files, both of which would require sone type of uninstall process to rectify.  But no one has mentioned running any uninstall utility. Can someone tell me what exactly they did to "remove" the Hyperspace application?  I don't believe this issue is closed, or answered until that process can be adequately described.


    Thanks to any and all that may reply.

  • jonathan125 Level 1 Level 1 (0 points)

    I have the exact same problem - brand new MacBook Air 13 with Lion.


    After about 10 minutes of use, it would start with Outlook & Mac Mail - I would lose the focus everytime I typed in the TO: field of either app. But the problem seems to be getting worse - it's swiching focus after some brief typing (always keyboard related) in many apps.


    I've tried re-installing Lion, stopping many processes, even called Apple Support - nothing seems to fix this problem.


    I don't have any any software I can think of that would be causing this.

  • KyleESmith Level 1 Level 1 (0 points)

    OK, I went to throw in the trash can, and it informed me that wasn't possible, because the app was still running, even though it did not show up as a running app.  So, what worked for me was to simply reboot, after removing the app from the dock.  Likely it would have worked by simply rebooting after making certain it would not run at login.  But the important point is that the issue did not require actually removing Hyperspace from my applications directory.  This is a good thing, as it means that the Hyperspace application does not require an uninstall utility.  It is sufficient to simply uncheck run at login, and remove it from the dock (so you don't accidentally run it again) and then reboot.  If one knew the processes used by Hyperspace, they could probably simply kill those processes from the shell, except that if you have this problem, you can't type into the shell.  Apple's installer should look for this offending application on upgrade, and disable it prior to the first boot of OS X Lion.  After all, it was sold to folks out of their own supposedly secure app store, the very same place from which you purchased the OS X Lion upgrade.  The good thing about the upgrade being distributed via the app store is that Apple can choose to fix this for future upgrades. Wether they will remains to be seen.  None-the-less, the problem now has a known solution.


    Thanks for the bandwidth.


    Best wishes.

  • helgafromreykjavik Level 1 Level 1 (0 points)

    I have this same problem in almost every application. It starts after the computer has been on for a while. Hyperspace has never been on this computer so the reason must be something else.


    I hope someone finds the reason soon. (Focus was lost about 12 times while I typed this)

  • _serg Level 1 Level 1 (0 points)

    MacOS Lion has new conception of desctops and window manager. Applications for Snow Leopard used functions of desctops or window manager now don't work correctly. You may try to find any applications such HyperSpaces and remove them. May be it will help.


    ps: sory for my english

  • jonathan125 Level 1 Level 1 (0 points)

    I think I might have tracked it down to Adobe Air? I uninstalled it and have not had any problems for a few hours - hoping this does the trick.

  • jonathan125 Level 1 Level 1 (0 points)

    I can confirm that the problem starts after the computer has been on 30+ minutes - and gets worse & worse with time. It is particularly bad when typing in the TO fields of both Outlook & Mac mail - but eventually it affects everything.


    I have had some luck uninstalling Adobe Air - which I needed to run SalesForce Chatter - and so far so good... keeping my fingers crossed.

  • jonathan125 Level 1 Level 1 (0 points)

    UPDATE: Still having the problem after uninstalling Adobe Air & the SalesForce Chatter App.


    However I might have tracked it down to another cause: The Mac Firewall(?)


    I was installing StarCraft II while in email - then the All Firewall Access dialog box came up - only for 0.5 second - but of course the active app lost focus. This kept happening, over and over - sometimes so fast I couldn't even see the Firewall dialog box.


    I turned off the Firewall and it stopped.


    As I think about it, the problems I experienced might be related to outside Internet requests (Email with the TO field, Chatter - which refreshed every 30 seconds, etc).



  • helgafromreykjavik Level 1 Level 1 (0 points)

    Are you running Little Snitch too? I was looking yesterday night at the console and decided to check out if it could be the cause. Installed their beta and I have not lost focus... yet.

    Before I updated I got the note when I opened the Little Snitch Configuration that I needed to install the latest version but I had it already on. Just for the heck of it I tried the beta version.

  • jonathan125 Level 1 Level 1 (0 points)

    I'm not running Little Snitch - but I checked it out and, based on that I'm really starting to think the cause has to do with how Lion handles outbound Internet requests.


    I've had this problem on 2 different Macs, both with Lion (one upgrade, one new install) so it must be something with how both are configured and/or their software.


    I have identical software for both, no resident utilities (like Little Snitch) but I always DO enable the Mac firewall. Shutting down some apps seems to reduce the problem (e.g. Adobe Air + Chatter) but not eliminate it. What these apps have in common is they all make frequent outbook requests to the Internet - so maybe there is a Lion compatibility issue with the firewall & some applications?


    Anyway, I've turned the Firewall off and will let you know if that fixes the problem.



Previous 1 2 Next