Previous 1 2 3 Next 39 Replies Latest reply: May 30, 2014 2:01 PM by amelinora Go to original post
  • gravitic Level 1 Level 1 (5 points)

    After fix permissions on my primary disk, Disk Utility detect same file permission errors again. I think permission list is wrong or corrupt. 


    I run this:


    $ sudo diskutil repairPermissions /


    Started verify/repair permissions on disk0s2 HD1

    Permissions differ on "System/Library/CoreServices/RemoteManagement/ ote Desktop"; should be -rw-r--r-- ; they are drw-r--r--



    But UIAgent.nib file apparently have correct permissions (-rw-r--r--). See:



    $ sudo ls -l /System/Library/CoreServices/RemoteManagement/ ote\ Desktop\


    -rw-r--r--  1 root  wheel  20773 Sep 27  2007 keyedobjects.nib

  • Michael Rosengarten Level 1 Level 1 (20 points)

    I could not repair permissions on my MBP or my wifes. This was with diskutility. Terminal did not seem to work either.What worked was cache cleaner lion.

    I think Apple has a bug to sort out with disk utility.


  • HansKaden Level 1 Level 1 (10 points)

    I have (had) the same problems. Thanks for "I0I0" to point to the procedure - it works fine. Hopefully Apple will fix this with the next update.

  • run.exe Level 1 Level 1 (0 points)

    This Disk Utility (RAID volume/Repair Permissions) bug is confirmed to persist in OS X Lion v10.7.2.

  • Phil_Mtl Level 1 Level 1 (5 points)

    Per IOIO's instructions, another way to get the disk identifier is to open disk utility and get info on your disk.


    I too confirm the problem persists in 10.7.2

  • tArre Level 1 Level 1 (85 points)

    I have a RAID appart from the System boot disk.


    When i run the commented from command line i get this error:


    # diskutil repairPermissions /Volumes/RAID1

    Error starting permissions repair for disk4 RAID1: Unable to determine the Mac OS X version on the targeted disk (-69831)


    There i have a lot of shared volumes, netboot images, network homes, etc... and i can't repair permissions there.

  • l0l0 Level 1 Level 1 (0 points)

    @tArre, when you say: "I have a RAID appart from the System boot disk." do you mean you RAID is not the boot disk of your Mac?


    Because in this case it is normal that you can't repair perissions:


    • On boot disk: you can repair disk and repair permissions.

    • On non-boot disk: you can ONLY repair disk.


    (that's the same as non RAID disk)

  • tArre Level 1 Level 1 (85 points)

    That's it IOIO!


    My system is in one drive, and i have two drives appart, with mirroring RAID 1.


    It's normal, but maybe not desired! because i have part of the system required files in the RAID, let's say "Netboot" images, User Data volume, etc...


    Someone has try to perform that repairing stuff with the "TechTool" from Apple Care?

  • Iain Simms Level 1 Level 1 (60 points)

    Terminal seems to be the only way to do this! Like everyone else, Disk Utility itself won't do anything, and returns zero errors. This definitely didn't happen under Snow Leopard, as I used to verify my RAID volumes on a weekly basis (because any minor errors that crept in tended to become serious if left unrepaired).


    I'm just wondering if there is some new distinction between verifying a disk and verifying a volume? Under Snow Leopard verifying a disk simply verified all volumes on that disk, now it appears to do something else. However, the verifyDisk command in the diskutil command line program will not operate on appleRAID or CoreStorage volumes.


    disktutil verifyVolume will however work just fine on any appleRAID volume, or unlocked CoreStorage volume (including a CoreStorage volume that spans an appleRAID =)

  • George Chew Level 2 Level 2 (250 points)


    I'm facing the same problem. Disk Utility can't perform verify/repair on my raid 1 boot volume. However, Drive Genius (3.1.2) is able to repair permissions on them.

  • Terry Fundak Level 2 Level 2 (150 points)

    Add me to the list of confused people...... Been using Disk Utility since who knows when 1980s..... the beginning and now with My RAID sets mounted on a MacMIni via Firewire 800 interface as a NON Bootable DAS, I cannot get DIsk Utility to even "verify" the disks let alone "repair" them.


    THis is scary....... I just converted this Snow Leopard Server 10.6.8 to a Lion Server 10.7.2.


    At the terminal, I'm running the verify command


       diskutil verifyVolume disk5


    on the RAID 1 two disk set and it does appear to be working ..... slowy.....


    I'm just really surprise Apple would not have fixed such a "basic" bug in the 10.7 Utilities....


    I will report back if I have further information of import....

  • ClassicII Level 3 Level 3 (830 points)



    Thanks for the terminal fixes so far. I hope this gets repaired in 10.7.3.

  • paultahoe Level 1 Level 1 (0 points)

    Add me to the list.. It doesn't seem like RAID volumes are that uncommon for Apple not to give some attention to this obvious bug still in 10.7.2.

  • adhuston Level 1 Level 1 (10 points)

    Fill out a Bug Report:



    The more people who report it the better the cances it gets resolved.

  • bonimac Level 1 Level 1 (20 points)

    in 10.7.3 still no RAID support.

    Since i'm not comfortable with terminal and have techtool pro, i found that v. 6.0.4 is able to repair permissions on my Mac mini server with 2 internal RAID-0 configurated drives.