Previous 1 124 125 126 127 128 Next 2,725 Replies Latest reply: Dec 5, 2013 6:55 AM by Nickofari Go to original post Branched to a new discussion.
  • Loerincz Level 1 Level 1 (0 points)

    Yes, i can see the progress bar, it advances, then it dissapears and i am still stuck at the grey screen with the turning ball. It does not load the OS. I could try to reinstall, but i do not want to lose the files i currently have there.

     

    The files i deleted are on the desktop under my user name. Any step by step instructions on how can i use terminal to put them back where they belong?

  • Redarm Level 4 Level 4 (2,580 points)

    Safe boot would have been the easiest option and I do hope you did give it enough time, as it often takes quite some time to start up that way.  Just don't be impatient.

    I don't think you would lose any files if you installed Lion again, you'd have to wipe first.

     

    I can start writing the Terminal instructions, but it will take a while - you try the safe start again and wait a bit longer?  Something like 15 min just to be on the safe side, while I type.

    When did the progress bar disappear (in which state, quarter done, half, three quarter, full?)

  • Redarm Level 4 Level 4 (2,580 points)

    Once you’ve booted into the recovery partition and see the window with “DiskUtility”, etc., go to the writing at the top and click on “Utilities”.  There you should find Terminal, which is a command line utility.

     

    The explanation:

    cd is short for “change directory”, where directory is a folder and symbolised by a “/“ (all without the quotes).

    ls stands for “list”

    mv stands for “move” and

    cp stands for “copy”

    \  introduces a special character, like a space, so a space would be “\ “ (followed by the space)

    sudo stands for “super doer” and gives you access to the protected/access limited folders like /Library/LaunchDaemons

    Try to avoid typos at all costs.  That’s all you need.

     

     

    How To:

    If you your files are on the Desktop, go there with the “change directory” command (if they are in a folder on the Desktop (and if your boot volume is called "Macintosh HD", which is the default) add the name of that folder to the end of the following command with a leading “/“ [without quotes], i.e. /foldername}:

    cd /Volumes/Macintosh\ HD/yourusername/Desktop

    (replace “yourusername” with your real username.  if your username has a space, precede the space with a “\” without the quotes)

    and hit enter after the command.

    Then just list them (to see what they are called exactly):

    ls -al

    Hit enter after every command

    You should now see the files (and folders) on your Desktop listed.  Folders start with a d

    (like in drwxr-xr-x)

    If it’s only files in

    /Library/LaunchDaemons

    /Library/LaunchAgents

    /Users/yourusername/Library/LaunchAgents

    that you have deleted (or moved), I would concentrate on this file:

    com.apple.remotepairtool.plist

    (forget about your user Library)

    Anything with apple in the name, put it back to where it was like this (replacing “yourusername” with your real one - also if the files are in a folder on the Desktop, you will have to put the foldername between /Desktop/ and the filename):

    sudo mv /Users/yourusername/Desktop/com.apple.remotepairtool.plist /Library/LaunchDaemons

     

    Hit enter after every command

    Edit:  with sudo it will ask for your administrator password (the one you use to log in).  Just type it (no bullet or anything visible will show you that you are actually typing it) and hit enter.

    Do you know what else you’ve moved and from where?  Hopefully nothing from /System/Library/LaunchDaemons or Agents?

    Try this one first and see if it boots.

     

    If you have any questions better ask them first, as you can muck things up even more by doing something very wrong (like moving files out of the System folder)

  • Loerincz Level 1 Level 1 (0 points)

    It dissapears at about one quarter done. I have waited for more than 15 mins. But nothing changed

  • Redarm Level 4 Level 4 (2,580 points)

    I am sorry, but if you try the Terminal solution, I won't be there to get you out of any trouble (not that you could get into much more) - bedtime for me.

    Hopefully somebody can take over.

     

    PS.  I forgot to put in the "hit enter" stages in my original instructions, but have since ammended it.

    There might also be a warning (using Terminal for the first time it asks you to be responsible when you use "sudo").  Just dismiss it.

     

    It dissapears at about one quarter done.

    I've heard of that one before, but don't know of a solution.  I'll have a look tomorrow.

  • Redarm Level 4 Level 4 (2,580 points)

    I'd suggest though that if you feel in any way uncomfortable with Terminal, do the install Lion instead.  But I would agree, seems overkill for moving a file or two.

    Don't forget to change the path (folder) according to where you took the file out of though.

  • Redarm Level 4 Level 4 (2,580 points)

    Sorry about these off topic posts, but they are a result of advice in this thread.

     

    Do you have File Vault enabled?  See here.

     

    Also depending on how big your disk is and how many files you've got it may take significantly longer to start up into safe mode.

    Also see here to start into safe mode without the shift key and with the "verbose" option.

  • maximillion82 Level 1 Level 1 (0 points)

    Same problem here, Snow Leopard 6-7 hours while only running Mac OS X Snow Leaopard, now with Lion right after startup (no programs open 3-4 hours. My next computer is a PC, Apple is loosing it's reliability, and that's what I paid the extra $1000 for, but since Apple no longer delivers I rather have a PC, then I can even run games. I already dumped my iPhone and it was a great decision.

  • sronco Level 1 Level 1 (0 points)

    Same problem
    , I'm upset!
    MacBook Pro 13-inch, Early 2011 with fresh install Lion and 4 hours of battery ... Apple does not fix the problem, do not want to buy a new model "without problems" because it seems that this is Apple's policy lately.

    10.7.3 anyone proved to see if it solves the problems of the battery?, because so far focus on solving other issues as if the problem did not exist.

    If 10.7.3 does not solve the problem back to Snow Leopard

     

     

     

  • Loerincz Level 1 Level 1 (0 points)

    Redarm wrote:

     

    Sorry about these off topic posts, but they are a result of advice in this thread.

    I also apologize for being off topic.

     

    Thanks Redarm for your help and sorry for replying so late, but I have a few other things on my plate now.

     

    Update: I tried to move the files, but did not manage.

     

    I tried to reinstall the OS, however, my MBP says that there is no Internet connection (weird, I plugged the same Ethernet cable that I used for my iMac and where the Internet was working perfectly!)

     

    Redarm: you asked if I have another Mac. I do have an iMac, however, it's running SL. Any thoughts? Could I use the iMac to start my MBP?

     

    And no, I do not have FileVault enabled (at least, I did not enabled it)

  • Redarm Level 4 Level 4 (2,580 points)

    You might be able to use target disk mode.  That way your computer in trouble behaves like an external hard drive and you could move the files:

    http://support.apple.com/kb/ht1661

    (if you get a "sorry the page can not be found" or something similar, just refresh)

     

    I think I may have given you the wrong command, as you'd be booted from a different partition.  I'm sorry, it was late.

    It should be (if it's on your Desktop):

    sudo mv /Volumes/Macintosh\ HD/Users/yourusername/Desktop/com.apple.remotepairtool.plist /Volumes/Macintosh\ HD/Library/LaunchDaemons

    Edit: not to forget to exchange "yourusername" for yours and to hit "enter".

  • MacMark88 Level 1 Level 1 (0 points)

    Enough with the off topic posts, please! This has nothing to do with battery life under Lion. There are plenty of other threads for restoring from backup, so use them not this!

  • Loerincz Level 1 Level 1 (0 points)

    Redarm wrote:

     

    You might be able to use target disk mode. 

    Solved, transfered files and restored from backup!

     

    Thanks Redarm for your valuable support and, again, apologize to all other ones for this OT.

  • MacMark88 Level 1 Level 1 (0 points)

    CT, this does not help. Basic information about how batteries work has been discussed many times in the 126 pages of posts regarding this problem that is specific with OS X Lion. We also don't need more suggestions on resetting SMC or deleting old applications, as that's been done already. There are very few who have resolved this problem other than reverting back to Snow Leopoard (as I have done). There are many who mysteriously do not have the problem or think they have fixed the problem but don't provide sound reasons for how they fixed it. Some don't realize they have a problem and apparently that is what Apple is banking on, maybe because they are too busy with IOS to be bothered with OSX fixes http://www.forbes.com/sites/timworstall/2011/12/11/apples-battery-problems-with- osx-10-7-lion-and-what-it-tells-us-about-apple-becoming-a-consumer-electronics-c ompany/