Previous 1 2 3 4 Next 93 Replies Latest reply: Jul 27, 2013 10:18 AM by Denbo_1 Go to original post
  • David_Purnell Level 1 Level 1 (10 points)

    @melodysnowleopard and others:

    I’m not sure if this is the source of your problem, but I and others found this fixed the problem of the “WebProcess” pop-up windows.


    Safari 5.1 and “WebProcess”: PROBLEM SOLVED

    The culprit is “Little Snitch”

     

    I am running OS 10.6.8 (Lion-ready). Yesterday, I installed the Safari updater from 5.0.5 to 5.1 . . . and am experiencing repeated and annoying pop-up windows for "WebProcessing."


    I found the culprit to be the third-party utility "Little Snitch" — which monitors outgoing internet connections. (http://www.obdev.at/products/littlesnitch/index.html).


    I solved the problem by upgrading (FREE) Little Snitch v2.0.x to v2.4 (for Snow Leopard and Lion).


    PROBLEM SOLVED.

  • ade_m Level 1 Level 1 (0 points)

    Hi David,

     

    As this threads about the Windows version of Safari (webkit2webprocess.exe), so it's probably not relevant about Little Snitch. However, it may be a generic thing. For example, I do have a 3rd party firewall product (Netpeeker) on my PC. No other applications have problems with it currently, but I have seen it be the cause of issues before now.

     

    If other users on the thread also have third-party firewalls, or network-type applications, then maybe theres a trend there.

  • BrownPolar Level 1 Level 1 (0 points)

    I was having the same problem, although not as bad or processor intensive as the other posts suggest.  I am using a Vaio Laptop running Windows XP (Final Service Pack).  In my case, the error messages only came up if I accessed, 'Reset Safari' or 'Preferences > Security or Privacy'. 

     

    The error message always was:

     

    "11d8: Webkit2WebProcess.exe - unable to locate component

    This application has failed to start because xpcom.dll was not found"

     

    Once you have okayed this, Safari 5.1 ran without any problems, although there were behavioural anomalies that were not there in previous versions of Safari.  For example I experienced so many bugs when using Gmail, and processes would suddenly use so much CPU that it was so irritating to do anything.  I had to wait till it all calmed down to even launch a software.

     

    In this particular computer, ‘xpcom.dll’ is a component of OpenOffice Suite and lives in OpenOffice Programme Folder.  It is a software created by Mozilla Partnership.  In my case or in the case of anyone running Windows XP and have OpenOffice installed, the problem is to do with ‘Webkit2WebProcess.exe’ not knowing where ‘xpcom.dll’ is.

     

    Safari does not give an option to add or look for a component, so unless you go through a potentially dangerous, Windows directory edit, there isn’t much anyone can do him or herself.

     

    In my searches, I also read that ‘Webkit2WebProcess.exe’ has been written using Microsoft Visual C ++ Code. In my case, I uninstalled all MS Visual C components a while ago, but some patches and updates of this still remains in my system, and even if you remove everything, the next Windows Update will add the patches again for stability.  Microsoft Visual C is an optional Windows Update for Windows XP, and some XP users may not have installed this at all, and therefore, may not experience these problems.  Similarly, those do not have OpenOffice on Windows XP may not experience this error.  However, those who run Safari on Windows Vista or 7 may have much more intensive problems including Safari crashes.

     

    I repeatedly sent bug reports to Apple using Safari Help Menu.  The one I sent last night was quite strongly worded.  Today, it took longer than usual to launch Safari, and the error message has now gone!

     

    So, I recommend to all of you to send bug reports to Apple, using Safari Help Menu. You don’t need to include screenshots or source code of the current page when you do this, but explain your problem clearly with the contents of the error messages you get.

     

    Safari, in my opinion is the simplest and most elegant browser available.  So, I think we should stick to it until Apple solves this problem in an update.

     

    Good luck.

  • Davey R Level 1 Level 1 (0 points)

    Don't think this is a Win7 issue as I'm affected on a Windows XP Pro (with final service pack) Dell Precision dual core laptop. I've only witnessed this when using Safari to access Google Maps and it has only started since updating to the latest version of Safari. Very annoying, even forcing me to start using Explorer again.

  • Brian Wiltshire Level 1 Level 1 (10 points)

    I agree this is probably not limited to Win7. I'd love to send bug reports to Apple, but Safari is totally non-responsive after launch. <sigh>

  • hel_len Level 1 Level 1 (0 points)

    Yes, in version 5.05 of process WebKit2WebProcess.exe is not present...

     

    after updating =>(5.1)

    Safari stays the same with a blank page and the spinning wheel as if it were loading the page :::CPU utilization 70%. If not close Safari, the system displays 'blue screen' (Win7/32)

     

    On XP/32 v. 5.1 still start. On Win7/32 - no.

       Probably without ' New Process Architecture ' ... interact with the web

     

    Thanks to those who unsubscribed on the problem, reduced time of agony and search. )

    I revert to Safari 5.05 until this is resolved.

  • hel_len Level 1 Level 1 (0 points)

    On sites to look in last turn... )

     

    All that is established Apple preliminary loaded on a computer, for example

    C: \ProgramData \Apple Computer \Installer Cache \Safari *

    in the form of

    Safari.msi (-  installation of the chosen (old) version without questions)

    SetupAdmin.exe

     

    folder Safari 5.33.21.1 - v 5.05 and etc

  • ncodo Level 1 Level 1 (0 points)

    I`m not using a Apple machine. I`m using Safari 5.1 (75.34.50), runningWindows XP on PC and the hotmail doesn´t work. I can´t ‘send’ any message –only read. On the other hand, when I´m running IE v.8, the hotmail doesn´twork. Today I´ve received a new version of iTunes system and I cound´t updated –“error on whritting memory”. Now I can´t synchronize my iPod.  I did run the CMD “netsh winsock reset “ and the problemreains – doesn´t work!

  • Jimena Chic Level 1 Level 1 (5 points)

    Exactly the same Win7, and XP-Pro either.

  • Jimena Chic Level 1 Level 1 (5 points)

    Exactly the same Win7, and XP-Pro either.

  • Jimena Chic Level 1 Level 1 (5 points)

    Me either in both systems; 7 and XP.

  • hel_len Level 1 Level 1 (0 points)

    I have an old Macintosh and problems of its updatings any more do not concern...

     

    Everything that is written by me in this topic applies to Safari on Win7/32

    ( https://discussions.apple.com/message/15798343#15798343

    https://discussions.apple.com/message/15802086#15802086 )

     

    After return on version Safari 5.05 (saved on a PC) errors during the launch iTunes and recommendation to remove and installing anew iTunes (downloaded from the site of Apple).

     

    Now :::Safari all loads, in iTunes all was saved for synchronization with ...

     

    ... Now I can´t synchronize my iPod. I did run the CMD “netsh winsock reset “ and the problemreains – doesn´t work!

     

     

    This is not a problem connecting PC to the Internet.

  • dr_gamer Level 1 Level 1 (0 points)

    Hi: I have solved this issue downgrading to safari 4, first you've to uninstall the 5 version.

    Now, my safari and itunes store work fine and smoothly.

     

    Here is the link for the safari 4:

    http://appldnld.apple.com.edgesuite.net/content.info.apple.com/Safari4/061-4663. 20090224.Fret6/SafariSetup.exe

     

     

    I hope apple fix the webkit issue in future upgrades.

     

     

    I've windows 7 home premium 64-bit

  • The hatter Level 9 Level 9 (60,380 points)

    I thought maybe you had tried a nightly build to see if that made a difference ;-)

     

    WebKit Nightly Builds

     

    The WebKit Open Source Project

     

    Surfin' Safari - The WebKit Blog

  • hel_len Level 1 Level 1 (0 points)

    Heh.

    Thanks for links certainly.

     

    True the time spent on "dancing with tambourines" on search of a problem and restoration of work of programs does not inspire on experiments with Nightly Builds  ヅ

    Such impression, that Apple has enticed the best experts Microsoft  ﻬ(

    P.S. imho

Previous 1 2 3 4 Next